Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com

Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com (http://www.camaro5.com/forums/index.php)
-   Forced Induction - V8 (http://www.camaro5.com/forums/forumdisplay.php?f=74)
-   -   Aeromotive A1000 Stealth Fuel System Issues (http://www.camaro5.com/forums/showthread.php?t=255494)

Matt @ RX 11-19-2012 10:20 AM

Quote:

Originally Posted by ayousef (Post 5822081)
isnt that a dual pump set-up? That is also asking for trouble, one pump fails and kaboom goes the motor.

I think most people are having problems due to poorly designed kits/wiring and not having the pump speed controller which is a must with an A1000 or bigger on the street.

I have EVERYTHING that is required (And then some in my opinion), including 10 gauge wiring, direct relay to battery, A1000 regulator, etc.

urr2slo 11-19-2012 10:54 AM

I have been running ADM's twin pump setup for almost 3 years and 45k miles with no issues. I'm pushing just over 700 rwhp.
I've heard of a lot of issues with the Aeromotive pumps lately. I have built or been involved with a lot of Camaro high horsepower builds and I either use the ADM twin or the ZL1 with ADM's fuel pump controler, depending on the horsepower level.
Check with ADM, Andy's fuel systems just work, You never hear of an unhappy customer with ADM products or builds.

TCAT 11-19-2012 10:57 AM

I agree with the above post. I have the ADM twin fuel pump set-up and its been fantastic. Two thumbs up to all the ADM crew for making a depending set-up.

Matt @ RX 11-19-2012 12:09 PM

Unfortunately I have spoken to ADM and LPE about using their respective systems on my car, I'll just be out of the power range that would hold. Damn!

- Matt

BullF-16 11-19-2012 12:22 PM

Quote:

Originally Posted by Matt @ RX (Post 5823952)
Unfortunately I have spoken to ADM and LPE about using their respective systems on my car, I'll just be out of the power range that would hold. Damn!

- Matt


I hear ya! I have the LPE twin pump now. My car is down getting the new motor installed as well as the full return style Aeromotive fuel system with Stealth eliminator pump, speed controller etc, etc. I am pinging about this system going in correctly. Aeromotive assures me it will work fine! Guess we will see!

realsquash 11-19-2012 01:52 PM

Quote:

Originally Posted by Matt @ RX (Post 5823952)
Unfortunately I have spoken to ADM and LPE about using their respective systems on my car, I'll just be out of the power range that would hold. Damn!

- Matt

Our setup flows twice as much as those, and the A1000 setup.... All is not lost!

Andy

gmg69 12-05-2012 12:02 AM

thread update reply...
 
I stumbled on this thread and couldn't help but keep reading, as I have the internal A1000 as well. In fact, I'm on my 3rd one.

1st pump: siphon tube failure (same as shown in pics posted here)

2nd pump: failed to pump consistantly in hot weather. Apparently the return fuel was vapor locking (getting HOT!)

3rd pump: So far so good. Now I have a FPCM hooked up to reduce pump noise and prolong the life.

My 2 cents on these: The A1000 pump is a powerhouse unit that will support the 1000hp motor no problem. BUT... you have to have it plumbed and wired perfectly for it to not cause issues. With my dilemmas on these pumps, Jared at Aeromotive has very supportive in trying to make things right and get me going on the reliabililty track. He also recommends an inline fuel cooler on the RETURN SIDE. I haven't done that yet. If I can't get the reliability from this 3rd pump and controller...I'm moving on to other options.

Time will tell.

incon3037r 12-05-2012 03:07 AM

Quote:

Originally Posted by gmg69 (Post 5880492)
I stumbled on this thread and couldn't help but keep reading, as I have the internal A1000 as well. In fact, I'm on my 3rd one.

1st pump: siphon tube failure (same as shown in pics posted here)

2nd pump: failed to pump consistantly in hot weather. Apparently the return fuel was vapor locking (getting HOT!)

3rd pump: So far so good. Now I have a FPCM hooked up to reduce pump noise and prolong the life.

My 2 cents on these: The A1000 pump is a powerhouse unit that will support the 1000hp motor no problem. BUT... you have to have it plumbed and wired perfectly for it to not cause issues. With my dilemmas on these pumps, Jared at Aeromotive has very supportive in trying to make things right and get me going on the reliabililty track. He also recommends an inline fuel cooler on the RETURN SIDE. I haven't done that yet. If I can't get the reliability from this 3rd pump and controller...I'm moving on to other options.

Time will tell.

I've had all of these problems as well. Aeromotive directions to wire the FPCM were wrong and when my mechanic contacted them to find the correct way, it took several days and being told several different wrong ways to wire it before the correct information was given. Then we were given the run around on which MSD tach adapter that was needed to find a signal for the FPCM. MSD would say to contact Aeromotive and vice versa.

Currently everything is working fine with the addition of the FPCM and MSD tach box. I was not advised on installing a cooler on the returne side but will do so. The fuel pump appears to be nicely made, but the trouble and all of the additional parts needed to install makes it a head ache. If this new unit doesn't hold up, I'll move onto the Squash setup.

It also sucks when you have to pay labor to remove and install a new pump because it was damaged from the manufacturer.

MANNYS2SS/RS 12-05-2012 08:31 AM

Quote:

Originally Posted by incon3037r (Post 5880737)
It also sucks when you have to pay labor to remove and install a new pump because it was damaged from the manufacturer.

Thats why I installed an access door under the seat. It takes me 15 min.

lexlueger 12-06-2012 09:26 AM

Any high HP cars running the internal A1000 without issues?

pyr0b0y 12-06-2012 05:06 PM

Quote:

Originally Posted by MANNYS2SS/RS (Post 5880981)
Thats why I installed an access door under the seat. It takes me 15 min.

Any pics? I talked to Jesse at Aeromotive and that's what he recommended.

One thing I'm jealous of on the mustang lol

MANNYS2SS/RS 12-06-2012 07:23 PM

Quote:

Originally Posted by pyr0b0y (Post 5886793)
Any pics? I talked to Jesse at Aeromotive and that's what he recommended.

One thing I'm jealous of on the mustang lol

There's several pic's posted on this thread. http://www.camaro5.com/forums/showthread.php?t=256182.

stangkilr 12-06-2012 09:39 PM

Never had good luck with aeromotive pumps. Squash perf. For me

incon3037r 12-07-2012 06:50 AM

Quote:

Originally Posted by MANNYS2SS/RS (Post 5880981)
Thats why I installed an access door under the seat. It takes me 15 min.

I requested this be done and it wasn't. I was also waiting on an access door cover that Squash mentioned making on the G8 forums.


All times are GMT -5. The time now is 09:51 AM.

Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.