Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com

Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com (http://www.camaro5.com/forums/index.php)
-   Cosmetics and Lighting Modification Discussions (http://www.camaro5.com/forums/forumdisplay.php?f=37)
-   -   AAC makes it right! Sort of! (http://www.camaro5.com/forums/showthread.php?t=155566)

Inferno LSX 06-28-2011 10:55 PM

AAC makes it right! Sort of!
 
So I bought a set of AAC side markers at C5F2. One got water in it and it was mess up.

http://tapatalk.com/mu/4c5f2dde-a030-1077.jpg
So I was B!tch!ng on another thread about my dissatisfied about thier product. Well I got a PM for someone at AAC and they were very professional about it and sent me out a brand new set. Not a cent out of my pocket and I got the new ones with some revised silicone.
http://tapatalk.com/mu/4c5f2dde-a0f4-abe7.jpg
Well I was trying to figure out how water got in the original one and the side marker was about 1/3 full of water but none would drain out of any sides. Then I noticed the plug on the back was a bit loose and I gave it a twist and bam all the water came out. http://tapatalk.com/mu/4c5f2dde-a170-9ba1.jpg
So I noticed on the new ones there isn't any additional sealant to this plug, well IMO should be sealed, because I'll never change out anything. So I hope this doesn't void my warranty, but I added silicone to the outside to help seal the plug.
http://tapatalk.com/mu/4c5f2dde-a1f4-96c0.jpg
http://tapatalk.com/mu/4c5f2dde-a206-6966.jpg
I hope this helps as I don't want to go through this again and maybe this helps some other AAC side markers customers.

GB EB 06-29-2011 08:40 AM

wow... how did you manage that...
every time one of my aac products goes bad I have to uninstall, put factory item back in, ship at my expense the bad part and wait for the return, then reinstall...

I like how they handled your issue much better... what is your secret?

SSTG 06-29-2011 08:48 AM

Wish my experience with them was as good also. I have PM' d Jonathan twice with no reply. Still have not received my Plasmas.

benradmo 06-29-2011 09:50 AM

I don't get why they would make the customer pay for shipping if their product fails???

vafinest25 06-29-2011 10:04 AM

That's funny that these side markers had this issue, I have the IOM and have the same problem. I called Jonathan and told him the issue and yes I had to pay and send mine back but one of my rear led's went out. But they called and explained that they are gonna add extra silicon around the light. But that makes sense about the plug area being the entry point of water, seeing how when I held the light up side down to get water out noon came out. So they sent mine out today and I'll do like the other guy suggest and put silicon around the plug housing.

Jonathan@AACstyle.com 06-29-2011 10:04 AM

Quote:

Originally Posted by SSTG (Post 3401332)
Wish my experience with them was as good also. I have PM' d Jonathan twice with no reply. Still have not received my Plasmas.

I sent you a PM back. Unfortunately with choosing to ship the item USPS there is not definite delivery date and the Priority service does have delivery confirmation but not much information in the travel of the package like UPS does.

~Stacy~ 06-29-2011 10:10 AM

Quote:

Originally Posted by Inferno LS3 (Post 3400331)
So I bought a set of AAC side markers at C5F2. One got water in it and it was mess up.

http://tapatalk.com/mu/4c5f2dde-a030-1077.jpg
So I was B!tch!ng on another thread about my dissatisfied about thier product. Well I got a PM for someone at AAC and they were very professional about it and sent me out a brand new set. Not a cent out of my pocket and I got the new ones with some revised silicone.
http://tapatalk.com/mu/4c5f2dde-a0f4-abe7.jpg
Well I was trying to figure out how water got in the original one and the side marker was about 1/3 full of water but none would drain out of any sides. Then I noticed the plug on the back was a bit loose and I gave it a twist and bam all the water came out. http://tapatalk.com/mu/4c5f2dde-a170-9ba1.jpg
So I noticed on the new ones there isn't any additional sealant to this plug, well IMO should be sealed, because I'll never change out anything. So I hope this doesn't void my warranty, but I added silicone to the outside to help seal the plug.
http://tapatalk.com/mu/4c5f2dde-a1f4-96c0.jpg
http://tapatalk.com/mu/4c5f2dde-a206-6966.jpg
I hope this helps as I don't want to go through this again and maybe this helps some other AAC side markers customers.

Wow Thanks Buddie:thumbsup: I got a updated marker also. I didn't have time to install it yet so I will DEFINATLEY too this before I plug her in:D

Inferno LSX 06-29-2011 12:01 PM

Yah this did seem very weird. There isn't a secret. I was just on a few threads about AAC and I was venting. I never called AAC or PM'd anyone. Someone at AAC PM'd me, we went back and forth. This person asked what could be done to make it right. I gave them two options, one refund, two was send me a new part first because I didn't want to install stock ones. They did better and sent me a whole new set that had more silicone on the edges. I give them credit on this, they did do the right thing to make it better.
Will I again buy AAC products? Well if this is how they take care of me then yes maybe someday I'll get the headlight halos.

CyberDan 06-29-2011 12:03 PM

That sucks that there has to be additional sealant put on it... It should come fully sealed like the factory side marker.

Inferno LSX 06-29-2011 12:11 PM

Quote:

Originally Posted by benradmo (Post 3401562)
I don't get why they would make the customer pay for shipping if their product fails???

I didn't have to ship back the bad set. Guess I'll add silicone to them and keep the 3 good ones for spares.

CyberDan 06-29-2011 01:03 PM

I wonder if plastidipping the backside of the sidemarker will help. That stuff is used for waterproofing... Might give that a shot

Inferno LSX 06-29-2011 02:47 PM

Quote:

Originally Posted by CyberDan (Post 3402583)
I wonder if plastidipping the backside of the sidemarker will help. That stuff is used for waterproofing... Might give that a shot

That ain't a bad idea. just mask it off and paint. there also is that "as seen on tv" sealant stuff too.

liquidsmoke 06-29-2011 06:19 PM

Quote:

Originally Posted by 2011 2SS/RS (Post 3401299)
wow... how did you manage that...
every time one of my aac products goes bad I have to uninstall, put factory item back in, ship at my expense the bad part and wait for the return, then reinstall...

I like how they handled your issue much better... what is your secret?

The secret is to complain in a public forum. Always does the trick.

Hutch52 07-05-2011 04:54 PM

Water in the sidemarker
 
Quote:

Originally Posted by benradmo (Post 3401562)
I don't get why they would make the customer pay for shipping if their product fails???

AAC wants to charge me $60.00 for one sidemarker and credit me back whwhen they receive the defective marker back. What to say the other 3 won't leak, they should replace all 4 that have been sealed right. :mad0260::mad0260:
I don't want to have the same problem again. :readthethread:

Inferno LSX 08-13-2011 02:53 AM

Well it seems the new set I got from AAC didn't even make it a full 2 months with out any problems. The other night while at the track someone who was on the fence about getting these side markers noticed about 3 LEDs out on one of the new side markers. They flicker for about a minute then either stay on or off till the next time I turn the car off. So I will have to deal with this someday. I figure I'll send my OEM ones to showstopper then get a refund from AAC. I was even considering getting new halos for the headlights and fog lights. They make it hard to trust any of thier products.

TheHorse13 08-13-2011 07:18 AM

I've never ordered a single item from AAC, however, after reading all the threads on this site I'm left with the impression that they sell poor quality items. Compared to the other vendors, who I rarely see a complaint about, AAC is typically the subject of posts like this. If I purchase a part, I expect it to be OEM quality or better.

Are you annoyed that you had to research and engineer a fix for a faulty seal design upon receiving your new lights?

Inferno LSX 08-13-2011 12:36 PM

Quote:

Originally Posted by TheHorse13 (Post 3610591)
I've never ordered a single item from AAC, however, after reading all the threads on this site I'm left with the impression that they sell poor quality items. Compared to the other vendors, who I rarely see a complaint about, AAC is typically the subject of posts like this. If I purchase a part, I expect it to be OEM quality or better.

Are you annoyed that you had to research and engineer a fix for a faulty seal design upon receiving your new lights?

Save your money. I wouldn't recommend them to anyone. What I did to seal them has caught on as others are sealing them this way too. It wasn't water that is messing up my new set. Just some bad LEDs. The funny thing is, I also have the CCFL afterburner halos and I've had the inverter go bad before. The ones they use are the EXACT same cheap ones you can find on eBay. The cost of a new one on eBay is usually cheaper than the cost to ship your defective one back to AAC. Some of the eBay sellers give free shipping.


---
I am here: http://maps.google.com/maps?ll=33.847420,-118.361500

Haole 08-13-2011 06:00 PM

I ordered sidemarkers from AAC. As like many of you one of them got water in it. I had the choice to return it and they would send a new one or they send me one and charge me $60 until I sent my bad one back.
I chose the later option. It took me about 2 weeks to get credited back after they received the bad one. I wasn't the least bit happy it took so long and not sure if I will give them anymore of my business. Especially after reading others weren't out of pocket at all to have new ones sent to them.

I don't mean to bash on them, just wondering why such a difference in their return/exchange policy.

GB EB 08-13-2011 08:57 PM

Just got my replacement marker last week.

It appears they've corrected the problem with more silicone or whatever.

Things are lookin' up.

Inferno LSX 08-14-2011 02:32 PM

Quote:

Originally Posted by 2011 2SS/RS (Post 3613135)
Just got my replacement marker last week.

It appears they've corrected the problem with more silicone or whatever.

Things are lookin' up.

I hope it works out for you. I'm gonna have to remove all the silicone I added to mine. I think I'm just gonna ask for a refund. I'll try the showstopper ones I guess.


---
I am here: http://maps.google.com/maps?ll=33.847363,-118.361475


All times are GMT -5. The time now is 10:13 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.