Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com

Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com (http://www.camaro5.com/forums/index.php)
-   Vendor and Seller review / feedback / experiences (http://www.camaro5.com/forums/forumdisplay.php?f=75)
-   -   BMR (http://www.camaro5.com/forums/showthread.php?t=290065)

c_LoW29 04-18-2013 07:08 AM

BMR
 
A while ago I purchased a set of BMR's drop springs. Orginally it was the 1.4 front and 1.0 rear. The problem with the front springs is the dead coils would rub under load going over bumps which eventually removed the red paint from that area. I called them and they send me a set of the 1.0 front springs to research why they were rubbing. Mind you I have paid for 2 alignments already to adjust to each set. I have been in constant contact with them for 9 months regarding this issue and they would only tell me that there technicians were looking into it. They did offer to pay for my alignment which is all good and dandy yet the front dead coils still rub to the point where it started removing the coating and making noise. They also offered to give me a discount on another part from them which to me doesnt seem like a good deal considering they havent fixed the first problem. Why would I want another part from their company. In the near future I will be taking these off for coil overs and trashing these I wouldnt even try to sell these to a member knowing the problems they have. I made this thread to warn anyone else that if they purchase a product from this company with issues dont expect to get them resolved in this lifetime. I held out on making this thread in hopes that they would fix this problem but have not contacted me or tried to resolve the issue.

Here is a link to my initial thread showing everyone the issues.

http://www.camaro5.com/forums/showthread.php?t=240098

As you can see they dont even attempt to defend themselves at all or even provide and explanation.

family man 04-18-2013 08:17 AM

In the mean time, you could use some split rubber hose to cover the coils, use a zip tie to hold the ends.

c_LoW29 04-19-2013 07:16 AM

Sent BMR technicians an email and a PM still no response, seems like they just dont care if they get bad feedback.

SC2150 04-19-2013 09:39 AM

They are usually pretty good at responses when needed. Try calling direct and ask for Kyle, he is the Camaro expert. This is not the norm w/them. Good luck!

c_LoW29 04-19-2013 09:51 AM

Quote:

Originally Posted by SC2150 (Post 6442399)
They are usually pretty good at responses when needed. Try calling direct and ask for Kyle, he is the Camaro expert. This is not the norm w/them. Good luck!

Thanks for the advice Tracey, but I have been calling him often for 9 months and he always says that his techs are looking into it. I dont think it takes 9 months to look into something.

c_LoW29 04-20-2013 08:42 AM

Where are you at BMR. 9 months with no response or resolution is pretty pitiful.

429 04-20-2013 09:38 AM

There isn't a problem with your springs, I don't see what there is to resolve. They're designed to stack coils, thats' how they work... put a sleeve on it if the rub bothers you,

c_LoW29 04-20-2013 10:03 AM

Actually there should be a sleeve but I'm not going to spend money on something they designed that causes rubbing noise. I have asked them to send me some and they don't. Your free to send me some too if you wish but I doubt you'll spend money on a problem that isn't your fault.

AdamZ 04-21-2013 06:42 AM

I mean they sent you a free set of springs and they payed for the alignment. Offered discounts on other merchandise...What else do you want them to do? Mine are perfectly fine. I have the 1.4 fronts/1.0 rears. You simply have a bad set I guess. I think they have handled it fine. If you don't like their product then move on.

Bad Dad 04-21-2013 06:47 AM

Quote:

Originally Posted by 429 (Post 6446303)
There isn't a problem with your springs, I don't see what there is to resolve. They're designed to stack coils, thats' how they work... put a sleeve on it if the rub bothers you,

Damn I cant hear anything Rub:der:

c_LoW29 04-21-2013 07:46 AM

2 bad sets huh

c_LoW29 04-26-2013 09:06 AM

BMR where are you at?

SGOS252382 05-04-2013 10:15 AM

Interesting
I've always gotten quick, excellent customer service (by phone) from BMR (run several of their suspension parts on my car).

StephenS_84 05-05-2013 02:28 AM

Quote:

Originally Posted by c_LoW29 (Post 6471848)
BMR where are you at?

Move on with your life. Put a sleeve on them and quit crying about the problem. Should you have to do that NO, but you do. It will cost maybe $5. At this point your probably harassing them, so they probably don't care. You seem to be a customer that will never be satisfied. Buy the sleeve or buy a different brand. I've never had a problem with BMR and have quite a few suspension upgrades on my car.

tandtperformance 05-05-2013 08:31 PM

He did do something diff I took care of it for him

c_LoW29 05-13-2013 09:18 AM

Quote:

Originally Posted by StephenS_84 (Post 6506440)
Move on with your life. Put a sleeve on them and quit crying about the problem. Should you have to do that NO, but you do. It will cost maybe $5. At this point your probably harassing them, so they probably don't care. You seem to be a customer that will never be satisfied. Buy the sleeve or buy a different brand. I've never had a problem with BMR and have quite a few suspension upgrades on my car.

Tim at TandT did take care of me thanks for the advice :noidea: I guess but on another note your signature does suit you well.


All times are GMT -5. The time now is 10:56 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.