Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com

Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com (http://www.camaro5.com/forums/index.php)
-   Camaro Issues / Problems | Warranty Discussions | TSB and Recalls (http://www.camaro5.com/forums/forumdisplay.php?f=70)
-   -   ISSUES with YOUR CAMARO! (http://www.camaro5.com/forums/showthread.php?t=30992)

JewelZ 07-05-2009 09:17 PM

ISSUES with YOUR CAMARO!
 
Ok, So I'm tired of seeing people with issues this far into production and after so much qaulity control! WTF, right? But I've witnessed worse with 1st year model from other makers. So somone earlier had a post saying something about making a CHECK LIST for issues with our new cars(to be in my case). So here we go people let's start posting all known issues that we as new car buyers/owners need to beware of and check on when we recieve/'d our car(s). Please I would appreciate it if people did not start random discussion I would like to take this thread seriously and make a solid CHECK LIST this will help all people who actually care about their new Camaros. THANK YOU...

-JewelZ-

CHECK LIST :

- BATTERY CABLE(MOSTLY V8's)
- OIL LEAK
- DIGITAL SPEEDO INACCURATE
- PULLY SHAKING
- BROKEN TRANNY
- IGNITION MECHANISM ISSUE WITH KEY GETTING STUCK IN CAR
- RS tail lights installed (all 4 of them).
- Rocker Panel aligned with body and clipped in correctly
- A pillar trim not loose and falling off.
- Bumper rub with body.
- Trunk opens with switch and remote
- Correct speedo/tach gauge ring color
- Ambient lighting on drivers door as bright as passenger door
- Doors gaps /alignment
- Dirt/bubbles in rally stripes
- Halo's work correctly and match in brightness.
- Door panel not scratched from seat belt.
- Door sill trim not loose or coming up.
- Rear spoiler not loose.
- shift knobs wearing out extremely fast could be faulty material
- AC system stops blowing cold air in random durations, most likely blockage in AC drainage
- clunking noise in changing gears
- trunk opens with remote and laser cut key
- USB/aux work
- rear spoiler is installed correctly
- pillars are snapped on right
- breaks don't squeek
- GFX installed correctly
- wheels are tires in good condition
- check for damage in the interior, basic procedure
- check the locking mechanism of both doors
__________________

JewelZ 07-05-2009 09:27 PM

ok? I'll start it out...

OIL LEAK...
check thread for details
http://www.camaro5.com/forums/showthread.php?t=30545

camaro67 07-05-2009 09:34 PM

car is purrfect

JewelZ 07-05-2009 09:36 PM

Quote:

Originally Posted by camaro67 (Post 651213)
car is purrfect


Most of them are perfect, hopefully mine will be. But I hope this thread will help us all make 110% sure that it is 'purrfect'.

tribone 07-05-2009 09:36 PM

Bottom pulley shakes and needs replacement per dealer. Will post video tomorrow.

JewelZ 07-05-2009 09:39 PM

Quote:

Originally Posted by tribone (Post 651218)
Bottom pulley shakes and needs replacement per dealer. Will post video tomorrow.

Keep in touch.

JewelZ 07-05-2009 09:39 PM

Digital Speedometer is off...

see thread for details - http://www.camaro5.com/forums/showthread.php?t=30979

Sharpe62 07-05-2009 10:37 PM

There are gonna be issues that people will come across at some point.. its completely natural for any car during its first year of production

JewelZ 07-05-2009 10:42 PM

ofcourse... but we should still make a solid check list...

speeflo 07-05-2009 10:45 PM

broken transmission i guess, will find out next week!

Vash 07-05-2009 10:45 PM

What pulley shaking?

Barry626 07-05-2009 10:57 PM

Quote:

Originally Posted by Sharpe62 (Post 651397)
There are gonna be issues that people will come across at some point.. its completely natural for any car during its first year of production

There will be issues with all cars during all years of productions.
If our own lives don't last forever surely our cars won't either!

Vash 07-05-2009 11:04 PM

Quote:

Originally Posted by tribone (Post 651218)
Bottom pulley shakes and needs replacement per dealer. Will post video tomorrow.

You talking about the belt tensioner?

qbert48 07-05-2009 11:15 PM

car is flawless mechanically with the first k behind it. we shall see

Rockytophummer 07-05-2009 11:24 PM

No performance issues. Only problem Ive had so far is the SS emblam on my trunk is starting to become loose. They ordered new one. I noticed this the day I took my car back to get stripes installed so dont know if he could of possibly got something caught on emblem to get it loose or if this could possibly be a problem with some? 2SS IOM not RS so its the white SS emblem just wanted to put that in there also in case it matters. But other than that my car is flawless and wish I could spend all my time in her. To everyone who is yet to get your car congrats when you get the call and enjoy!

67CamaroRS 07-05-2009 11:25 PM

Ignition Key and Lock Mechanism
 
It seems so simple, but after buying my car, I put the Key in the Ignition and started it right up and drove it home to my Garage. Whereupon, I was able to turn the key far enough to turn the Engine off, but not the Accessories.
I, also, was not able to turn the key to the last stop in order to turn off the Accessories and pull the Laser Cut Key out of the Ignition Lock. Yes, I put the Automatic Transmission in Park and turned the steering wheel, but the key would still not come out. Because the car could be started right up, I left it locked up in the Garage overnight. The Battery did not run down, and I was able to drive it back to the dealer the next day which was last Tuesday. Now I and my dealers service dept is waiting for an Ignition replacement part which is not to be found in the system. None are available from the Factory and None seem to be available from the Manufacturer. I am awaiting a call back from GM's Western Districk Manager this week with an answer and hopefullly a resolution to this problem. So Far One week with the Car in the shop. Hopefully I think I am the only Camaro Owner in the US with this problem right now.

Halo2 07-05-2009 11:34 PM

Here's some of the items from the delivery check list that I started for myself. These are based upon items covered in this forum reported from others.

RS tail lights installed (all 4 of them).
Rocker Panel aligned with body and clipped in correctly
A pillar trim not loose and falling off.
Bumper rub with body.
Trunk opens with switch and remote
Correct speedo/tach gauge ring color
Ambient lighting on drivers door as bright as passenger door
Doors gaps /alignment
Dirt/bubbles in rally stripes
Halo's work correctly and match in brightness.
Door panel not scratched from seat belt.
Door sill trim not loose or coming up.
Rear spoiler not loose.

ElManny 07-05-2009 11:35 PM

not sure if mine is a issue or not but when i stop or hit a big bump, the auto shifter like moves a lil. like if i have my hand behind it a 1/4 in it will move and touch my hand. the performance is great but it just moves

JewelZ 07-05-2009 11:35 PM

Quote:

Originally Posted by 67CamaroRS (Post 651522)
It seems so simple, but after buying my car, I put the Key in the Ignition and started it right up and drove it home to my Garage. Whereupon, I was able to turn the key far enough to turn the Engine off, but not the Accessories.
I, also, was not able to turn the key to the last stop in order to turn off the Accessories and pull the Laser Cut Key out of the Ignition Lock. Yes, I put the Automatic Transmission in Park and turned the steering wheel, but the key would still not come out. Because the car could be started right up, I left it locked up in the Garage overnight. The Battery did not run down, and I was able to drive it back to the dealer the next day which was last Tuesday. Now I and my dealers service dept is waiting for an Ignition replacement part which is not to be found in the system. None are available from the Factory and None seem to be available from the Manufacturer. I am awaiting a call back from GM's Western Districk Manager this week with an answer and hopefullly a resolution to this problem. So Far One week with the Car in the shop. Hopefully I think I am the only Camaro Owner in the US with this problem right now.

This happened to my friends Accord. Get into your car turn it on, put it in drive and see if takes a while for the tranny to kick into drive. Drive it around for 5 minutes, once you park it make sure your wheels are straight and briskly put the shift into park. The key should come out. If this happens than your transmission is not aligned properly.

JewelZ 07-05-2009 11:39 PM

Quote:

Originally Posted by Halo2 (Post 651548)
Here's some of the items from the delivery check list that I started for myself. These are based upon items covered in this forum reported from others.

RS tail lights installed (all 4 of them).
Rocker Panel aligned with body and clipped in correctly
A pillar trim not loose and falling off.
Bumper rub with body.
Trunk opens with switch and remote
Correct speedo/tach gauge ring color
Ambient lighting on drivers door as bright as passenger door
Doors gaps /alignment
Dirt/bubbles in rally stripes
Halo's work correctly and match in brightness.
Door panel not scratched from seat belt.
Door sill trim not loose or coming up.
Rear spoiler not loose.

THANX HALO!

JewelZ 07-05-2009 11:41 PM

Quote:

Originally Posted by ElManny (Post 651552)
not sure if mine is a issue or not but when i stop or hit a big bump, the auto shifter like moves a lil. like if i have my hand behind it a 1/4 in it will move and touch my hand. the performance is great but it just moves

Make a thread on it and see what people have to say about this. It doesn't seem normal, but as long as your car is running great at the moment I guess that's all that matters now. But I would hate for something to happen to your car later down the road.

tribone 07-05-2009 11:42 PM

Quote:

Originally Posted by Vash (Post 651488)
You talking about the belt tensioner?

Hmm. I don't know. It's the big one in the center towards the bottom. I didn't notice it until one of my co-workers did. So I went to get my oil change at 500 miles and asked the dealer to look at it and they told me that they would order the part and let me know when they got it. I will take a video and post it tomorrow. Hopefully it's nothing serious. By the way I have a 2SS Automatic.

sewwhut 07-05-2009 11:57 PM

:paddle:
Quote:

Originally Posted by Rockytophummer (Post 651521)
No performance issues. Only problem Ive had so far is the SS emblam on my trunk is starting to become loose. They ordered new one. I noticed this the day I took my car back to get stripes installed so dont know if he could of possibly got something caught on emblem to get it loose or if this could possibly be a problem with some? 2SS IOM not RS so its the white SS emblem just wanted to put that in there also in case it matters. But other than that my car is flawless and wish I could spend all my time in her. To everyone who is yet to get your car congrats when you get the call and enjoy!

did it look like some1 was trying to peel it off ????:paddle:

67CamaroRS 07-06-2009 12:06 AM

Quote:

Originally Posted by JewelZ (Post 651553)
This happened to my friends Accord. Get into your car turn it on, put it in drive and see if takes a while for the tranny to kick into drive. Drive it around for 5 minutes, once you park it make sure your wheels are straight and briskly put the shift into park. The key should come out. If this happens than your transmission is not aligned properly.

This procedure sounds so simple, I would have thought that the Technicans(Mr GoodWrench) at the Chevrolet Dealership would have dome this procedure the first day they had it. However, It still sits and even they can not get the key out of the Ignition Lock. They are waiting on a replacement part that can not be found.:mad0259: Hopefully I will get an Answer from GM this week as they have opened a casefile on the problem.

JewelZ 07-06-2009 12:07 AM

Quote:

Originally Posted by sewwhut (Post 651592)
:paddle:
did it look like some1 was trying to peel it off ????:paddle:


Oh snap, some people would!


All times are GMT -5. The time now is 11:27 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.