Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com

Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com (http://www.camaro5.com/forums/index.php)
-   Wheels and Tires Talk Sponsored by The Tire Rack (http://www.camaro5.com/forums/forumdisplay.php?f=28)
-   -   steering wheel shakey after new wheels (http://www.camaro5.com/forums/showthread.php?t=310237)

000montoya 07-30-2013 07:34 PM

steering wheel shakey after new wheels
 
i just installed the zl1 wheels from factory reproductions. i had the tsw's and used the same tires but now the steering shakes alot going faster then 25mph. :noidea: i did the install myself and balance and it was perfect. im thinking its the hub centering ring.. i used the same one that came with the tsw's. could that be the problem?

joeybsyc 07-30-2013 07:47 PM

Why do you need the rings? Just looking to push the wheels out farther? I'd check to be sure all your wheel weights are still in place. I had a couple fall off my new SLP wheels while it was sitting in the garage. it seems the glue on some of the latest sticky weights doesn't stick too well. I'd take the rings out, if that doesn't cure your problem look at re-balancing the wheels.

000montoya 07-30-2013 07:57 PM

Quote:

Originally Posted by joeybsyc (Post 6840022)
Why do you need the rings? Just looking to push the wheels out farther? I'd check to be sure all your wheel weights are still in place. I had a couple fall off my new SLP wheels while it was sitting in the garage. it seems the glue on some of the latest sticky weights doesn't stick too well. I'd take the rings out, if that doesn't cure your problem look at re-balancing the wheels.

i left the rings on cause i thought they needed it.
so its okay if im riding with no rings on or do i need different ones? and yes i checked the weights when i got home and theyre all good

joeybsyc 07-30-2013 08:06 PM

I don't see why you'd need the rings... Anyone else I know that has bought those wheels bolted them up directly to the hub without issue.

000montoya 07-30-2013 08:58 PM

oh okay ill try it without them. hopefully it fixes it. the wheels feel like they're going to fall off but thanks for the help!

000montoya 07-31-2013 02:58 PM

took the centering rings off and fixed the problem :thumbsup:

Rudy@Tirerack 07-31-2013 04:41 PM

Correct! OE wheels do not need centering rings. Just most aftermarket ones do.


All times are GMT -5. The time now is 07:04 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.