Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Cold Air Inductions
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Search Forums

Showing results 1 to 7 of 7
Search took 0.01 seconds.
Search: Posts Made By: Sprov
Forum: Canada 05-28-2014, 11:12 AM
Replies: 121
Views: 8,342
Posted By Sprov
I'm In!

I'm In!
Forum: Canada 07-15-2013, 04:57 PM
Replies: 823
Views: 21,193
Posted By Sprov
Sounds like a good time, Gonna try to make it!

Sounds like a good time, Gonna try to make it!
Forum: 5th Gen Camaro SS LS LT General Discussions 06-03-2013, 10:01 PM
Replies: 4
Views: 580
Posted By Sprov
Engine ticking noise

On a cold start up, my engine has a distinct ticking noise....any idea as to why?
Forum: Engine | Exhaust | Bolt-On | Drivetrain Modifications 06-03-2013, 01:00 PM
Replies: 54
Views: 4,735
Posted By Sprov
Makes Sense, thanks!!

Makes Sense, thanks!!
Forum: Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 06-03-2013, 11:39 AM
Replies: 35
Views: 5,877
Posted By Sprov
My car does the same thing....kinda worries me!...

My car does the same thing....kinda worries me! only does it cold, maybe I should change oil and see if problem persists?
Forum: Engine | Exhaust | Bolt-On | Drivetrain Modifications 06-03-2013, 11:38 AM
Replies: 2
Views: 493
Posted By Sprov
start up / ticking noise

When I Start up my Camaro, there's a ticking noise? any ideas, I was thinking maybe a lifter or injector?!
Forum: Engine | Exhaust | Bolt-On | Drivetrain Modifications 06-03-2013, 11:35 AM
Replies: 54
Views: 4,735
Posted By Sprov
Exhasut Fuse

I took my trunk apart and it did not have a Fuse in the panel at #8? anyone know why it does not have one, right from the dealer?
Showing results 1 to 7 of 7

 
Forum Jump

All times are GMT -5. The time now is 11:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.