Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Emblempros
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Search Forums


Showing results 1 to 30 of 227
Search took 0.02 seconds.
Search: Posts Made By: VASCAR2
Forum: 5th Gen Camaro SS LS LT General Discussions 07-31-2017, 01:40 PM
Replies: 51
Views: 1,771
Posted By VASCAR2
Illinois is $101 for registration per year. When...

Illinois is $101 for registration per year. When you purchase a vehicle you pay 6.25% sales tax on purchase price plus $110 title fee.
Forum: Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 12-16-2016, 10:34 AM
Replies: 108
Views: 11,383
Posted By VASCAR2
I have a 2010 1LT I bought new in 09/2009 and...

I have a 2010 1LT I bought new in 09/2009 and mine developed an oil leak. Dealer fixed main seal between engine and transmission after owning about two years and 25,000 miles. I had a check engine...
Forum: Camaro V6 LLT Engine, Exhaust, and Bolt-Ons 08-14-2016, 12:14 PM
Replies: 20
Views: 2,175
Posted By VASCAR2
I broke my LLT in hard and I have yet had to add...

I broke my LLT in hard and I have yet had to add any oil to my 2010 but I only have 53,000 miles. My car did develope an oil leak at the main engine to transmission seal. Dealer fixed the oil leak...
Forum: 4th Generation Camaros 07-30-2016, 07:15 PM
Replies: 5
Views: 1,355
Posted By VASCAR2
My 94 pass key/ignition went bad and the car...

My 94 pass key/ignition went bad and the car would not recognize the original keys. My mechanic fixed it by installing a new ignition switch inline. I still use the original keys but might be...
Forum: 4th Generation Camaros 07-20-2016, 09:33 PM
Replies: 5
Views: 1,355
Posted By VASCAR2
The Camaro is known to have issues with coils. I...

The Camaro is known to have issues with coils. I know on my police B4C had to have the coils replaced. Mechanic found it was weak and the LT1/LS1 needed a good hot spark. The Camaro never failed...
Forum: 4th Generation Camaros 07-20-2016, 09:26 PM
Replies: 6
Views: 1,988
Posted By VASCAR2
My 94 V6 Camaro has the check engine light come...

My 94 V6 Camaro has the check engine light come on after the car warms up. My mechanic thought it was the EGR which we replaced and did not stop the light from coming on. I know you can get a...
Forum: 4th Generation Camaros 11-02-2015, 06:25 PM
Replies: 9
Views: 2,075
Posted By VASCAR2
Glad your OK, cars can be replaced. Sorry to...

Glad your OK, cars can be replaced. Sorry to hear about your SS and by the pictures and age I'd say it is totaled. Hopefully you'll be fairly compensated.
Forum: 4th Generation Camaros 08-24-2015, 05:44 PM
Replies: 9
Views: 1,736
Posted By VASCAR2
Kind of corney but my screen name was chosen...

Kind of corney but my screen name was chosen because I had a moving RADAR and a VASCAR to. Just an ole traffic cop at heart but I really enjoyed my career but LE is definitely is not a job for an...
Forum: 4th Generation Camaros 08-23-2015, 11:56 AM
Replies: 9
Views: 1,736
Posted By VASCAR2
Very nice Z-28, I like the Charger in the...

Very nice Z-28, I like the Charger in the background. Retired LEO still look at patrol cars, (Commision, Squad Car whatever term). I bet your Z28 is very quick and tons of fun to drive! :drool:
Forum: 4th Generation Camaros 08-07-2015, 06:58 PM
Replies: 4
Views: 1,040
Posted By VASCAR2
Fuel pumps are a known problem with 4th...

Fuel pumps are a known problem with 4th generation Camaro. My mechanic found my similar problem by checking the fuel pressure. I had previously replaced the fuel filter. Fuel pressure in the tank...
Forum: 4th Generation Camaros 07-23-2015, 07:38 PM
Replies: 2
Views: 881
Posted By VASCAR2
As the air temperature goes up it makes the A/C...

As the air temperature goes up it makes the A/C work harder, if the system is low on freon the compressor won't kick on. On a Cooler day the A/C may work but it probably has a freon leak. You might...
Forum: 4th Generation Camaros 06-30-2015, 07:17 PM
Replies: 1
Views: 1,004
Posted By VASCAR2
Mine has been doing this and I believe mine is...

Mine has been doing this and I believe mine is probably emissions related. I had my EGR valve replaced thinking this would cure the problem but didn't seem to help. My 3.4 runs fine and doesn't...
Forum: Camaro V6 LLT Engine, Exhaust, and Bolt-Ons 06-01-2015, 07:19 PM
Replies: 4
Views: 699
Posted By VASCAR2
Sounds like the engine was not firing on every...

Sounds like the engine was not firing on every cylinder. If the CEL flashed the dealer or mechanic can check to see what code was thrown. If it were me I'd go to autozone and see if they would put...
Forum: 5th Gen Camaro SS LS LT General Discussions 05-20-2015, 03:32 PM
Replies: 51
Views: 5,873
Posted By VASCAR2
The RADAR detector normally will not help you if...

The RADAR detector normally will not help you if your clocked by aircraft. Normally an observer or pilot times a target vehicle between two painted lines on the highway. Most states use an 1/8 mile...
Forum: 4th Generation Camaros 05-10-2015, 04:28 PM
Replies: 7
Views: 1,310
Posted By VASCAR2
If it is a manual 5 speed check the transmission...

If it is a manual 5 speed check the transmission fluid. Ours was low, drained fluid and filled the transmission with new fluid, noise went away.
Forum: 4th Generation Camaros 05-04-2015, 10:57 AM
Replies: 2
Views: 1,261
Posted By VASCAR2
If I was betting I'd say the fuel pump is bad. ...

If I was betting I'd say the fuel pump is bad. My 94 3.4 Camaro still uses the original key. My pass code key system went bad many years ago. My mechanic wired in a new ignition switch with key...
Forum: 4th Generation Camaros 04-29-2015, 03:39 PM
Replies: 2
Views: 921
Posted By VASCAR2
If the Camaro has the original spark plug wires I...

If the Camaro has the original spark plug wires I would change them. Be sure to use AC Delco plugs or ones specified in the owners manual. One common problem is the fuel pump in the tank. If the...
Forum: Camaro V6 LLT Engine, Exhaust, and Bolt-Ons 03-24-2015, 06:29 PM
Replies: 8
Views: 1,064
Posted By VASCAR2
I broke my LLT in hard and no problems yet, I...

I broke my LLT in hard and no problems yet, I have 44,000 miles on mine. I always broke my police cars in hard, just like I was going to use them. My cars were usually some of the fastest most...
Forum: 4th Generation Camaros 12-31-2014, 06:11 PM
Replies: 8
Views: 1,367
Posted By VASCAR2
Sounds like you may not be getting fuel. Has the...

Sounds like you may not be getting fuel. Has the fuel filter ever been changed? My 94 3.4 had low fuel pressure and I ended up having to replace the fuel pump which is located in the fuel tank. My...
Forum: 4th Generation Camaros 12-13-2014, 02:45 PM
Replies: 17
Views: 17,529
Posted By VASCAR2
My 94 3.4 L, 5 speed has an inaccurate fuel gauge...

My 94 3.4 L, 5 speed has an inaccurate fuel gauge but also failed to suck the last couple of gallons out of the tank. If you went 300 miles your on fumes or running out. I since have had the fuel...
Forum: Camaro V6 LLT Engine, Exhaust, and Bolt-Ons 12-08-2014, 01:15 PM
Replies: 84
Views: 7,901
Posted By VASCAR2
Still here, took delivery of my 1LT IBM in Sept....

Still here, took delivery of my 1LT IBM in Sept. Of 09. Still have my IBM about 42,000 miles but haven't been driving as much. Doesn't seem possible it's been over 5 years.
Forum: Camaro V6 LLT Engine, Exhaust, and Bolt-Ons 09-07-2014, 11:33 PM
Replies: 6
Views: 1,039
Posted By VASCAR2
Just curious what type of scales were used, by...

Just curious what type of scales were used, by looking at the results it would appear there were individual pads under each tire. If the vehicle being weighed is not on a level surface or the pads...
Forum: Off-topic Discussions 03-29-2014, 06:54 PM
Replies: 9,222
Views: 790,831
Posted By VASCAR2
I have a 16" Tavor in black with EO Tech. The...

I have a 16" Tavor in black with EO Tech. The Tavor really shines in off hand shooting, CQB and out to 300 yards. Closer to the handling of short sub gun than an AR-15. Very smooth shooting...
Forum: 4th Generation Camaros 03-07-2014, 11:56 AM
Replies: 39
Views: 6,385
Posted By VASCAR2
You might contact the National Insurance Crime...

You might contact the National Insurance Crime Bureau (NICB). This a not for profit agency and is a go between between manufactures of autos and Law Enforcement. The NCIB replaced the NATB...
Forum: Off-topic Discussions 02-15-2014, 09:47 PM
Replies: 9,222
Views: 790,831
Posted By VASCAR2
I really like the Tavor, very smooth shooting,...

I really like the Tavor, very smooth shooting, very natural ergo's with very minimal recoil. The only thing I've shot that compared to it in handiness was an MP5. The Tavor uses a long stroke gas...
Forum: Off-topic Discussions 02-04-2014, 04:36 PM
Replies: 9,222
Views: 790,831
Posted By VASCAR2
Here is a companion I bought for my Camaro. ...

Here is a companion I bought for my Camaro.


http://i222.photobucket.com/albums/dd244/VASCAR2/image_zps06fe64ad.jpg (http://s222.photobucket.com/user/VASCAR2/media/image_zps06fe64ad.jpg.html)

...
Forum: 4th Generation Camaros 01-06-2014, 09:08 PM
Replies: 14
Views: 2,493
Posted By VASCAR2
I just checked and the 99 Camaro B4C I drove was...

I just checked and the 99 Camaro B4C I drove was Mystic Green Matallic.
Forum: 4th Generation Camaros 01-06-2014, 08:55 PM
Replies: 14
Views: 2,493
Posted By VASCAR2
You really brought back memories for me with...

You really brought back memories for me with those B4C Camaros. I drove a 1999 B4C automatic LS1 and it was the medium green. I never knew the name GM gave that color but it was a phenomenal car. ...
Forum: Wheels and Tires Talk Sponsored by The Tire Rack 12-22-2013, 07:34 PM
Replies: 31
Views: 3,298
Posted By VASCAR2
I am at 39200 miles on my 1LT with 19" Pirelli's...

I am at 39200 miles on my 1LT with 19" Pirelli's and I have had a lot of fun on the twisty roads. I try to keep cold tire pressure at 35 lbs PSI.
Forum: Camaro V6 LLT Engine, Exhaust, and Bolt-Ons 11-27-2013, 11:14 PM
Replies: 76
Views: 5,489
Posted By VASCAR2
39000, I use 5W30 Pennsoil, no oil consumption...

39000, I use 5W30 Pennsoil, no oil consumption but had a rear main seal replaced under warranty because of an oil leak. My 2010 1 LT was built Sept, 2009.
Showing results 1 to 30 of 227

 
Forum Jump

All times are GMT -5. The time now is 04:43 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.