View Single Post
Old 04-04-2010, 05:34 PM   #36
Emperor_SS
 
Emperor_SS's Avatar
 
Drives: 05 C6
Join Date: Nov 2009
Location: Las Cruces, NM
Posts: 140
Quote:
Originally Posted by mws444 View Post
So what is the verdict with your car? What came loose at the strip?
I think you might want to check out a bushing set for that wheel hop.
We put it on the lift and I couldn't find anything loose so I don't know. i recheck everything i have ever loosened and everything was tight.

Quote:
Originally Posted by alex33x View Post
You think with a supercharger and all my mods I wouldnt drive fast? I've actually gone 150mph on the freeway lol.

You just need to take more care of your finish, a clear bra in the front end then sealant then wax on your finish should be enough. for those who dont like a clear bra you can even add extra hands of clear coat to your front end, though if you have rock chips its too late now.

I only have some scratches inside the engine bay that the guys at the body shop did when installing my SLP hood, but Im taking it back monday and making them repair them.
well I've done better than 150 in my car but thats not what I meant I was talking about the long drive we have to get to work see my round trip a day is a 108 miles and I encounter all kinds of weather conditions, road surfaces and various debris on the road. With a drive like I have even with the extra precautions taken to prevent driver's marks it is impossible because of the it is my DD.
Emperor_SS is offline   Reply With Quote