View Single Post
Old 03-04-2012, 02:39 PM   #5
ssmike
Missing Big Red
 
ssmike's Avatar
 
Drives: 2013 Equinox CRT
Join Date: Jul 2009
Location: Buffalo, NY
Posts: 6,282
I'll get to more pics soon! As I mentioned above, I had some PITA problems from the begining. I'll get the negative stuff out of the way and move on to the good stuff later!

My first summer with Big Red was good until I tried doing some mods, like SLP LM II's and OTR intake. I didn't like the sound of the LM II's, kinda sounded like a motor boat at idle. I also bought a New Era OTR intake but had drivability issues (herkey jerkies), so I ended up returning it after 2 months of trying everything to resolve the issue. It ended up being an issue with the maf placement that New Era fixed later that year. I replaced it with a Roto-Fab cai. I ended up removing and selling the LM II's and bought a Solo Mach-X catback which ended up being one of my favorite mods to this day!

All was good until that fall when I noticed an oil leak and I also had 3rd gear notchy issues. The oil leak was an oil cooler gasket and they couldn't find a problem with 3rd gear, go figure! Long story short, after a year and 1/2 and 3 tries the dealership refused to do anything about the tranny. Also, my oil leak came back, this time it was the pan gasket. On top of all that I was worried about the trans output shaft snapping because I had an earlier vin, below 25,000! Also, during the first year I had problems with passenger side window indexing which was finally fixed after 3 attempts by the dealer.

By the end of 2010 I was getting pissed about the transmission and my dealership not doing anything about it so I wrote an e-mail to Al Oppenheiser whome I met at the Summit Racing Camaro fall classic in 2009! A couple weeks later I got a call from Detroit powertrain division that they wanted to swap out my trans with a new one! I was elated because not only would this resolve the 3rd gear problem but I won't have to worry about the output shaft anymore! What a relief! The trans was replaced in March of 2011 and all is good!

One last negative to discuss before moving on. I had a JRE SCT tune done and noticed a higher than usual knock retard at certain rpms and shifts. After a month or 2 of datalogging and Ted's tweeking we decided that it may be due to false knock from something vibrating or rattling. I checked all the obvious places but all was tight and there was no audible rattle anywhere. Well, I was under the car doing an oil change and I grabbed the starter to move myself aound under the car and the damned thing moved! The starter was loose! Both bolts needed to be tightend, only thing I could figure is that the dealership never tightened it when they did the oil pan gasket or trans replacement! After I tightened it up my knock sensor problem went away!

So by now Big Red was finally coming together and I really started to enjoy the experience of driving! Here's a couple pics of what it looked like after a year and 1/2! At this point my mods were:
Stillen rotors
Roto-Fab cai
Doug thorley shorty headers
Big Worm Graphics lens tint
Hurst short throw with T-handle
SS mats
Junky Autozone pedals
Solo Mach-X catback
Roto-Fab engine covers
Attached Images
     
ssmike is offline   Reply With Quote