View Single Post
Old 08-28-2012, 06:55 PM   #26
BaylorCamaro
Track > 1/4 Mile
 
BaylorCamaro's Avatar
 
Drives: 2013 ZL1
Join Date: Sep 2009
Location: Kemah, TX
Posts: 5,242
Well this Rx Chiller has been the bane of my existence. Ever since it was installed it has been nothing but issues. Sure it works great, cooling my IAT temps down to 56-60 degrees. However since it makes the IAT temps inside the intake tube so cold and this Texas heat is 90-100 degrees everyday all day, it creates condensation on the MAF sensor. So far I've had the $80 MAF sensor go out twice now. The first time was on the way back to Texas from the shop down in Florida. The sensor went out 100 miles south of Tallahassee leaving me stranded there for two days until the local dealership express shipped in a new sensor. For the rest of the drive (11-12 hours) I drove without the AC in fear that it might go out again.

Since I've been back to my house in Houston, I've been running the AC a little bit, since the temps have been in the high 90's and my car sits out in the hot sun at work, making cabin temps well over 100 degrees. Well the MAF sensor went out again last week and as I guessed, when I pulled the MAF sensor out it was completely soaked. So for the past week I've been driving without any AC. Lucky for me work is only a 15 min drive from my house. However today I had to go to the doctor after work and I sat in my car for 45 mins without the AC. Here's a nice pic of my shirt lol.

Tracy just sent me a valve that is supposed to help regulate the IAT temps, but I have no idea when I'm actually going to have time to install it.

Hopefully this works, or I'm going to be tempted to rip out this chiller.

I'm fairly confident that Tracy and I can get this bugger figured out though. The Chiller is doing it's job, too well. LOL
Attached Images
 

Last edited by BaylorCamaro; 08-28-2012 at 09:22 PM.
BaylorCamaro is offline   Reply With Quote