View Single Post
Old 03-24-2013, 01:24 PM   #2
newagemuscle
Philippians 4:13
 
newagemuscle's Avatar
 
Drives: SLP Supercharged LS3
Join Date: Aug 2009
Location: The Motor City - Michigan
Posts: 2,527
Quote:
Originally Posted by lincoln361 View Post
Well I finally did the installation of the tvs 2300. It was not nearly as bad has I thought, I had a good pal of mine really take is time and read every single step. I think the drilling was the most stressful part but once you did one the other hole was a breeze. I went and installed the 1:1 Cog drive, new taylor wires, NGK tr6 spark plugs, and hopefully get my prosport evo gauges installed this week as well. But I do have a question.

Since I have only uploaded the stock charger tune that came with the kit. Will I be able to drive around 130 miles to get to my tuner in san Antonio. I have headers and high flo cats. I don't want to drive it that far and something go wrong? Also, I did not install the 160 thermostat on the vehicle, I drove it around with the A/C on a couple of times and it got hot, no leaks or anything, I think it might have air in the system, im letting it cool down and putting more coolant, the reservoir was empty so I put some in their as well. wondering if anybody encountered this problem before when they installed their supercahrger, maybe their is a way to vent the system, or does this have to do with a tune and needs to get adjusted? Or do I need the new 160 thermostat? Any input on any of this will be great. Thanks.
Nice job!
__________________
newagemuscle is offline   Reply With Quote