View Single Post
Old 05-16-2013, 01:39 PM   #24
Childs Play
Is this thing working?
 
Childs Play's Avatar
 
Drives: 2014 Versa POS
Join Date: Jan 2012
Location: Katy, TX.
Posts: 172
I'd also call GM's corporate office if the problem persists. I had an issue with my last Camaro escalated all the way up to them. They'll talk to the dealership and help set them straight.

I had an issue that dragged on for about 4 months with my last Camaro... It ended with a dealership (Westside Chevrolet in Katy, TX.) telling me they wouldn't look at my car because of all the issues it was having even though it wasn't even a year old. (Even though GM specifically told them to look at the car). I gave them a one finger salute and went and traded in my SS for a ZL1 that day. I haven't looked back. haha.

On a side note... I also had a dealership put a gash one of my rims and it also cut into the tire on that rim destroying it as well. They claimed it wasnt them and said I didn't have any proof. Even though I was still at the dealership when I pointed it out and it had the same blue paint engraved into the rim that was on their lifts... NOT PROOF THOUGH because that blue paint could have been from anywhere... you know... all those curbs painted blue around here.
That guy also got a one finger salute. I'm a nice guy... I really am...
__________________
Knowledge is knowing that a tomato is a fruit, but Wisdom is knowing not to put it in a fruit salad.

H-Town Camaro Club FTW!

Past Rides:
2012 Camaro 2SS/RS M6 w/Corsa Cat Back Exhaust, CAI intake and Kooks Headers.
2012 Camaro ZL1 A6 Bone Stock.

Last edited by Childs Play; 05-16-2013 at 01:52 PM.
Childs Play is offline   Reply With Quote