View Single Post
Old 05-17-2013, 06:27 PM   #56
KMPrenger


 
KMPrenger's Avatar
 
Drives: '10 ABM LT/RS, 06 Chevy Colorado
Join Date: May 2009
Location: Jefferson City, Missouri
Posts: 9,627
Quote:
Originally Posted by CamaroC-17 View Post
Got the car. Runs and sounds great! I forgot how good the engine sounds when its not covered up by a loud exhaust. Oil PSI is back to normal. The sound that I thought was a loose heat shield was A bad slave cylinder and throw out barring in the clutch which they found and replaced on their own. They even transferred over my painted valve covers for me. The guy who did the work said its a 2013 LLT. Only thing he didn't do is hook my ZL1 light harness back up to the fuze box. So my lower fogs are not powered right now. They had the car spotless inside and out and did replace the windshield and fixed the radiator fans.

Here's the million dollar question...mod or not to mod. At the least my elite catch can will go back on.


Sent from my DROID RAZR HD using Tapatalk 2
Glad to see it is all taken care of. For me, the million dollar question is if the timing chain issue still exists in your new LLT engine, or if its the same exact design as the 2010 engines.

So before this all began, did you take off the headers and everything before taking it in? I can't remember. That sounds like a lot of work lol.
__________________
IPF Tune, Custom Magnaflow Exhaust, Vararam intake, MACE Ported Manifold, RX Ported TB, "Black Ice" manifold insulator, Elite Catch Can, ZL1 repro wheels, ZL1 Springs, DRL Harness, Front GM GFX, Heritage grill, Street Scene lower grill, NLP Spoiler, ZL1 rockers and much more!
KMPrenger is offline   Reply With Quote