View Single Post
Old 06-22-2013, 04:01 PM   #10
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,817
Quote:
Originally Posted by pmandeep View Post
Hey Guys,

My HUD was acting up today on my way back from work. I usually leave it 'ON' so every time I turn on the car it comes on by itself. What happened today was after getting off from work when I turned the car on and left the parking lot and had just come to the first stop at a signal light the HUD just faded away and disappeared even though the brightness was turned up all the way and the for the rest of my drive to home, it would just come back at a random time and again fade away and it kept doing that.

In my attempt and hopes of fixing it, I ended up pulling over on freeway once and actually turned the car off and opened the door to shut the electronics off. Tried to do the same when I was stopped at a signal light. And every time I turned the car back on and it did the same thing and faded away.

Then once I got home, I had the car in driveway for just a little over 5mins (turned off) before pulling it in the garage and at that time when I was pulling it in garage the HUD seemed to stay on. This has happened first time and my car is only 1month old with only 1130miles on it.

Should I wait and see if it does it again or take it to the dealership?

Hello pmandeep,

Sorry for the HUD issues your having. I would like to look into this issue for you. If you could, private message me your VIN and current mileage and I will investigate a bit further for you. I will update you there.

Reggie B.
Chevrolet Customer Care
Chevrolet Customer Svc is offline   Reply With Quote