View Single Post
Old 06-25-2013, 09:10 AM   #958
VanquisherSS
Hasbin of Stock Bottom HP
 
Drives: CTS-V Coupe, 04 TT Viper
Join Date: May 2011
Location: NJ
Posts: 2,560
Quote:
Originally Posted by Sickwitit View Post
I think it's a defective amp...the shop will determine when they strip it down to replace the other components. The Rockford rep at the OC show missed quoted the LIQUID COOLED components as the T5's...but actually it will be the T6 series when their released (If they keep the name and or design), the T5's series are in fact...LCP, Liquid Crystal Polymer. Information and spec's from web site.

The T5652-S is the best 6.5” 2-way component system from Rockford Fosgate. Rated at 300 max Watts 150 RMS, the system includes two woofers with grilles, pair of tweeters, a multi-function audiophile crossover and mounting hardware.

  • 1" (25mm) ring radiator LCP dome tweeter with copper phase plug
  • LCP (Liquid Crystal Polymer) fiber trilaminate cone
  • True Nomex spider
  • Die cast aluminum frame
  • Multi-pole™ neodymium motor structure
  • Solid copper phase plug for extended frequency range and greater power handling
Well if your turning it up and it sounds blown then its the speaker I would think. If its up and your getting distortion at levels you never did or a bunch of clipping then your amp took a shit. If the sub isn't moving then its blown. To be honest man I was never a fan of Rockford stuff, but I know you have a potential sponsorship there so whatever costs you the least green is the best .

I had my Alpine V12 amp since high school man, thing ran strong as hell for like 6 years never skipped a beat and the best part about it was when it hit thermal protection mode it didn't shut off it just cut power by 50% and kept playing. Alpine, Rockford, JL, now a days IMO is shit. Not what it used to be. I sold my JL W3 and that amp to a buddy and its still bumping to this day. If you really want SPL sound look into FI Car Audio and some Sundown Audio amps. I'm telling you I had that setup it was so clean it was ridiculous. At the same time it was so ****ing loud it could open automatic doors LOL . At FI Car Audio man everything is built to order nothing sitting in a warehouse mass produced, I legit cannot stress the quality enough. I fed two of those FI BL subs over 3000W RMS man and I beat the shit out of them on the daily and they laughed at me.

Sorry for the lengthy post my dude but you know if it ain't the best I'm gonna keep it moving and tell it like it is haha. Either way get that system back up and running. If you need an amp in the meantime I have a 1200W RMS at 2ohms mono block you can use.
VanquisherSS is offline   Reply With Quote