View Single Post
Old 09-13-2013, 07:24 AM   #116
10 2SS/RS 6M
 
10 2SS/RS 6M's Avatar
 
Drives: 2010 Camaro 2SS/RS 6M Black-s/s
Join Date: Oct 2010
Location: Philadelphia, PA
Posts: 273
Quote:
Originally Posted by PMJ View Post
Just put on my new track shoes for the first time (thanks to a little help from Jamie). Had to cut off the skates up front. And now I'm almost ready to go to the track Saturday.

Attachment 555442



Attachment 555443

Attachment 555444

Supposed to be in the 80s Saturday night in Seally, TX. I hope the rain holds off. Should be good enough weather for me to break into the 10s for the first time.

I'm expect 17.5+# of boost, so should be running around 830-850 whp.

I found out my belts are shredding because my balancer is recessed about 1 rib behind the rest of my 10 rib pulleys. So I took a new belt, cut 1 rib off, so now i'm running a 9 rib belt...and it appears to be riding just fine. We'll see how it holds up at the track.

My hex vents showed up today (install pending), and I'm still waiting on my larger chiller. The current chiller helps, but not anywhere close to what I was expecting.
With that amount of horsepower you should have no problem running 10's, hope it all works out for you, wheels look great! Post some video's, Good Luck!
__________________
SLP- long tube headers, hi flow cats w/full SLP 3'' PowerFlo exhaust incl/X-pipe, 160 degree stat, SLP Blackwing CAI. Dyno tuned by ECS-407/409RWHP&TQ. BMR- trailing arms w/poly knuckle bushings, toe links, cradle bushings and differential bushings. Hurst short throw shifter, DSS- level 4 axles, DSS- aluminum driveshaft, Pfadt- sport swaybars w/HD adjustable links. Monster LT1-S twin, clutch, Prothane motor mounts. Best 1/4 mile so far- 12:70ET @ 112.24 MPH w/ 2.06 60'.
10 2SS/RS 6M is offline   Reply With Quote