View Single Post
Old 05-05-2014, 07:30 PM   #1
JHall651
 
JHall651's Avatar
 
Drives: 2012 Camaro 2SS LS3 Ashen Grey
Join Date: Mar 2012
Location: Chicago, IL
Posts: 483
Pfadt Coilover Troubleshooting

Hey everyone. A bit over a year and about 8k ago I had some pfadt featherlights installed and have loved every mile. Recently though I have had some creaking and popping coming from the front end when I would turn the wheel right or left. Thought maybe it was the Sway bar but I disconnected it at the end links and still made the noise when I would turn the wheel. This happened moving or sitting still. So I figured it was the mounts. Lucky for me my Dealer is very mod friendly and replaced the mounts for free. Seems to have made a big improvement but still seems to happen when I turn out to lockout position. I thought I would snug up the upper nuts just a few pounds and see if it would help but here is where things got funny. Seems my passenger side just keeps spinning and spinning. I mean it pops my torque wrench at 70 ft lbs but if I give it a hair more the mount spins inside and the nut never really goes anywhere. Is this normal? Is the shaft running into the strut that has the threads on it suppose to spin like that? If all this is normal then how do I go about snugging those without it spinning? And any suggestions on what the pooping could be would be appreciated. It seems to be maybe my springs doing it when they twist, when I turn my wheel. Not sure. Thanks everyone.
__________________
2012 2SS/RS, Magna TVS2300, RX Catch Can, Borla S-Type, Pfadt Stage 4 w/ ZL Spec Sway Bars, ADM Custom Boost/AFR Gauges, Hurst Short Throw, Forgestar F14 Matte Black 20x11 & 20x9.5 Deep Concave all 4, Nitto Invo 315/35 & 275/40, Heritage Grill, Sparks Black Grill SS & Trunk SS, P13W Fog Lights (cool white) w/ DRL Harness, Blacked Out Brake light bezels, Xpel Smoke Light Kit
JHall651 is offline   Reply With Quote