Thread: Scosche
View Single Post
Old 09-08-2013, 11:57 AM   #1
DaFisch
Master Amateur Mechanic
 
DaFisch's Avatar
 
Drives: Victory Red 2011 2SS/RS
Join Date: Jan 2013
Location: South Barrington, IL
Posts: 1,722
Thumbs up Scosche

Scosche had some bad reviews before with the cracking of their dashes and so they took several months on fixing the issue. When they returned I was one of the first to order the new kit from Phastek along with the Kenwood DNX570HD from an Amazon seller. They were both delivered the same day and when my friend and I got home from school we decided to install it. (we are only 17, still seniors in highschool)
Anyways, we took out the old dash, uninstalled the factory unit and started wiring in the new one. After 3-4 hours we had everything wired in and the cables managed so we went to put it back in.. That night I took it for a test drive and noticed that the steering wheel controls weren't working. So, what did I do you might ask? I emailed Kenwood, Phastek, and Scosche. Kenwood gave me their automated message and I never heard from them. Phastek told me they sold the units and they couldn't help (Hey, at least they responded and are still my favorite company!) Anyways, Scosche's representative Gabriel Flores was able to help me out. He emailed/trouble shot with me for days until he sent me over to the R&D department where they suggested running a 10k resistor from the ignition wire over to the steering commands wire. Well, what do you know, it worked! I just want to say that I received great customer service from Scosche and would definitly order from them again!
DaFisch is offline   Reply With Quote