Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Flowmaster Exhaust
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 07-10-2009, 08:57 AM   #51
topweldman
 
Drives: 2SS/RS Black with Orange
Join Date: May 2009
Location: Celina, OH
Posts: 1
Ground effects

I am writing because I am completely frustrated with this car deal. My car has been at the dealership for 2 weeks now and still have not gotten the ground effects for the car. They were odered when I put my order for my car in. It's not like they didn't know I wanted them. Customer service and dealer prep at this point is probably a good reason as to why GM is having the trouble it is. Anyone experiencing similar problems with getting the ground effects for their car? Let me know. I'm thinking I will be telling them to shove the car up their ass if they can't provide parts and customer service.
topweldman is offline   Reply With Quote
Old 07-10-2009, 11:44 AM   #52
Hawks
 
Hawks's Avatar
 
Drives: 2010 Camaro, 2004 Frontier
Join Date: May 2009
Location: Abilene, KS
Posts: 275
Quote:
Originally Posted by topweldman View Post
I am writing because I am completely frustrated with this car deal. My car has been at the dealership for 2 weeks now and still have not gotten the ground effects for the car. They were odered when I put my order for my car in. It's not like they didn't know I wanted them. Customer service and dealer prep at this point is probably a good reason as to why GM is having the trouble it is. Anyone experiencing similar problems with getting the ground effects for their car? Let me know. I'm thinking I will be telling them to shove the car up their ass if they can't provide parts and customer service.
Why did you leave it at the dealership? The GFX were on backorder from what I have read on other threads(I'm not completely positive since I didn't order them and haven't been tracking them as closely). You should go pick the car up and just bring it back later to have them put on.
__________________
CGM 2SS/RS, Manual VIN# 24515

Please go to this site to add your information to the site and spreadsheet...

http://camarotracking.com/

At the top is a blue ADD ORDER TO TRACKING DATABASE click on it and fill in the blanks. Make sure spelling and case is correct. Thats it and you will be added.
Hawks is offline   Reply With Quote
Old 07-10-2009, 12:14 PM   #53
14pilot
Original Bumblebee Owner
 
14pilot's Avatar
 
Drives: 265hp ZX-14, 500hp Silverado, V-ROD
Join Date: Apr 2009
Location: Arizona
Posts: 1,386
Issues on mine...

1-Door sill plates are wrinkled on their outside edges on both Drive and Passenger sides. [Parts on order.]
2-All 4 Rear Spoiler nuts were loose 3/8 of a turn. [I tightened them]
3-Trunk release fails to pop the Trunk Lid about every 1 out of 4 attempts. [Fixed under warranty.]
4-Where is my GD GFX Kit? [Came in 5 weeks after car. Installed.]
5-My Silver Rally Stripes are not installed as my Dealer wants to address 1,3 and 4 above at the same time, when the GFX comes in. [Came in 3 weeks after car. Installed.]
6-Clear coat is orange peeled badly. [Color sanding??? Maybe in a couple years.]
7-Underbody Exhaust Heat Sheild rattles when the Passenger Door is closed. [Haven't noticed it anymore.]
__________________
Quote:
Quote:
#5 - 2010 2SS/RS MN6 ABM #142-Silver Rallys-GFX / Med Titanium
My previous Camaros:
#4 - 1994 Z/28 6M Black over Arctic White / Graphite-Red Inserts - traded
#3 - 1981 Z/28 Bright Blue Metallic / Black - sold
#2 - 1970.5 RS Mulsanne Blue / Blue - endo crashed it and parted it out
#1 - 1967 RS Butternut Yellow w/ Black Bumblebee Stripe-RPO D91 / Parchment-Black - sold

Last edited by 14pilot; 07-27-2009 at 07:55 PM. Reason: Updating my status on these issues...
14pilot is offline   Reply With Quote
Old 07-13-2009, 03:46 PM   #54
rickerda
 
rickerda's Avatar
 
Drives: 2010 Camaro 2LT RS
Join Date: May 2009
Location: Chester VA
Posts: 513
Side dash pannel, where the driver side door and dash meet is popping open
rickerda is offline   Reply With Quote
Old 07-13-2009, 05:21 PM   #55
broncosman
 
broncosman's Avatar
 
Drives: 2010 Camaro 1SS
Join Date: Jun 2009
Location: Houston
Posts: 310
Send a message via Skype™ to broncosman
pls post your issues in this thread: http://www.camaro5.com/forums/showthread.php?t=30865
this way I don't have to jump through several threads to update the list. ty
p.s. only post what's not on the list already. double ty
__________________

2SS/RS with painted Rally Stripes
http://www.h-towncamaroclub.com/index.php
broncosman is offline   Reply With Quote
Old 07-14-2009, 09:18 AM   #56
TelliCamaro
 
Drives: Inferno Orange 2SS
Join Date: Mar 2009
Location: Chesapeake, VA
Posts: 9
Power Steering Pump Failure

Quote:
Originally Posted by rickerda View Post
Side dash pannel, where the driver side door and dash meet is popping open
Took delivery of my Camaro 6/26/09 (VIN #2048), I have the same problem with the side dash panel popping open, dealer has ordered another.

The power steering pump failed with 430 miles on it, leak is from where the pump assembly is actually pressed into the resevoir body. New pump on order, still waiting to get her back.

This car was born on April Fools Day, keep an eye on your steering.

2SS/IOM
TelliCamaro is offline   Reply With Quote
Old 07-18-2009, 01:05 PM   #57
BruceJames
 
Drives: 2010 SS2 RS Inferno Orange
Join Date: Jul 2009
Location: Clifton NJ
Posts: 43
Took delivery Friday the 17th.. So far... A pillar hanging off.. ( the should have found that in prep.. and the tranny makes God Awful noises from the rear end as well as sometimes from what seems to be mid car when I depress or let up the clutch..It also sounds like lots of backfiring when I coast down a hill with the car in gear (usually 3rd or 4th) although... I think it's mechanical and not a backfire... ANYWAY... I'll bring the tech for a ride when I bring it in next Thursday for the A pillar..
I'll keep you all posted.
BruceJames is offline   Reply With Quote
Old 07-19-2009, 08:34 PM   #58
IOM_ROCKER
Senior Member
 
IOM_ROCKER's Avatar
 
Drives: 2010 Camaro / IOM / SS / RS
Join Date: Apr 2009
Location: No. Cal, East Bay
Posts: 201
Trunk release on driver door panel failed.

Trunk release on remote failed.

Attempted both several times and still failed.

Dash said trunk was open.

Checked trunk several times, but was open.

Lightly pushed trunk down and heard a "click" (it did not look slightly open at all and was previously closed and opened without incident).

Pushed trunk release on remote again and it opened.

Problem solved.
__________________
___________________________
TEAM LS3
IOM_ROCKER is offline   Reply With Quote
Old 07-20-2009, 12:29 AM   #59
JewelZ
Just Lovin' My Camaro!
 
JewelZ's Avatar
 
Drives: CGM 2LT/RS/AUTO
Join Date: Apr 2009
Location: san antonio, tx
Posts: 1,325
Please post all problems to the Ultimate Check List Thread

http://www.camaro5.com/forums/showthread.php?t=30865

Thanks Broncosman!
__________________
CGM( GRAY 2 tone interior ) 2LT/RS/AUTO

NJHKKM $29,965.00 1EH37 1100 03/28/2009 AFF, B34, DCP, FE9, GBV, LLT, MX0, SGC, UQA, WRS, 2LT

50 YEARS FROM NOW, DON'T YOU WANNA BE ABLE TO LOOK BACK AND SAY YOU HAD THE GUTS TO GET INTO THE CAR!?!?

ORDER STATUS : 6000 as of 08.18.2009. VIN# 33,985!!! His name is 'GOLIATH'!!!

GOT MY CAR!!!! AND I LOVE IT!!!!
JewelZ is offline   Reply With Quote
Old 07-20-2009, 03:15 AM   #60
TJTKSDMJ8
I COMMAND YOU TO HOOK 'EM
 
TJTKSDMJ8's Avatar
 
Drives: 2010 Black Camaro SS2/RS R6P
Join Date: Feb 2009
Location: Re-building Death Star (Need Contractors)
Posts: 2,881
umm. petty..no freaking back seat mats?
__________________
Proud Owner of a R6P Black SS/2, RS, CGM Stripe Package Delivered July 3!!!
TJTKSDMJ8 is offline   Reply With Quote
Old 07-20-2009, 04:12 AM   #61
BruceJames
 
Drives: 2010 SS2 RS Inferno Orange
Join Date: Jul 2009
Location: Clifton NJ
Posts: 43
OK any of you guys with a manual get a sound like the gears are hitting something (almost like something hitting a fan blade) when you depress the clutch?? ALSO, while driving do you get a noise from the rear (almost like a backfire but it's mechanical) I think I might have a problem with the tranny.. I've had a ton of sticks, but this one just sounds bad.
Any ideas???
BruceJames is offline   Reply With Quote
Old 07-23-2009, 03:46 PM   #62
BruceJames
 
Drives: 2010 SS2 RS Inferno Orange
Join Date: Jul 2009
Location: Clifton NJ
Posts: 43
Took it in today.. The dealer fixed the a pillar, the weather strip on the rear window and the loose spoiler... They had to call GM Engineering before they did the a pillar work.. GM wants every dealer to call when they see that particular problem before they fix it.. Seems like GM is trying to see how far reaching that particular defect is.. Thanks to GM for that!
Had the tranny and the real end looked at.. They state that the "backfiring" is normal and was engineered by GM that way to mimic the muscle cars of the past with their exhaust note.. I'll take their word for that for now.. They sais ALL M6's do that.
Anyway.. LOVE the car and the fixes were very easy.
BruceJames is offline   Reply With Quote
Old 09-20-2009, 09:57 AM   #63
will69camaro
 
will69camaro's Avatar
 
Drives: 1969 and 2010 Camaros
Join Date: Oct 2008
Location: Spring, TX
Posts: 515
I had the a/c problem already. Heard it was from high speed runs with a/c on. Condenser core freezes up and you lose the velocity and temperature. Talked to a friend who knows the guys at Delphi and apparently they're working on a fix (maybe car programming on how it runs the compressor?). He said to stop using a/c for about 30 minutes (let core thaw) and it'll be back to working order. I parked the car for about an hour as I detailed it, hopped in and it was back to perfect working order.

Just an FYI tip!
William
will69camaro is offline   Reply With Quote
Old 09-24-2009, 01:34 AM   #64
whiplash
 
Drives: Silver 2SS RS LS3
Join Date: Sep 2009
Location: California
Posts: 28
My 2SS RS M6 was just delivered to the dealership on Tuesday 9/22 and when I arrived to the dealership to look at the car they told me they have some bad news.... The A/C compressor has a leak so no cold air was blowing out. Now the car is sitting there waiting for a new compressor. I wonder if this a bad sign not to take the car!
whiplash is offline   Reply With Quote
Old 09-29-2009, 10:32 AM   #65
RuffEL
Semper Fi! Do or DIE!
 
RuffEL's Avatar
 
Drives: '10 camaro 1SS, '02 silverado 1500
Join Date: Sep 2009
Location: Schertz actually...
Posts: 301
Quote:
Originally Posted by TelliCamaro View Post
Took delivery of my Camaro 6/26/09 (VIN #2048), I have the same problem with the side dash panel popping open, dealer has ordered another.

The power steering pump failed with 430 miles on it, leak is from where the pump assembly is actually pressed into the resevoir body. New pump on order, still waiting to get her back.

This car was born on April Fools Day, keep an eye on your steering.

2SS/IOM
I think my power steering pump just went out too (im at 1300 miles) it'll turn fine at speed, but when i slow down (to park or Y turn) the power steering seems to have failed on me....taking it to the dealership today.
RuffEL is offline   Reply With Quote
Old 10-03-2009, 01:45 PM   #66
RuffEL
Semper Fi! Do or DIE!
 
RuffEL's Avatar
 
Drives: '10 camaro 1SS, '02 silverado 1500
Join Date: Sep 2009
Location: Schertz actually...
Posts: 301
yep, it was the pump...wouldnt put out enough steering fluid when the engine was below 1200 rpms.....they fixed it the same day once the part got in and threw in an oil change...not too bad...im runnin the shit outta the car early to find the faulty parts and get em fixed per the warranty....

car works great now
RuffEL is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Songs About Camaros (for your driving pleasure) Emjay 5th Gen Camaro SS LS LT General Discussions 71 12-28-2013 07:56 AM
GM memo to dealers Moose 5th Gen Camaro SS LS LT General Discussions 41 02-04-2010 07:33 PM
2010 Camaro, Decisions Decisions… (Winding Road Review) Xmicro_SS 5th Gen Camaro SS LS LT General Discussions 19 05-09-2009 11:40 AM
Answeres to questions I have stumbled on dieseldave24v 5th Gen Camaro SS LS LT General Discussions 13 02-23-2009 06:56 PM
UPCOMING CAMARO IMPORTANT DATES CamaroScotty 5th Gen Camaro SS LS LT General Discussions 125 01-11-2009 12:31 AM


All times are GMT -5. The time now is 01:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.