Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Emblempros
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 11-14-2009, 09:05 AM   #1
jey2101
 
Drives: Black 2010 2LT RS
Join Date: Aug 2009
Location: New York
Posts: 17
Question Engine Clicking while Idle

I have had my new 2LT RS for less than 12 hours and I have already developed a clicking sound coming from the engine. I opened the hood and it sounds like it is coming from the back of the engine in the drivers side. Its a very rhythmic clicking, like 2 beats per second and it kinda sounds like a ratchet turning. Anyone have a clue what is going on?

Last edited by jey2101; 11-14-2009 at 09:22 AM.
jey2101 is offline   Reply With Quote
Old 11-14-2009, 09:35 AM   #2
scrming
Red Brick of Vengeance!
 
scrming's Avatar
 
Drives: 12 Second Brick
Join Date: Jun 2009
Location: at my pulpit
Posts: 7,739
Quote:
Originally Posted by jey2101 View Post
I have had my new 2LT RS for less than 12 hours and I have already developed a clicking sound coming from the engine. I opened the hood and it sounds like it is coming from the back of the engine in the drivers side. Its a very rhythmic clicking, like 2 beats per second and it kinda sounds like a ratchet turning. Anyone have a clue what is going on?
Normal... think we decided it was the high pressure fuel pump... also the injectors are a bit noisy too...
scrming is offline   Reply With Quote
Old 11-14-2009, 05:26 PM   #3
latinoslife
 
Drives: silver ice 2010 camaro 2lt RS
Join Date: Jul 2009
Location: dyer, indiana
Posts: 136
i have that too its soooo annoying
__________________

[IMG][CENTER][/IMG]
latinoslife is offline   Reply With Quote
Old 11-15-2009, 11:20 PM   #4
Toastylicious
My car goes Vrooom.. You?
 
Toastylicious's Avatar
 
Drives: 2010 Rally Yellow Camaro LS
Join Date: Oct 2009
Location: Everett Washington
Posts: 136
Yep same thing here. Its just the fuel injectors. It does sounds like and overwound poket watch lol.
Toastylicious is offline   Reply With Quote
Old 11-15-2009, 11:30 PM   #5
Sevn86


 
Sevn86's Avatar
 
Drives: 2010 Camaro 2LT/RS ABM
Join Date: Sep 2009
Location: Sugar Land, TX
Posts: 13,087
I thought I was the only one who had that sound and was gonna start a thread to ask everyone but I guess its normal (I got my car on thursday 11/12/09)...I hear it when Im crusing not at idle...its not that loud but if the radios on I can sort of hear it...but when I stop its gone...so what is that? Do yalls cars start out loud when yall turn them on? then within 30seconds to a minute the car gets all quiet and you cant hear the engine running that much?
__________________
2LT, RS, AT6 ABM, Gray Leather
Quote:
Originally Posted by baclarsen View Post
Dude, you go through cars faster than I go through underware!!
1000 Initial Order 9/14/2009 - Classic Chevy Sugar Land
1100 Order accepted at dealer: 9/15/2009 - NPGV41.
2000 Order accepted by GM: 9/29/2009
3000 Accepted By Production Control: 9/30/2009 - TPW 10/26/09
3100 Sequenced:10/12/09
3300 Scheduled For Production:10/13/09
3400 Broadcast:10/22/09
3800 Produced:10/27/09
4000 Available To Ship:10/28/09
4200 Shipped:10/29/09
5000 Delivered To The Dealer:11/09/09
6000 Delivered To Customer:11/12/09
Sevn86 is offline   Reply With Quote
Old 11-16-2009, 10:47 AM   #6
RickyTheStorm
 
Drives: '10 Camaro 2SS,04 Colorado,06 ZX6R
Join Date: May 2008
Location: Chambersburg, PA
Posts: 524
Definitely normal - although mine only does it when cold. However every time I hear it I naturally go "S**t - what the hells wrong now ... oh wait, that's normal"
__________________
Vararam CAI, ARH Headers, Flowmaster Exhaust, Nitto NT555Rs, Custom CAM and Tune - 11.981 @ 116.27



IOM - 2SS/RS - Auto - IAP - Sunroof - Ordered 10/13 (#7 at dealer)
3000(accepted to production ): 4/19/09
3300 (scheduled for prod ): 5/11/09
3400 (broadcast ): 5/16/09
3800 (produced ): 5/22/09
4150 (invoiced ): 6/01/09
4200 (shipped ): 6/01/09
5000 (at dealer ): 6/12/09
6000 (delivery to me ): 6/12/09
RickyTheStorm is offline   Reply With Quote
Old 11-16-2009, 12:24 PM   #7
HeavyD

 
HeavyD's Avatar
 
Drives: 1SSRS RY L99
Join Date: Aug 2009
Location: Ontario
Posts: 1,330
Sound clip?
HeavyD is offline   Reply With Quote
Old 11-16-2009, 03:17 PM   #8
camaro5


 
camaro5's Avatar
 
Drives: Off Into The Sunset
Join Date: Mar 2008
Location: Cape Coral, Florida
Posts: 4,430
It's normal with direct fuel injection.
camaro5 is offline   Reply With Quote
Old 11-16-2009, 03:18 PM   #9
Camaro509

 
Camaro509's Avatar
 
Drives: 2010 2SS/RS Black
Join Date: Mar 2009
Location: Kansas
Posts: 1,087
This now has me concerned, if it is indeed a normal thing, mine isn't doing it...
__________________
Understeer, Oversteer, Wheel Alignment (Camber etc), Torque, Horsepower, Camaro

Fold for team 11108 to help find a cure!
Folding@home Stanford's Research DC Program.
Camaro509 is offline   Reply With Quote
Old 11-16-2009, 04:48 PM   #10
DangerZL1

 
Drives: Accord
Join Date: Oct 2009
Location: Memphis, TN Area
Posts: 1,910
Quote:
Originally Posted by Camaro509 View Post
This now has me concerned, if it is indeed a normal thing, mine isn't doing it...
The LS3 isn't direct injected and should be much quieter.
DangerZL1 is offline   Reply With Quote
Old 11-16-2009, 05:16 PM   #11
Chevyrocker
Weekend Rockstar
 
Chevyrocker's Avatar
 
Drives: Depends on the day...
Join Date: Mar 2008
Location: West Palm Beach
Posts: 1,445
It's because of direct injection...the fuel injectors are inside the cylinder walls and made of metal (and brawn) which causes the "click" noise everyone's experiencing. But by dealing with that noise, you are getting 304hp and 29mpg.
__________________
Shortcuts can slow you down...
Chevyrocker is offline   Reply With Quote
 
Reply

Tags
2lt, clicking, engine, idle

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
High Performance Exhaust AntmanZ28 Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 94 08-22-2009 02:16 PM
Idle trouble Looking Good in Red 4th Generation Camaros 1 07-28-2009 03:24 AM
Intermittent clicking noise at low speeds I8A4RE Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 10 06-30-2009 09:08 PM
V6 engine idle showcamaro Camaro V6 LLT Engine, Exhaust, and Bolt-Ons 9 06-17-2009 04:03 PM
Polished Aluminum Wheels and the V6 Idle KJS 5th Gen Camaro SS LS LT General Discussions 13 06-12-2009 09:45 PM


All times are GMT -5. The time now is 08:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.