Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
JUICEDMOTORSPORTS
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 12-06-2009, 02:41 AM   #1
F N MUSCLE
 
F N MUSCLE's Avatar
 
Drives: Black 1SS/RS, manual
Join Date: Jul 2009
Location: Chatsworth, CA
Posts: 57
Clutch Sticking

I know that there have been other posts about this, but I thought I would check and see if anyone has recently had any issues with the clutch pedal sticking on our cars. I drive a 2SS M6. Yesterday I was takin my buddies for a ride, waiting at the light with clutch in and in first gear. Light turns green, I slowly let the clutch out and hit the gas and the car just revs. I am like WTF!!! I go to press the clutch in and its stuck half way. I eventually get the clutch pedal down, shift into neutral then back into first and go to let the clutch out again....same deal. After a few seconds, the clutch pedal final releases and we are off with the sweet smell of burnt clutch. Didn't have any problems after that. Still freaked me out. Should I take it in? What do you guys think?
F N MUSCLE is offline   Reply With Quote
Old 12-06-2009, 03:12 AM   #2
TAG UR IT
www.Camaro5store.com
 
TAG UR IT's Avatar
 
Drives: 2014 ZL1 #705
Join Date: Jul 2006
Location: SA, Texas
Posts: 26,307
Hrm....my issue is when really hitting it hard...shifting fast through the gears. The cluch pedal likes to stay down halfway. I don't lose ANY momentum...the cars goes w/ no issue. It's just that the damn clutch pedal stays down on the floor. Feels like I won't be able to shift again.

What the hell am I supposed to do about that??
TAG UR IT is offline   Reply With Quote
Old 12-06-2009, 09:34 AM   #3
2SSRS@Gen5diy
Salt & Pepper 2014 Z/28

 
2SSRS@Gen5diy's Avatar
 
Drives: 2010 2SS IOM ,2014 Z/28, 66 Nova
Join Date: Oct 2008
Location: By the lake in AZ
Posts: 11,653
Thumbs up

Guys i have been on the corvette forum for 3 1/2 years and from day one that has been a problem with the vett, That is why they made a Sticky out of this thread.

http://forums.corvetteforum.com/c6-z...-and-cure.html

Now for the bad in the camaro.

1: We use the brake reservoir and not a separate Clutch Fluid reservoir.
2: The brake reservoir we have dos not have a cap that is airtight,
3: By not having an airtight seal the brake Fluid starts to boiling faster and in humid place's some amount of water may get in and bring down the boiling point for the Fluid
4: in the camaro we run dot3 and in the VETT it is dot4.

So this is one thing that i do is change the Clutch Fluid after some hard driving or as soon as the pedal starts to fell hard, At that time you can see the color has gone from amber to a gold or brown-red, Here is some thing that i think we need to do, Put on a separate Clutch Fluid reservoir with an airtight cap.

And update to a dot4 i know that want fix all the Clutch Pedal Issues but it will help some if not a lot of members.IMO
__________________
2SSRS@Gen5diy is offline   Reply With Quote
Old 12-06-2009, 05:32 PM   #4
UCI CamaroFan
Zot!
 
UCI CamaroFan's Avatar
 
Drives: Toyota 4Runner
Join Date: Feb 2009
Location: Orange County, California
Posts: 1,332
Quote:
Originally Posted by F N MUSCLE View Post
I know that there have been other posts about this, but I thought I would check and see if anyone has recently had any issues with the clutch pedal sticking on our cars. I drive a 2SS M6. Yesterday I was takin my buddies for a ride, waiting at the light with clutch in and in first gear. Light turns green, I slowly let the clutch out and hit the gas and the car just revs. I am like WTF!!! I go to press the clutch in and its stuck half way. I eventually get the clutch pedal down, shift into neutral then back into first and go to let the clutch out again....same deal. After a few seconds, the clutch pedal final releases and we are off with the sweet smell of burnt clutch. Didn't have any problems after that. Still freaked me out. Should I take it in? What do you guys think?
I too have had this problem.

It was trying to do a semi hard launch, and all it would do is just sit there... Really smelled that burnt clutch.
__________________
UCI CamaroFan is offline   Reply With Quote
Old 12-06-2009, 05:42 PM   #5
lrc250
480 HP 2010 2SS
 
lrc250's Avatar
 
Drives: 2010 Camaro 2SS
Join Date: Sep 2008
Location: Eastern, NC
Posts: 324
I had it happen to me once as well. I was going to do a burnout at the local drag strip and the pedal stayed down and the car just sat there with a big cloud of smoke coming from the clutch.
__________________
Without data you are just another person with an opinion.
1100 :10/15/08
3000:3/2609
3300:4/18/09
3400 (broadcast)April 25, 2009
3800 (produced):May 4, 2009 #7470
4200 (Shipped): June 1, 2009
5000 (At Dealer) June 9,2009

374.9 rwhp & 371.7 rwtq - bone stock @ 85 deg.
lrc250 is offline   Reply With Quote
Old 12-06-2009, 07:08 PM   #6
F N MUSCLE
 
F N MUSCLE's Avatar
 
Drives: Black 1SS/RS, manual
Join Date: Jul 2009
Location: Chatsworth, CA
Posts: 57
Quote:
Originally Posted by lrc250 View Post
I had it happen to me once as well. I was going to do a burnout at the local drag strip and the pedal stayed down and the car just sat there with a big cloud of smoke coming from the clutch.
OUCH!!! Not a fun feeling.
F N MUSCLE is offline   Reply With Quote
Old 12-06-2009, 07:11 PM   #7
F N MUSCLE
 
F N MUSCLE's Avatar
 
Drives: Black 1SS/RS, manual
Join Date: Jul 2009
Location: Chatsworth, CA
Posts: 57
Quote:
Originally Posted by 2SSRS View Post
Guys i have been on the corvette forum for 3 1/2 years and from day one that has been a problem with the vett, That is why they made a Sticky out of this thread.

http://forums.corvetteforum.com/c6-z...-and-cure.html

Now for the bad in the camaro.

1: We use the brake reservoir and not a separate Clutch Fluid reservoir.
2: The brake reservoir we have dos not have a cap that is airtight,
3: By not having an airtight seal the brake Fluid starts to boiling faster and in humid place's some amount of water may get in and bring down the boiling point for the Fluid
4: in the camaro we run dot3 and in the VETT it is dot4.

So this is one thing that i do is change the Clutch Fluid after some hard driving or as soon as the pedal starts to fell hard, At that time you can see the color has gone from amber to a gold or brown-red, Here is some thing that i think we need to do, Put on a separate Clutch Fluid reservoir with an airtight cap.

And update to a dot4 i know that want fix all the Clutch Pedal Issues but it will help some if not a lot of members.IMO
Thanks for the advice! I dunno. I was thinkin about takin it in to the dealership cuz I need to throw my hurst short throw shifter on, but don't want them to see that and be like oh sorry that voids your clutch/gear warranty.
F N MUSCLE is offline   Reply With Quote
Old 12-06-2009, 07:35 PM   #8
lawdogg149
 
lawdogg149's Avatar
 
Drives: Corvette ZO6 CSR edition #47
Join Date: Apr 2009
Location: Calhoun, GA
Posts: 741
Stock clutch want handle the power even the stock motor has when pushed. I burnt mine out the first trip to the strip. Replaced with fidanza twin disk from MAperformance. No problems now even with the turbo pushing 628 rwhp. Rev it up dump it no problems.
__________________
Nationwide Turf
"artificial turf factory"
lawdogg149 is offline   Reply With Quote
Old 12-06-2009, 10:18 PM   #9
mitchellmcfly2010
 
mitchellmcfly2010's Avatar
 
Drives: 07 Chevy Avalanche
Join Date: Apr 2009
Location: New Orleans
Posts: 78
I was out driving today and had the worst "burnt clutch smell", but no stick, anybody else?
mitchellmcfly2010 is offline   Reply With Quote
Old 12-07-2009, 12:53 AM   #10
camaro5


 
camaro5's Avatar
 
Drives: Off Into The Sunset
Join Date: Mar 2008
Location: Cape Coral, Florida
Posts: 4,430
I will add a separate clutch fluid resevoir, and change the fluid just like the Vette. Then she no sticky.
camaro5 is offline   Reply With Quote
Old 12-07-2009, 09:46 AM   #11
JICPerformance
Here to make you faster
 
Drives: 2005 GTO supercharged 2009 GXP
Join Date: Apr 2009
Location: Atlanta, GA
Posts: 126
Quote:
Originally Posted by TAG UR IT View Post
Hrm....my issue is when really hitting it hard...shifting fast through the gears. The cluch pedal likes to stay down halfway. I don't lose ANY momentum...the cars goes w/ no issue. It's just that the damn clutch pedal stays down on the floor. Feels like I won't be able to shift again.

What the hell am I supposed to do about that??
Install a GM LS7 clutch and flywheel. You will lose about 7-10 HP at the rear wheels but it drives great and will handle 500 rwhp without a problem.
JICPerformance is offline   Reply With Quote
Old 12-07-2009, 12:44 PM   #12
2SSRS@Gen5diy
Salt & Pepper 2014 Z/28

 
2SSRS@Gen5diy's Avatar
 
Drives: 2010 2SS IOM ,2014 Z/28, 66 Nova
Join Date: Oct 2008
Location: By the lake in AZ
Posts: 11,653
It was posted by OrangeChevyII that the LS7 clutch is the clutch in the LS3 Camaro's.
__________________

Last edited by 2SSRS@Gen5diy; 12-07-2009 at 05:42 PM.
2SSRS@Gen5diy is offline   Reply With Quote
Old 12-07-2009, 04:00 PM   #13
Vinz68
 
Vinz68's Avatar
 
Drives: 68,69,72&10 Camaro's 12 CTS-V
Join Date: Sep 2009
Location: Hampton Bays,NY
Posts: 193
Same thing happened to me yesterday!! Took a buddy for a ride to show him launch control and the peddal only released half way.... Glad to see I'm not the only one who had this problem.I'm going to do a clutch and flywheel this winter when I install the supercharger.
Vinz68 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch fluid contamination problems on Vette fixed for Camaro??? LDGn63 V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) 11 05-28-2012 09:17 PM
Oil Change Ramp mjlash22 Mechanical Maintenance: Break-in / Oil & Fluids / Servicing 17 01-21-2010 10:40 PM
clutch sticking to floor BatmanX Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 6 11-21-2009 03:39 PM
Clutch sticking again KATHY63 Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 13 09-21-2009 07:50 PM
Burned my clutch a bit with Launch Control.... Caution you guys... Embalmer 5th Gen Camaro SS LS LT General Discussions 49 04-23-2009 08:49 PM


All times are GMT -5. The time now is 10:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.