Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
TireRack
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Suspension / Brakes / Chassis

Suspension / Brakes / Chassis All suspension, brakes and chassis discussions.

Reply
 
Thread Tools
Old 03-02-2010, 10:40 AM   #1
Kurtisp
 
Kurtisp's Avatar
 
Drives: 2010 Camaro 2SS/RS Inferno Orange
Join Date: Jan 2010
Location: Thibodaux, LA
Posts: 64
is this normal??

this is after Eibach lowering springs, off jack on the ground, just curious if this is normal?
Attached Images
 
Kurtisp is offline   Reply With Quote
Old 03-02-2010, 10:57 AM   #2
Mike TexaSS
 
Drives: 454 LS7 Camaro SS
Join Date: Jun 2009
Location: Houston
Posts: 380
No
Mike TexaSS is offline   Reply With Quote
Old 03-02-2010, 10:59 AM   #3
g-townmach
I FARTED
 
g-townmach's Avatar
 
Drives: 2010 2SS/RS
Join Date: Nov 2009
Location: cen-tex
Posts: 874
Yes
__________________
g-townmach is offline   Reply With Quote
Old 03-02-2010, 11:01 AM   #4
BEARS-SS
 
BEARS-SS's Avatar
 
Drives: 2010 Camaro 2SS/RS
Join Date: Feb 2010
Location: Yorktown, Virginia
Posts: 454
I guess I'll help out with....maybe?
__________________
BEARS-SS is offline   Reply With Quote
Old 03-02-2010, 11:11 AM   #5
2010 SSRS



 
2010 SSRS's Avatar
 
Drives: 3 V8 Camaros
Join Date: May 2009
Location: The Ocean State
Posts: 123,973
HAHHHHH
2010 SSRS is offline   Reply With Quote
Old 03-02-2010, 11:11 AM   #6
SSMickey
SECC
 
SSMickey's Avatar
 
Drives: 2010 IBM 2SS
Join Date: Feb 2010
Location: Columbia S.C.
Posts: 1,428
It's fine. I went out and looked at mine, stock suspension and no front end noise. I have about the same gap as you do.
__________________
Vengeance Stage II Cam, Halltech CAI, RX Catch Can, Full ARH Exhaust, QTP Cutouts, Powerbond 25% Underdrive, MGW Shifter, MTI Drop Springs, Forgeline RB3C Wheels, 3.91 gears, Night Owl LED Control System
SSMickey is offline   Reply With Quote
Old 03-02-2010, 11:19 AM   #7
g-townmach
I FARTED
 
g-townmach's Avatar
 
Drives: 2010 2SS/RS
Join Date: Nov 2009
Location: cen-tex
Posts: 874
Go look at PQ's long thread when he installed his springs. There's good explanations on why this is normal. When the suspension is loaded is creates this gap
__________________
g-townmach is offline   Reply With Quote
Old 03-02-2010, 11:20 AM   #8
jeancarlo
 
Drives: Chevrolet
Join Date: Mar 2010
Location: Costa Rica
Posts: 3
I think that is normal, I donīt see anything wrong
jeancarlo is offline   Reply With Quote
Old 03-02-2010, 12:11 PM   #9
Kurtisp
 
Kurtisp's Avatar
 
Drives: 2010 Camaro 2SS/RS Inferno Orange
Join Date: Jan 2010
Location: Thibodaux, LA
Posts: 64
thanks for the info, im going get it alligned today, i'll see what they say
Kurtisp is offline   Reply With Quote
Old 03-02-2010, 01:53 PM   #10
Mr Twisty


 
Mr Twisty's Avatar
 
Drives: the 2nd amendment home
Join Date: May 2008
Location: OK
Posts: 14,386
Quote:
Originally Posted by Kurtisp View Post
thanks for the info, im going get it alligned today, i'll see what they say
If they say it's not normal, take your car someplace else, because it is.
__________________
"They that can give up essential liberty to obtain a little temporary safety deserve neither liberty nor safety."
-- Benjamin Franklin
Great Racing Quotes

"Never run out of real estate, traction and ideas at the same time."
"I was doing fine until about mid-corner when I ran out of talent."
"Don't brake until you see God, just don't meet him"
Mr Twisty is offline   Reply With Quote
Old 03-02-2010, 03:50 PM   #11
camarowa

 
camarowa's Avatar
 
Drives: 2013 SVT Raptor, sold 2010 Camaro
Join Date: Jul 2009
Location: PNW....almost canada
Posts: 1,899
sure hope it is normal as i have the same gap after the pfadt springs. Pretty sure it is as I am having no issues what so ever.
__________________
- Pfadt Suspension Package; Springs & Sways
- Brembo Brake Upgrade (Yellow); Courtesy Fesler Built
- Custom Magnaflow Exhaust
- Blacked-Out Bowties & RS Emblems, Front bowtie delete
- Full Dynamat Extreme Trunk Coverage
- Tinted side markers
- Interior DSV Customs Leather Upgrades
- Airaid CAI V2
- Forgestar F14 Gunmetal 20x9, 20x11
- Doug Thorley Shorties
camarowa is offline   Reply With Quote
Old 03-02-2010, 04:08 PM   #12
PfadtRacing
 
PfadtRacing's Avatar
 
Drives: 2010 Camaro, 2006 Z06
Join Date: Feb 2009
Location: SLC, UT
Posts: 3,375
Agreed. This is normal. You can sleep well tonight!
PfadtRacing is offline   Reply With Quote
Old 03-02-2010, 04:17 PM   #13
Bruce@raymondsperformance
 
Bruce@raymondsperformance's Avatar
 
Drives: 2010 camaro
Join Date: Sep 2009
Location: Indy
Posts: 708
I second that it is normal.
Bruce@raymondsperformance is offline   Reply With Quote
Old 03-02-2010, 04:26 PM   #14
sykb47l
 
sykb47l's Avatar
 
Drives: 73' VW Bug
Join Date: Sep 2008
Location: San Antonio, TX
Posts: 730
Yep im stock and have that.
__________________
sykb47l is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Is this noise normal? For LS3 M6 owners only. CamaroSS_LS3 V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) 57 06-19-2012 02:39 PM
a few camaro issues- normal? or problems? Arachnyd Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 11 05-20-2010 11:13 AM
Is this normal...? MCSDS Camaro V6 LLT Engine, Exhaust, and Bolt-Ons 10 03-01-2010 10:20 PM
Is it normal to have a funny smell after exhaust? Jeanius Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 7 01-08-2010 12:50 AM
Great Read and Info on Oil Weight Banshee Mechanical Maintenance: Break-in / Oil & Fluids / Servicing 1 11-23-2009 10:03 PM


All times are GMT -5. The time now is 07:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.