Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Cold Air Inductions
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 06-22-2010, 10:51 PM   #43
dwade76
 
dwade76's Avatar
 
Drives: Camaro 2LT RS
Join Date: May 2010
Location: Schenectady, NY
Posts: 23
hey guys sorry for just getting back to this. I got it back from the dealership and they toldd me it was a ground wire from the engine to body that was connected all the way. They connected it all the way extra tight and my baby is running amazing now.
dwade76 is offline   Reply With Quote
 
Reply

Tags
engine, low power

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Automatic Transmission Problems Kyzer Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 18 06-25-2016 07:36 PM
1st and 2nd gear problems. 1SS 6M jnm2003 V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) 6 08-17-2010 01:06 PM
Long Problem(s) GM techs or someone needed here... xpanda305x Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 37 07-04-2010 02:00 PM
Potential Solutions to Radio Problems The_Blur Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum 17 11-10-2009 10:23 PM
Does an axle back have the same problems as a cat back? G.E. Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 2 09-15-2009 03:31 PM


All times are GMT -5. The time now is 10:14 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.