Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
JDP Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Member Car Journals


Reply
 
Thread Tools
Old 11-20-2009, 11:15 AM   #43
montej23

 
montej23's Avatar
 
Drives: 2011 VR Camaro
Join Date: Jun 2009
Location: Arkansas
Posts: 975
good luck hope it works now
montej23 is offline   Reply With Quote
Old 11-20-2009, 10:07 PM   #44
zebra
just can't seem to leave
 
zebra's Avatar
 
Drives: your mom wild!!
Join Date: Oct 2008
Location: cold & windy
Posts: 10,520
thanks y'all!

still ain't got time to fill in the details, but here's a quick summary of where i'm at:
everything's been running and driving fine-ish... the idle's set at 700 but it's been hanging around 475-500 (i'm guessing there might be a vacuum leak somewhere because i ain't getting a IAC code ). the message center keeps flashing the red battery picture although the battery & alternator test fine. i think the speedometer calibration is off because sometimes, it ain't mathemetically accurate to the tach (i offhandedly remember certain speeds/RPMs/gear for my truck from when i was considering a transmisison swap). as to how much it's off, i'll have to sit down with a calculator & cypher it out. the tuner says he put the correct tire size & diff in the tune, so...

that's about where it stands as of now
__________________
zebra is offline   Reply With Quote
Old 11-22-2009, 05:04 PM   #45
zebra
just can't seem to leave
 
zebra's Avatar
 
Drives: your mom wild!!
Join Date: Oct 2008
Location: cold & windy
Posts: 10,520
pictures are back
__________________
zebra is offline   Reply With Quote
Old 11-22-2009, 09:37 PM   #46
cerberus
 
cerberus's Avatar
 
Drives: 2010 CGM
Join Date: Nov 2008
Location: St. Charles MO
Posts: 511
Just read this whole thread...man, I was laughing/sad/happy...you right I betcha there ain't nobody doing this. But man you got it working, congrats, Enjoy, it was well worth it and glad everything worked out for you.

I too was waiting for something about a Camaro but man, you got me too!!
__________________
2 SS CGM RS, IOM interior, Customized by Clean Cut Creations St. Louis, MO
cerberus is offline   Reply With Quote
Old 12-04-2009, 11:34 PM   #47
zebra
just can't seem to leave
 
zebra's Avatar
 
Drives: your mom wild!!
Join Date: Oct 2008
Location: cold & windy
Posts: 10,520
Quote:
Originally Posted by cerberus View Post
Just read this whole thread...man, I was laughing/sad/happy...you right I betcha there ain't nobody doing this. But man you got it working, congrats, Enjoy, it was well worth it and glad everything worked out for you.

I too was waiting for something about a Camaro but man, you got me too!!
thanks it's been a fun project & well worth the extra time & effort (and gas).

december 4 2009
so a lot's happened over the past couple weeks...
mostly just getting random little parts & trying to tweak stuff.

i just seafoamed it yesterday morning, put my new spark plugs in, i've replaced the EGR & PCV valves and fixing to change the oil again. i'm thinking i might have to replace the IAC valve because, even after cleaning it twice, the engine still idles around 475-500 instead of the 700 set in the tune and when the motor's cold, it'll jump to & hang around 2000rpm for a few seconds upon startup.

my speedometer & odometer are also out of whack (i think it's the tune). they're both reading 12% low (on average). after doing a little math, i think Jesse programmed it as a 4.10 rear instead of my 3.73 - i'll need to get some more numbers to crunch to make sure

also, i keep getting a flashing battery light on the message center - apparently 99 model trucks getting newer motor swaps don't like the way it talks to the alternator or something because it keeps showing P1638 (generator terminal code) even though nothing's wrong. i talked to a few guys who do swaps & they said they've seen it a few times - it just has to have that code tuned out.

that's about all that's noteworthy for now.

ps - after the new seafoam-and-gunk-less oil, i might get to have a little more fun!! the clutch's good & broke in now!!
__________________
zebra is offline   Reply With Quote
Old 12-05-2009, 07:57 AM   #48
PQ
Booooosted.
 
PQ's Avatar
 
Drives: 2010 Supercharged SS
Join Date: Apr 2008
Location: Mobile, AL
Posts: 36,712
Send a message via Yahoo to PQ











__________________
PQ is offline   Reply With Quote
Old 04-27-2010, 12:20 AM   #49
zebra
just can't seem to leave
 
zebra's Avatar
 
Drives: your mom wild!!
Join Date: Oct 2008
Location: cold & windy
Posts: 10,520
so, after talking with MTI Racing & Tom Henry last weekend, they've helped push me over the boosted cliff Chris & Kyle - y'all're gonna be the death of my bank account after letting me drive like that :(

but still, that's got me thinking...
mp112 or tvs1900 - both are pretty comparable from what i'm reading & both are fine for a daily-driven 5.3 with 105k on the clock. right now, the thought would be 5-6psi, but i'm open to suggestions.

i'm really new to forced induction (because until now, i've been pretty opposed to going that far), so please offer your comments & suggestions - i'm all ears.
__________________
zebra is offline   Reply With Quote
Old 04-28-2010, 09:37 PM   #50
zebra
just can't seem to leave
 
zebra's Avatar
 
Drives: your mom wild!!
Join Date: Oct 2008
Location: cold & windy
Posts: 10,520
and thanks to Jamie Mac for making me dead set on my quest for the ever elusive Hurst shifter for my truck - they stopped making them a year & a half ago. :( so if anybody happens to run across a Hurst Competition Plus Shifter for the 99-03 silverado/sierra, please let me know (part #3910122)
__________________
zebra is offline   Reply With Quote
Old 05-03-2010, 04:08 PM   #51
Milk 1027
Camaro➎ moderator
 
Milk 1027's Avatar
 
Drives: '13 BLK 1LE
Join Date: Aug 2008
Location: AZ
Posts: 13,519
should've done an LS3 conversion........









jk




I'd go with a TVS. Proven, reliable technology.
__________________
Milk 1027 is offline   Reply With Quote
Old 05-03-2010, 07:37 PM   #52
zebra
just can't seem to leave
 
zebra's Avatar
 
Drives: your mom wild!!
Join Date: Oct 2008
Location: cold & windy
Posts: 10,520
building a 408 would make about the same power, cost about the same (maybe less), and be easier...

yeah the TVS is the awesomer of the two, but costs so daggum much!!
i know, i know: cheap, fast, reliable - pick two
__________________
zebra is offline   Reply With Quote
Old 09-06-2010, 12:21 PM   #53
zebra
just can't seem to leave
 
zebra's Avatar
 
Drives: your mom wild!!
Join Date: Oct 2008
Location: cold & windy
Posts: 10,520
thanks to Speedy1975, i've got a vid of me running at C5F





figures... Doug just had to make me look that much slower that i already am!
__________________
zebra is offline   Reply With Quote
Old 09-06-2010, 09:24 PM   #54
zebra
just can't seem to leave
 
zebra's Avatar
 
Drives: your mom wild!!
Join Date: Oct 2008
Location: cold & windy
Posts: 10,520
and since then, i've added some Bilsteins to take care of the bouncing (the old shocks literally had no charge left in them ), and i dropped 36 unsprung lb by swapping to the aluminum wheels i bought at Summit on the way down there
__________________
zebra is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:18 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.