Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Gen5DIY
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Suspension / Brakes / Chassis

Suspension / Brakes / Chassis All suspension, brakes and chassis discussions.

Reply
 
Thread Tools
Old 09-13-2010, 01:59 PM   #1
Merc
COTW 12/5/11
 
Merc's Avatar
 
Drives: 2010 Camaro 2SSRS IOM
Join Date: May 2009
Location: Abbotsford BC Canada
Posts: 8,397
TCI Line Lock

Has anybody installed a TCI line lock?
Merc is online now   Reply With Quote
Old 09-13-2010, 03:26 PM   #2
MillerTime
Blowin the doors off!
 
MillerTime's Avatar
 
Drives: A 2013 SS RS 6M SR
Join Date: Apr 2010
Location: Phoenix, AZ
Posts: 2,402
+1 lookin to put one in and would like info as well.
__________________

2G1FS1EWXD9163847





MillerTime is offline   Reply With Quote
Old 09-13-2010, 03:33 PM   #3
Merc
COTW 12/5/11
 
Merc's Avatar
 
Drives: 2010 Camaro 2SSRS IOM
Join Date: May 2009
Location: Abbotsford BC Canada
Posts: 8,397
Quote:
Originally Posted by MillerTime View Post
+1 lookin to put one in and would like info as well.

There is an issue with there line lock, that I am trying to resolve. I would not buy a TCI line lock right now. Once the issue is resolved I will post again.
Merc is online now   Reply With Quote
Old 09-13-2010, 05:06 PM   #4
Merc
COTW 12/5/11
 
Merc's Avatar
 
Drives: 2010 Camaro 2SSRS IOM
Join Date: May 2009
Location: Abbotsford BC Canada
Posts: 8,397
Made several calls to TCI today trying to resolve the brake line fitting issue. No sucess I am blown off for another day. Buyer beware of TCI.
Merc is online now   Reply With Quote
Old 09-13-2010, 06:29 PM   #5
Z Madness
 
Z Madness's Avatar
 
Drives: 2010, 2000, 1971 Camaros
Join Date: May 2010
Location: Hawaii
Posts: 529
What problems did you have? I purchased a set from Spohn Performance which where the TCI and mine seems to be fine. Just curious to see what you issues were/are.
Z Madness is offline   Reply With Quote
Old 09-13-2010, 07:04 PM   #6
Merc
COTW 12/5/11
 
Merc's Avatar
 
Drives: 2010 Camaro 2SSRS IOM
Join Date: May 2009
Location: Abbotsford BC Canada
Posts: 8,397
Quote:
Originally Posted by Z Madness View Post
What problems did you have? I purchased a set from Spohn Performance which where the TCI and mine seems to be fine. Just curious to see what you issues were/are.

Heres the problem. The brass fitting is not tapped deep enough to get the stock brake line to seal. So what happens is the stock flair nut bottoms out in the brass fitting before the double flair seats. Creates a massive brake fluid leak. We have searched high and low for a re-placement brass fitting, no luck. We tried finding a flair nut for the purpose of making a tap to fix the brass fitting. No luck. I made several calls to TCI tech line today. All I am asking for is a spare brass fitting and a flair nut to make a tap. I have been jerked around all day. I am being told they have to wait til some dude comes out of a meeting to OK them sending me $2 worth of parts. Another option would be to us a dremel with a cut off wheel and shorten the stock flair nut. Very delicate work and I refuse to do that to the stock brake line, to make there junk work. Not to mention were doing jack shit stuff on a braking system of a very fast car.

IT'S TOTAL GARBAGE!
Merc is online now   Reply With Quote
Old 09-13-2010, 07:24 PM   #7
Z Madness
 
Z Madness's Avatar
 
Drives: 2010, 2000, 1971 Camaros
Join Date: May 2010
Location: Hawaii
Posts: 529
I feel your frustration. Mine went on fine, though I do have a V-6. I believe the kits are the same for both but I have not had any issues. Maybe they sent you the incorrect nut. Needing an ok to get a $2 part sucks. I went through Spohn and not TCI but didn't have any issues for them to resolve. I used Spohn parts on my 4th gen is why I went with them for the line lock. I saw another line lock on another car that tapped in near the ABS system as opposed to TCI which is right at the master cyclinder. Hope you get this fixed.
Z Madness is offline   Reply With Quote
Old 09-13-2010, 07:26 PM   #8
Z Madness
 
Z Madness's Avatar
 
Drives: 2010, 2000, 1971 Camaros
Join Date: May 2010
Location: Hawaii
Posts: 529
Oh, forgot to mention. I switched from the tap they included to an inline fuse. Much better connection.
Z Madness is offline   Reply With Quote
Old 09-13-2010, 07:29 PM   #9
Merc
COTW 12/5/11
 
Merc's Avatar
 
Drives: 2010 Camaro 2SSRS IOM
Join Date: May 2009
Location: Abbotsford BC Canada
Posts: 8,397
Quote:
Originally Posted by Z Madness View Post
I feel your frustration. Mine went on fine, though I do have a V-6. I believe the kits are the same for both but I have not had any issues. Maybe they sent you the incorrect nut. Needing an ok to get a $2 part sucks. I went through Spohn and not TCI but didn't have any issues for them to resolve. I used Spohn parts on my 4th gen is why I went with them for the line lock. I saw another line lock on another car that tapped in near the ABS system as opposed to TCI which is right at the master cyclinder. Hope you get this fixed.
I went with TCI because it tapped into the master cylinder and was kind of hidden out of the way. I have lots of custom parts and paint under the hood and did not want the selinoid sticking out like a sore thumb.
Merc is online now   Reply With Quote
Old 09-13-2010, 07:31 PM   #10
Z Madness
 
Z Madness's Avatar
 
Drives: 2010, 2000, 1971 Camaros
Join Date: May 2010
Location: Hawaii
Posts: 529
Yes, I liked the location of the install. Hope they get you the correct fittings FOR FREE! Good luck to you.
Z Madness is offline   Reply With Quote
Old 09-13-2010, 07:33 PM   #11
Merc
COTW 12/5/11
 
Merc's Avatar
 
Drives: 2010 Camaro 2SSRS IOM
Join Date: May 2009
Location: Abbotsford BC Canada
Posts: 8,397
Quote:
Originally Posted by Z Madness View Post
Oh, forgot to mention. I switched from the tap they included to an inline fuse. Much better connection.
My system is powered from the the hot post under the hood and I have a weather pack connection hidden under dash for the activation switch which is attached temporarly to the e-brake handle. The reason for that is, I remove it after Friday Night Street Legals.
Merc is online now   Reply With Quote
Old 09-14-2010, 11:44 AM   #12
Merc
COTW 12/5/11
 
Merc's Avatar
 
Drives: 2010 Camaro 2SSRS IOM
Join Date: May 2009
Location: Abbotsford BC Canada
Posts: 8,397
TCI has agreed to send me a couple more brass fitting, hopefully that will work. Failing that they are sending a couple of flare nuts for the purpose of making a tap to run the threads deeper into the brass fitting.
Merc is online now   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DIY Brake Calipers Rotors and Line Removal Gotthat02fire Camaro DIY & HOW-TO instructions & discussions 31 02-14-2012 06:52 PM
2nd Gen. Line Lock Kit carsismeZ06 1st & 2nd Generation Camaros 2 05-29-2010 11:58 AM
2010 Camaro Line Lock Kit? Windy City Wheels and Tires Talk Sponsored by The Tire Rack 15 11-09-2009 10:05 PM
# of Cars on Line...? carguy 5th Gen Camaro SS LS LT General Discussions 6 06-09-2009 11:32 AM


All times are GMT -5. The time now is 10:15 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.