Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
DJ Grilles
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > 5th Gen Camaro SS LS LT General Discussions

5th Gen Camaro SS LS LT General Discussions General 5th generation Camaro topics not covered by other subforums.

Reply
 
Thread Tools
Old 01-27-2011, 11:11 PM   #1
BIGSWOLE
 
BIGSWOLE's Avatar
 
Drives: 2010 Cyber Grey 2SS/RS (L99)
Join Date: Dec 2010
Location: Luling,LA.
Posts: 109
CARS DRIVING BAD

I just got my car back yesterday and I am so disgusted right now.I was in a accident a couple of months ago;front end damage,supposedly no damage to the drivetrain.I picked the car up yesterday and it look really good but didnt really get on it cause its been sitting up for a couple of months,I figured I'de wait at least a day.Before I went to bed last night I did the fuse pull because the fear that crappy gas was put in at the dealer.Drove the car all day,it runs fine if your driving normal.Well, tonight I got on it and it will take off nice in fast but whenever it shifts to third from second its almost redlining and then nothing for a second.It just kind of revs like the trans isn't catching.Once it drops down to about 4000 rpm's it will catch and start to acc. again,almost redlining.After all this it will start to acc. normal for a couple of seconds then start to screw up again.I went home and looked under the hood to see if something was unplugged or something,but everything looked fine.So I let the car sit for awhile and took it back out to see if it happened again and it does everytime you get on it.

Im sorry this is so long,just want to describe this the best I can.I know there are some really knowledgable people on this forum.Can someone please tell me what is wrong with my car.
BIGSWOLE is offline   Reply With Quote
Old 01-27-2011, 11:29 PM   #2
Gavros 4 Life
 
Gavros 4 Life's Avatar
 
Drives: 2SS/RS Summit White Black Stripes
Join Date: May 2010
Location: New Jersey
Posts: 383
that sucks :( if you got your warranty still make them fix it nothing less $=0
Gavros 4 Life is offline   Reply With Quote
Old 01-27-2011, 11:33 PM   #3
ffrcobra_65
Account Suspended
 
Drives: SuperCharged 2SS/RS IOM MN6
Join Date: May 2009
Location: CA
Posts: 5,104
sounds like the tranny is slipping. If dealer doesn't cover it under warranty due to the accident history, I would contact your insurance and let them know they they might have under-estimated the damage. I am sure they'll send you to get it estimated and confirm the mechanical damage and they'll take care of the cost.
ffrcobra_65 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How bad is it??? Susantroy1 Off-topic Discussions 5 10-27-2009 11:32 PM
Ontario (Canada) Highway Traffic Act.. read so you dont lose your car sigma_1966 Canada 10 08-11-2009 05:51 PM
Pictures of classic cars driving in to park at Stafforclassics car show Camaro68 USA - Southeast 0 06-13-2009 09:36 PM
To owners...how bad are the blind spots while driving? Ant 5th Gen Camaro SS LS LT General Discussions 52 05-25-2009 02:20 PM


All times are GMT -5. The time now is 12:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.