Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
HeadlightArmor
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Other Generations > 3rd Generation Camaros

3rd Generation Camaros 1982-1992 Camaros

Reply
 
Thread Tools
Old 04-10-2011, 08:29 PM   #1
B2k4E
Listen to cereal guy...
 
B2k4E's Avatar
 
Drives: 1986 Z28 Camaro 383 TPI
Join Date: Apr 2011
Location: Amarillo, Texas
Posts: 293
Exclamation Possible IAC (Idle air control) Valve problem

Some of you might have seen my rear end help thread, but now I've run into a new problem... Every time I go into any gear that puts power to the ground (OD, D, 1, 2, R) the camaro seems to propel itself without me even touching the accelerator. Usually hovers around 10-15mph by itself and I have to intervene by using the brakes by which no doubt is wearing the brakes down and causing stress on the engine. The engine in my 86 camaro is a 350 TPI.

My father says it's the IAC valve but I'm wondering if anybody has had a problem like this?

If it is the IAC valve; where is it and how do you go about uninstalling then reinstalling it, and reseting it to the correct idle speed?

Also noticed that the tachometer runs about 2300 RPM when in park and 1300-1600 RPM when in drive pressing on the brakes. The tach might be off but I doubt it.

Any help/advice would be appreciated, so close to getting this thing drivable. Got a fan harness and relay to fix the fan issue and a new pinon seal for the rear end on the way. (After some inspection it looks like the original seal is done for)
B2k4E is offline   Reply With Quote
Old 04-10-2011, 08:49 PM   #2
GRASSHOPPER
 
Drives: 1987 z28
Join Date: Jan 2011
Location: callander, ontario, can
Posts: 49
look at your engine emisions sticker under the hood, i think your idle is way too high and that is why it moves so easily when in gear. it could be 1 of several sensors not working right, check your engine codes it might tell you which one is shot
good luck
GRASSHOPPER is offline   Reply With Quote
Old 04-10-2011, 08:55 PM   #3
B2k4E
Listen to cereal guy...
 
B2k4E's Avatar
 
Drives: 1986 Z28 Camaro 383 TPI
Join Date: Apr 2011
Location: Amarillo, Texas
Posts: 293
Quote:
Originally Posted by GRASSHOPPER View Post
look at your engine emisions sticker under the hood, i think your idle is way too high and that is why it moves so easily when in gear. it could be 1 of several sensors not working right, check your engine codes it might tell you which one is shot
good luck
Only thing is that Z28's in 1986 had a 305 TPI, the guy I bought it off of had the original engine taken out and a 350 TPI bored over to a 383 stroker put in it. So idk if the emission sticker will match it. My dad's pretty sure it's the IAC, but I'm just trying to cover all the bases. When I read your idle problem on the IROC youre getting I almost wondered if our problems are similar.

Just found out that the emission sticker is gone, so cant go by that.
B2k4E is offline   Reply With Quote
Old 04-12-2011, 06:13 PM   #4
GRASSHOPPER
 
Drives: 1987 z28
Join Date: Jan 2011
Location: callander, ontario, can
Posts: 49
you might have to just start trial and error on the sensors, i have the manuals from the factory shops but i have not had the time to look them over yet
if i find anything i will let you know, but i don`t know when i will have the time
GRASSHOPPER is offline   Reply With Quote
 
Reply

Tags
3rd gen, engine, iac valve, idle air control valve

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DIY: LS3 Camshaft Install (a lot of pictures, may take a moment to load) robertway Camaro DIY & HOW-TO instructions & discussions 253 09-02-2014 03:16 PM
Help You and Your Ride Breath Easier GmPartsDirect.com V8 Bolt-Ons & Tunes 0 03-30-2011 04:49 PM
\\\\\\K&N INTAKES BLOW OUT SALE +FREE SHIPPING////// GmPartsDirect.com V8 Bolt-Ons & Tunes 2 03-29-2011 04:27 PM
How to see if oil is in intake manifold? CamaroC-17 5th Gen Camaro SS LS LT General Discussions 53 03-23-2011 05:06 PM
Why RAM Air is a myth!!! Long Read (Wall of text) live2well Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 80 11-02-2009 03:34 PM


All times are GMT -5. The time now is 08:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.