Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
BeckyD@RodgersChevrolet
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Other Generations > 4th Generation Camaros

4th Generation Camaros 1993-2002

Reply
 
Thread Tools
Old 09-30-2011, 05:57 PM   #1
davidbecker
 
Drives: 1998 camaro
Join Date: Sep 2011
Location: ohio
Posts: 26
Help Please

I have a 98 camaro base w/ 3.8. I will not run right. it seems to idle ok but has no power driving down the road. it seems like something is holding it back. i have replaced the plugs ,wires, crank sensor. the check engine light is throwing 3 codes 1 is for the egr valve the other 2 is for misfire. i did disconnect the egr valve and blocked of the holes. i was told that is why its has no power that i need the egr. is that true?
davidbecker is offline   Reply With Quote
Old 09-30-2011, 06:01 PM   #2
dmginc


 
dmginc's Avatar
 
Drives: 01 Jeep/11 HHR/14 Camaro 1LS
Join Date: Mar 2011
Location: Freeville, NY
Posts: 3,061
try reconnecting the EGR and see what happens? sounds like a clogged fuel filter or a bad fuel pump to me.
__________________

CAI Cold Air Intake, BMR Strut Tower Brace, Gen5DIY Fog Lights,
Big Worm Third Brake Light/Side Marker Tint (Charcoal), GTS Tail Light Covers,
Purple Under Hood Lighting, Purple Gill Inserts, Purple Hood Vinyl,
Magnaflow Resonated X-Pipe w/ Muffler Delete
dmginc is offline   Reply With Quote
Old 09-30-2011, 06:06 PM   #3
fielderLS3


 
fielderLS3's Avatar
 
Drives: 02 Alero, 2011 Mustang 5.0
Join Date: Mar 2010
Location: Portage, Wisconsin
Posts: 4,236
My father had an EGR valve go bad on a car, and it only affected the idle. I don't think they can route enough exhaust back into the engine to effect it that much under a load.

There are a lot of reasons it could be down on power. Weak fuel pump, bad compression, weak coil/spark (you do have misfires), a plugged up catalytic converter, sensors, etc...
__________________
"Proven V-8 power with better efficiency than a turbo V-6"

"The car is the closest thing we will ever create to something that is alive."eds.
fielderLS3 is offline   Reply With Quote
Old 10-01-2011, 12:31 AM   #4
davidbecker
 
Drives: 1998 camaro
Join Date: Sep 2011
Location: ohio
Posts: 26
thanks for all the fast responces. I did not think the EGR valve would do that either. the car runs but not very well. even on very wet roads from a stop , flooring it will not spin the tires it just climbs speed slowly. also i have noticed today that my fuel economy is crap.im getting about 200-250 miles to a full tank of gas :(. could it be my TPS? im sorry im new to thesde and just trying to figure out what is what. as i dont want to get ride of it as the body has no rust at all. its very solid
davidbecker is offline   Reply With Quote
Old 10-01-2011, 10:39 AM   #5
Ant32894
Youjellybra?
 
Ant32894's Avatar
 
Drives: 95 3.4l V6
Join Date: Oct 2009
Location: Shirley, NY
Posts: 876
Does it rev to high rpms and you are barley moving? That usually means a clogged cat.

also, have you changed the spark plugs yet?
__________________
Animated Gif not allowed
Ant32894 is offline   Reply With Quote
Old 10-01-2011, 12:47 PM   #6
davidbecker
 
Drives: 1998 camaro
Join Date: Sep 2011
Location: ohio
Posts: 26
i changed everything yes. and no it just seems like it has a 4 cylinder in it the rpms build with speed. just lacks the HP
davidbecker is offline   Reply With Quote
Old 10-01-2011, 12:47 PM   #7
davidbecker
 
Drives: 1998 camaro
Join Date: Sep 2011
Location: ohio
Posts: 26
and it runs rough. shaking and seems like it wantes to stall but i dont.
davidbecker is offline   Reply With Quote
Old 10-01-2011, 02:24 PM   #8
dmginc


 
dmginc's Avatar
 
Drives: 01 Jeep/11 HHR/14 Camaro 1LS
Join Date: Mar 2011
Location: Freeville, NY
Posts: 3,061
sounds like a fuel issue...fuel filter is pretty cheap and easy to replace and is the first thing i would try.
__________________

CAI Cold Air Intake, BMR Strut Tower Brace, Gen5DIY Fog Lights,
Big Worm Third Brake Light/Side Marker Tint (Charcoal), GTS Tail Light Covers,
Purple Under Hood Lighting, Purple Gill Inserts, Purple Hood Vinyl,
Magnaflow Resonated X-Pipe w/ Muffler Delete
dmginc is offline   Reply With Quote
Old 10-01-2011, 06:35 PM   #9
davidbecker
 
Drives: 1998 camaro
Join Date: Sep 2011
Location: ohio
Posts: 26
if the filter was pluged i would not be going through that much gas would I ?. not trying to argue just trying to figure out how this car works.
davidbecker is offline   Reply With Quote
Old 10-02-2011, 07:07 AM   #10
fielderLS3


 
fielderLS3's Avatar
 
Drives: 02 Alero, 2011 Mustang 5.0
Join Date: Mar 2010
Location: Portage, Wisconsin
Posts: 4,236
Does it run lousy at idle, or just under a load? Does it get worse as you give it more throttle?
__________________
"Proven V-8 power with better efficiency than a turbo V-6"

"The car is the closest thing we will ever create to something that is alive."eds.
fielderLS3 is offline   Reply With Quote
Old 10-02-2011, 11:21 AM   #11
davidbecker
 
Drives: 1998 camaro
Join Date: Sep 2011
Location: ohio
Posts: 26
it runs rough at lower rpms. but even worse at idle and especialy when you put it in gear and hold the brake, it really shakes then
davidbecker is offline   Reply With Quote
Old 10-02-2011, 11:24 AM   #12
davidbecker
 
Drives: 1998 camaro
Join Date: Sep 2011
Location: ohio
Posts: 26
also i just checked my gas as im on E now. i went from As full as i could get it to E in 188 miles.and i drive it highway and very easy.
davidbecker is offline   Reply With Quote
Old 10-03-2011, 08:59 PM   #13
davidbecker
 
Drives: 1998 camaro
Join Date: Sep 2011
Location: ohio
Posts: 26
got it guys, i had to replace all 3 coils and she runs great
davidbecker is offline   Reply With Quote
Old 10-06-2011, 10:09 PM   #14
Ant32894
Youjellybra?
 
Ant32894's Avatar
 
Drives: 95 3.4l V6
Join Date: Oct 2009
Location: Shirley, NY
Posts: 876
Glad to hear she runs good now lol.
__________________
Animated Gif not allowed
Ant32894 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.