Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Apex Paul
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Suspension / Brakes / Chassis

Suspension / Brakes / Chassis All suspension, brakes and chassis discussions.

Reply
 
Thread Tools
Old 04-24-2012, 11:04 PM   #1
caliguy
Don't ask to pop my hood!
 
caliguy's Avatar
 
Drives: it's loud.......
Join Date: Jun 2011
Location: southern cali,
Posts: 856
Unhappy Clunk.. Clunk.....

Ok.... I keep rereading this thread on the clunk noise http://www.camaro5.com/forums/showthread.php?t=148648
My noise started off with the grunting/groaning noise, ( turning the wheel left or right ) thats almost gone but when driving ( bumps, driveways, etc, etc ) i get the clunk sound, So i took off the plastic cap ontop and re tighten the nut is wasn't lose, is there another nut under the metal plate if i took off the first nutt in this photo here? Or does the center shaft need to be checked for tightness? Also is there a another nutt under the metal plate? can i remove first nutt where the plate is without jacking up the car to check to see if its tight and would it be safe too?

Everything else is tight IE tie rods, end links etc, etc and i do have the correct isolators or whatever they are called? LoL.. I can't deal with this clunking noise anymore

P.S. and its only the left front side. Thanks for any advice or help i recieve

P.S.S Before someone chimes in and say do the toilet bowl mod mine isn't rubbing against the strut tower
Attached Images
 
__________________
Limo tint rears, 35% sides | B&G lowering springs | BowTies Blacked out | Red Footwells|Dome Light|Kicker 500Watts-Amp-Kicker 12" Ported Sub=BOOM| Stillin Splitter |Pssst 100 shot| 13.36 @102.7 @LVMS |
2010.

Last edited by caliguy; 04-24-2012 at 11:09 PM. Reason: I suck at typing :P
caliguy is offline   Reply With Quote
Old 04-25-2012, 09:02 AM   #2
camslambam
Account Suspended
 
Drives: 2010 SS, 06 SRT10 Ram
Join Date: Nov 2011
Location: C. America
Posts: 1,660
I have the same clunk, just that it's evident that my tire is actually hitting the inside of the fender because there's actually marks on the tire lol. On hard braking car actually moves a little left. Mine is also on the front left side.

When I inspect it closely it looks like the actual strut is not fully aligned. Almost looks like it popped out and popped back in at an angle.
camslambam is offline   Reply With Quote
Old 04-25-2012, 04:54 PM   #3
73vette

 
73vette's Avatar
 
Drives: 2010 Camaro LS, 1973 Corvette
Join Date: Dec 2010
Location: Olathe, KS
Posts: 784
You can take that nut off (if you want) while the car is on the ground. Then there is that plate, then the nut holding the spring on the strut (don't take that off!!).

Both nuts should be at 65 lb-ft torque.


__________________
73vette is offline   Reply With Quote
Old 04-25-2012, 06:04 PM   #4
caliguy
Don't ask to pop my hood!
 
caliguy's Avatar
 
Drives: it's loud.......
Join Date: Jun 2011
Location: southern cali,
Posts: 856
Thanks, i'll check that bottom nutt.
__________________
Limo tint rears, 35% sides | B&G lowering springs | BowTies Blacked out | Red Footwells|Dome Light|Kicker 500Watts-Amp-Kicker 12" Ported Sub=BOOM| Stillin Splitter |Pssst 100 shot| 13.36 @102.7 @LVMS |
2010.
caliguy is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.