Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Vector Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Marketplace > Vendor and Seller review / feedback / experiences

Vendor and Seller review / feedback / experiences Share review & feedback on vendors and sellers

Reply
 
Thread Tools
Old 08-21-2012, 01:31 PM   #1
jadyn_425
 
jadyn_425's Avatar
 
Drives: 2010 CGC SS
Join Date: Sep 2009
Location: KATY TX
Posts: 41
DMH Electric Cutouts Poor customer service...!!!!

Ok does anyone have these cut outs or hv had
The pleasure of dealing with the customer service
Reguarding shipping new or warranty parts because
Ive got a set of the E cutouts and they wk great but
The set i have for some readon the motors were loose
To the point where i could hear them while cruising on
Te frwy (very annoying)!!! Any whooo so i called dmh
And spoke to the guy there and he says yeah i got a
Batch of motors i know about it and ill take care of it
And send u some new ones you should get em in a wk
THAT WAS 6 MONTHS AGO!! And counting so does anyone
Know of another place that makes the low profile electric cutouts
Tnks....
jadyn_425 is offline   Reply With Quote
Old 08-21-2012, 02:04 PM   #2
Sales@Phastek


 
Sales@Phastek's Avatar
 
Drives: 2010 X5 Camaro Turbo
Join Date: Apr 2012
Location: Houston, TX
Posts: 1,942
QTP sells some oval shapes for better clearance.

http://www.quicktimeperformance.com/OVAL/index.php
Sales@Phastek is offline   Reply With Quote
Old 08-21-2012, 04:55 PM   #3
litle88
V8 Lounge member #2
 
litle88's Avatar
 
Drives: 2001 Ws6
Join Date: Sep 2009
Location: Burbank,IL
Posts: 6,353
I have the dmh Dual oval low profile cutouts and I sent him mine on July 9th still haven't received it!
__________________
01 Ws6, m6, ASC#618 of 1583,40k Miles,shortblock built by AES the rest built by me,Ls3 416,FAST 102, NW102,LPE Ls3 heads

Join us:
https://www.facebook.com/groups/5138...3848358733509/
litle88 is offline   Reply With Quote
Old 08-21-2012, 05:54 PM   #4
01pewterz28
Camaro Junkie
 
01pewterz28's Avatar
 
Drives: 2010 2LT/RS,Born 9/14/09 @ 11:50:57
Join Date: Aug 2008
Location: Ocoee, FL
Posts: 7,417
I had them on my 01Z28 1st set died, the second set died after 6 months they sent me a replacement I then sold it I did not wanto deal with them anymore.
__________________
2010 2LT/RS, 2001 Z/28, 2014 Impala 2LT

Last edited by 01pewterz28; 08-23-2012 at 07:13 AM.
01pewterz28 is offline   Reply With Quote
Old 08-22-2012, 06:42 AM   #5
Dr Jkel
and MR. HYDE
 
Dr Jkel's Avatar
 
Drives: 2010 2SS RJT/BLK 6Spd Man
Join Date: May 2009
Location: Oxford, Alabama
Posts: 4,461
WOW......I have had them on my car for almost 2 years. The first set burned up rather quickly...about 2 months......I contacted the vendor I purchased them from and who installed them.

A replacement set was sent to me rather quickly and since they were replaced I have not had one single issue with them....
__________________
MUSTANG...Like Bringing a Hot Dog to a Steak Dinner....There is no comparison.
Dr Jkel is offline   Reply With Quote
Old 08-22-2012, 07:04 AM   #6
jadyn_425
 
jadyn_425's Avatar
 
Drives: 2010 CGC SS
Join Date: Sep 2009
Location: KATY TX
Posts: 41
Quote:
Originally Posted by Dr Jkel View Post
WOW......I have had them on my car for almost 2 years. The first set burned up rather quickly...about 2 months......I contacted the vendor I purchased them from and who installed them.

A replacement set was sent to me rather quickly and since they were replaced I have not had one single issue with them....
Yea its like hit n miss Mine still wk but the motors are really loose
And make a lot of noise its annoying as hell..to drive around n listen to dat
jadyn_425 is offline   Reply With Quote
Old 08-22-2012, 07:06 AM   #7
jadyn_425
 
jadyn_425's Avatar
 
Drives: 2010 CGC SS
Join Date: Sep 2009
Location: KATY TX
Posts: 41
Quote:
Originally Posted by 01pewterz28 View Post
I had them on my 01Z28 1st set died, the second set died after 6 months they sent me a replacement I then old it I did not wanto deal with them anymore.
I dont blame you one bit
jadyn_425 is offline   Reply With Quote
Old 08-22-2012, 07:07 AM   #8
Dr Jkel
and MR. HYDE
 
Dr Jkel's Avatar
 
Drives: 2010 2SS RJT/BLK 6Spd Man
Join Date: May 2009
Location: Oxford, Alabama
Posts: 4,461
I guess I got a good set cause mine work and don't rattle at all....You may can tighten the screws that hold the motor on to help your situation.
__________________
MUSTANG...Like Bringing a Hot Dog to a Steak Dinner....There is no comparison.
Dr Jkel is offline   Reply With Quote
Old 08-22-2012, 07:09 AM   #9
jadyn_425
 
jadyn_425's Avatar
 
Drives: 2010 CGC SS
Join Date: Sep 2009
Location: KATY TX
Posts: 41
Quote:
Originally Posted by litle88 View Post
I have the dmh Dual oval low profile
cutouts and I sent him mine on July 9th still haven't received it!
Yea the last time i spoke with him he said that he got
A bad set of motors and he would take care of the situation
Thats been months now so im gonna check out this other company
That makes them now...
jadyn_425 is offline   Reply With Quote
Old 08-22-2012, 07:29 AM   #10
1954 Belair-man

 
1954 Belair-man's Avatar
 
Drives: 2010 Camaro IOM 1SS M6
Join Date: Aug 2010
Location: Michigan
Posts: 893
Quote:
Originally Posted by jadyn_425 View Post
Ok does anyone have these cut outs or hv had
The pleasure of dealing with the customer service
Reguarding shipping new or warranty parts because
Ive got a set of the E cutouts and they wk great but
The set i have for some readon the motors were loose
To the point where i could hear them while cruising on
Te frwy (very annoying)!!! Any whooo so i called dmh
And spoke to the guy there and he says yeah i got a
Batch of motors i know about it and ill take care of it
And send u some new ones you should get em in a wk
THAT WAS 6 MONTHS AGO!! And counting so does anyone
Know of another place that makes the low profile electric cutouts
Tnks....
Wow that sucks, i thank you for posting and making us aware of a possible issue with the product and the after the sale customer service. I will now scratch them off my list of cut-outs i'am thinking of buying. As mentioned above i'am thinking about the QTP's. Has anyone had any issues with these?
1954 Belair-man is offline   Reply With Quote
Old 08-22-2012, 02:24 PM   #11
Cali_Camaro_SS

 
Cali_Camaro_SS's Avatar
 
Drives: 2010 Camaro 1SS (BLACK)
Join Date: Jan 2010
Location: Cali
Posts: 773
I think I have posted twice about them already, I have some of there cutouts and i was trying to get a hold of DMH for about 2 months now and no answer.
__________________
_________________
1SS: Dnyatech LT Headers | Dynamaxx CatBack | Diablo Tune | Intake | Pfatds Springs | Heritage Grill | Blacked out Bezels | Black Chevy Sign | Blacked out Wheels | Tint | HIDs w/Error code Eliminator | Green Dome/Trunk Light |

Cali_Camaro_SS is offline   Reply With Quote
Old 08-22-2012, 02:27 PM   #12
jadyn_425
 
jadyn_425's Avatar
 
Drives: 2010 CGC SS
Join Date: Sep 2009
Location: KATY TX
Posts: 41
Quote:
Originally Posted by Cali_Camaro_SS View Post
I think I have posted twice about them already, I have some of there cutouts and i was trying to get a hold of DMH for about 2 months now and no answer.
Yea join the club.... Ph goes to vm and thats if it isnt
Full half the time.... They prob dnt even reply to vm
Anyways prob just delete em all.... whats wrong with
The ones u have?
jadyn_425 is offline   Reply With Quote
Old 08-22-2012, 02:30 PM   #13
jadyn_425
 
jadyn_425's Avatar
 
Drives: 2010 CGC SS
Join Date: Sep 2009
Location: KATY TX
Posts: 41
Quote:
Originally Posted by 1954 Belair-man View Post
Wow that sucks, i thank you for posting and making us aware of a possible issue with the product and the after the sale customer service. I will now scratch them off my list of cut-outs i'am thinking of buying. As mentioned above i'am thinking about the QTP's. Has anyone had any issues with these?
No prob just wanted everyone to know the experience
Ive had with them so they dnt hv to deal with all dat bs...
jadyn_425 is offline   Reply With Quote
Old 08-25-2012, 01:10 PM   #14
Cali_Camaro_SS

 
Cali_Camaro_SS's Avatar
 
Drives: 2010 Camaro 1SS (BLACK)
Join Date: Jan 2010
Location: Cali
Posts: 773
Quote:
whats wrong with
The ones u have?
Well thankfully I got it fixed, the thing was they sent me new ones like 3 months ago and they didnt work out of the box even when I applied power to the motors directly, so they sent me new ones again and when I went to plug them in they didnt work either. didnt think to apply power to them also thinking they keep sending crap but then I had a blown fuse somehow and replaced it and the 2nd pair now work
__________________
_________________
1SS: Dnyatech LT Headers | Dynamaxx CatBack | Diablo Tune | Intake | Pfatds Springs | Heritage Grill | Blacked out Bezels | Black Chevy Sign | Blacked out Wheels | Tint | HIDs w/Error code Eliminator | Green Dome/Trunk Light |

Cali_Camaro_SS is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.