Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
BORLA
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Forced Induction - V8


Reply
 
Thread Tools
Old 10-21-2012, 10:51 AM   #127
Whipped416

 
Whipped416's Avatar
 
Drives: 2010 CAMARO SS
Join Date: Mar 2011
Location: Texas
Posts: 1,517
i have my chiller installed.. did not see the results i was hoping for.... temps did not drop as much as i thought they would .... as idle its not dropping at all.
Whipped416 is offline   Reply With Quote
Old 10-21-2012, 10:54 AM   #128
SUKXOST
Do you even lift, bro?
 
SUKXOST's Avatar
 
Drives: 2013 1LE Camaro
Join Date: Aug 2012
Location: Sumter, SC
Posts: 3,158
Quote:
Originally Posted by Whipped416 View Post
i already have a super chiller its getting installed this week..
Quote:
Originally Posted by Whipped416 View Post
i have my chiller installed.. did not see the results i was hoping for.... temps did not drop as much as i thought they would .... as idle its not dropping at all.
WTF? Why not? how is it even possible that it not drop? Installed correctly? pics?
__________________
My 1LE (645WHP/597WTQ) build/journal Thread:
1st ever 1LE COTW http://www.camaro5.com/forums/showthread.php?t=255461
SUKXOST is offline   Reply With Quote
Old 10-21-2012, 11:04 AM   #129
Whipped416

 
Whipped416's Avatar
 
Drives: 2010 CAMARO SS
Join Date: Mar 2011
Location: Texas
Posts: 1,517
dropped about 20 degrees at wot did not drop just idleing tho...
hooked up just as instructions say to.. ac is cold in car just not seeing the iat drops i was hoping for .
Whipped416 is offline   Reply With Quote
Old 10-21-2012, 11:07 AM   #130
SUKXOST
Do you even lift, bro?
 
SUKXOST's Avatar
 
Drives: 2013 1LE Camaro
Join Date: Aug 2012
Location: Sumter, SC
Posts: 3,158
hmmmm....maybe Dave will chime in here
__________________
My 1LE (645WHP/597WTQ) build/journal Thread:
1st ever 1LE COTW http://www.camaro5.com/forums/showthread.php?t=255461
SUKXOST is offline   Reply With Quote
Old 10-21-2012, 11:33 AM   #131
TrekGTO

 
TrekGTO's Avatar
 
Drives: 05 GTO / JETTA TDI
Join Date: Jan 2012
Location: St Pete Fl
Posts: 400
Quote:
Originally Posted by SUKXOST View Post
hmmmm....maybe Dave will chime in here
After talking to installer I donít think it is installed correct and none of my support questions to owner have been answered. We canít provide much support without communication. The other Whipple installs have yielded great results! This is a Whipple in picture, Sage reports IAT staging around 70deg and below 130deg crossing the ľ mi. Very close results hot lapping in 95deg Fl

__________________

ACTIVE INTERCHILLER.COM Fl INTERCHILLER
Original SUPER CHILLER Since 2009
Original XTREME CHILLER Since 2013
FACEBOOK 727 656 1422
TrekGTO is offline   Reply With Quote
Old 10-21-2012, 11:41 AM   #132
SUKXOST
Do you even lift, bro?
 
SUKXOST's Avatar
 
Drives: 2013 1LE Camaro
Join Date: Aug 2012
Location: Sumter, SC
Posts: 3,158
Quote:
Originally Posted by TrekGTO View Post
After talking to installer I donít think it is installed correct and none of my support questions to owner have been answered. We canít provide much support without communication. The other Whipple installs have yielded great results! This is a Whipple in picture, Sage reports IAT staging around 70deg and below 130deg crossing the ľ mi. Very close results hot lapping in 95deg Fl
hmmm. I hope Carolina Auto Masters gets it right then on my install
__________________
My 1LE (645WHP/597WTQ) build/journal Thread:
1st ever 1LE COTW http://www.camaro5.com/forums/showthread.php?t=255461
SUKXOST is offline   Reply With Quote
Old 10-21-2012, 11:47 AM   #133
Whipped416

 
Whipped416's Avatar
 
Drives: 2010 CAMARO SS
Join Date: Mar 2011
Location: Texas
Posts: 1,517
im sure that whipple is not running on a 416 and 10 rib setup and spinning the blower as hard as it will spin with 17 pounds boost with the 2.75 pulley...
you never asked for no information...
and yes the kit is installed to your directions. you asked what water temp was thats all u asked me ...
Whipped416 is offline   Reply With Quote
Old 10-21-2012, 11:55 AM   #134
TrekGTO

 
TrekGTO's Avatar
 
Drives: 05 GTO / JETTA TDI
Join Date: Jan 2012
Location: St Pete Fl
Posts: 400
Quote:
Originally Posted by Whipped416 View Post
im sure that whipple is not running on a 416 and 10 rib setup and spinning the blower as hard as it will spin with 17 pounds boost with the 2.75 pulley...
you never asked for no information...
and yes the kit is installed to your directions. you asked what water temp was thats all u asked me ...
I’m available for phone support 7 days a wk I replied to your text Saturday with a question and today with a question but no replies.
Yes water temp is the first question and first place to start. If water is not getting cold then we need figure out why. That’s all the Super Chiller does is make cold water.
__________________

ACTIVE INTERCHILLER.COM Fl INTERCHILLER
Original SUPER CHILLER Since 2009
Original XTREME CHILLER Since 2013
FACEBOOK 727 656 1422

Last edited by TrekGTO; 08-23-2015 at 04:10 AM.
TrekGTO is offline   Reply With Quote
Old 10-21-2012, 11:57 AM   #135
Whipped416

 
Whipped416's Avatar
 
Drives: 2010 CAMARO SS
Join Date: Mar 2011
Location: Texas
Posts: 1,517
and we did not install the cheap water gauge ... water is getting cold just not effecting the iat cause of heat soak where and sensor location on whipple.
is air suppose to travel through chiller at idle?
Whipped416 is offline   Reply With Quote
Old 10-21-2012, 11:59 AM   #136
Whipped416

 
Whipped416's Avatar
 
Drives: 2010 CAMARO SS
Join Date: Mar 2011
Location: Texas
Posts: 1,517
i never bashed you are your product... just stated the results i was having .
Whipped416 is offline   Reply With Quote
Old 10-21-2012, 12:05 PM   #137
TrekGTO

 
TrekGTO's Avatar
 
Drives: 05 GTO / JETTA TDI
Join Date: Jan 2012
Location: St Pete Fl
Posts: 400
Quote:
Originally Posted by Whipped416 View Post
i never bashed you are your product... just stated the results i was having .
Air never flows through a Super Chiller only Water and Freon.
Without water temp I would not know where to start. You don’t have to mount the digital display it can be hidden under hood or under dash just for diagnostic use.
__________________

ACTIVE INTERCHILLER.COM Fl INTERCHILLER
Original SUPER CHILLER Since 2009
Original XTREME CHILLER Since 2013
FACEBOOK 727 656 1422

Last edited by TrekGTO; 08-23-2015 at 04:08 AM.
TrekGTO is offline   Reply With Quote
Old 10-21-2012, 12:11 PM   #138
Whipped416

 
Whipped416's Avatar
 
Drives: 2010 CAMARO SS
Join Date: Mar 2011
Location: Texas
Posts: 1,517
ok well i will see if i can get it hooked up... im not bashing your product again!!
Whipped416 is offline   Reply With Quote
Old 10-21-2012, 12:12 PM   #139
TrekGTO

 
TrekGTO's Avatar
 
Drives: 05 GTO / JETTA TDI
Join Date: Jan 2012
Location: St Pete Fl
Posts: 400
Quote:
Originally Posted by Whipped416 View Post
im sure that whipple is not running on a 416 and 10 rib setup and spinning the blower as hard as it will spin with 17 pounds boost with the 2.75 pulley...

and yes the kit is installed to your directions. you asked what water temp was thats all u asked me ...
A 416 with 17lb boost will not see the low temps a stock engine at 10lbs but benefit is still in proportion. The description you posted above is not working.
__________________

ACTIVE INTERCHILLER.COM Fl INTERCHILLER
Original SUPER CHILLER Since 2009
Original XTREME CHILLER Since 2013
FACEBOOK 727 656 1422
TrekGTO is offline   Reply With Quote
Old 10-21-2012, 12:21 PM   #140
TrekGTO

 
TrekGTO's Avatar
 
Drives: 05 GTO / JETTA TDI
Join Date: Jan 2012
Location: St Pete Fl
Posts: 400
Quote:
Originally Posted by Whipped416 View Post
i have my chiller installed.. did not see the results i was hoping for.... temps did not drop as much as i thought they would .... as idle its not dropping at all.
70deg water feels cold to the touch but we need to be seeing a 50deg reduction in water temp on vs. off. Even with your setup we should at least get close to that. I donít believe your description of performance reflects anything close to that. In fact it seems backwards, your IAT should be lower at idle than WOT. Sounds to me like a simple mistake somewhere in wiring, vacuum or water hose routing.
__________________

ACTIVE INTERCHILLER.COM Fl INTERCHILLER
Original SUPER CHILLER Since 2009
Original XTREME CHILLER Since 2013
FACEBOOK 727 656 1422
TrekGTO is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Whiteside Customs Super Street 1 Package - Install Thread Whiteside Customs Suspension / Brakes / Chassis 5 12-12-2011 08:40 PM
Drag Racing..."Real Street Cars" Steve Dallas Dragstrip and Launch Techniques Discussion 40 09-04-2011 11:02 AM
Portable Dynamometer added to Houston Super Chevy Show Midway, Sept. 11-12 Houston Raceway USA - Texas 6 09-01-2010 11:26 PM
LG g6x3 or Super Charger Cam!!! Your Thoughts Mr. Brownstone Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 30 01-24-2010 01:45 PM
Shelby Super Snake KILLER74Z28 General Automotive + Other Cars Discussion 18 07-23-2007 07:12 PM


All times are GMT -5. The time now is 07:35 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.