Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
HURST
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Tuning / Diagnostics -- engine and transmission


Reply
 
Thread Tools
Old 03-30-2012, 10:25 AM   #1
Mkn95u0
 
Drives: 2012 IBM L99
Join Date: Feb 2012
Location: Pomona, CA
Posts: 383
Check Eng. Light already? P0442

Car: 2012 2SS Camaro L99 - Auto
Aftermarket AEM COI
Last Fill up: 3/25/12 - 3983 miles - Shell, 91

I just threw a code at 4152 miles,

P0442 EvaporativeEmission Control System Leak Detected (small leak)

I’m, fairly new to "new" car's, still stuck in the 80's era of Camaro's where I could just count the flashes of the check engine light blinking with a paper clip... so any help on what this may relate to would be appreciated, its still under warranty - I only have an AEM intake installed, and wanted to make sure this isn't something that GM will find as the cause the check engine light went off if it needs to be taken in, since i know they're good at that (06' Aveo, they blamed a fuel electrical issue on the after market radio which was put in the car prior to me purchasing it, so wasn't covered)

From my understanding, this should be a fuel system vapor "Small" leak? So maybe me pulling my gas cap off and putting it back on could fix it (unlikely)?
Mkn95u0 is offline   Reply With Quote
Old 03-31-2012, 06:57 PM   #2
Ventmaster

 
Ventmaster's Avatar
 
Drives: 2017 1SS 6spd
Join Date: Jan 2011
Location: Utah
Posts: 2,070
Yup, I bet just re-tightening the gas cap will do it.

May take a couple of drive cycles to drop away.
Ventmaster is online now   Reply With Quote
Old 04-08-2012, 03:03 AM   #3
KRich2587
 
KRich2587's Avatar
 
Drives: 2014 Summit White 1LE
Join Date: Jan 2012
Location: Temple, TX
Posts: 432
I had the same fault @ about 3k miles on my 2012. Gas cap would most likely be a large leak.i had a leaking valve on the charcoal canister covered under warranty no issue.the tech told me he has done a few I bet your is leaking too. I dont have acai but I do have a catch can installed they gave me no issues. Also acai install should not cause a evap leak.
KRich2587 is offline   Reply With Quote
Old 05-18-2012, 05:56 PM   #4
brAnd7onX

 
brAnd7onX's Avatar
 
Drives: 2012 SS IOM
Join Date: Oct 2009
Location: Round Rock, TX
Posts: 1,554
Hey guys I have a 2012 L99 as well with only 4k miles and my check engine light came on as well for P0442. They said it is the vent solenoid and they special ordered it for me and I have to take it back in and get it fixed. We shall see if it works.
__________________

2012 Camaro SS IOM "TigreSS"
Borla "S" Catback
C.A.I. Intake
VMax Ported TB
JRE Tune
brAnd7onX is offline   Reply With Quote
Old 10-18-2012, 04:26 PM   #5
smokeylt
 
Drives: 2012 camaro SS 45th Aniversary Edit
Join Date: Jan 2012
Location: Shelbyville, Tn
Posts: 6
Angry really at 3000 miles

Same problem with my Camaro. Just turned 3000 miles. Been in to the dealer twice. The first time the replaced the vent solenoid. The second time they did a smoke test and found no issue. Now the light is on again, with the check engine light and they say I have to bring it in again so they can finally call GM's technicians too see if they can figure it out.

Is anyone else having an ongoing issue?

Name:  camaro pic.JPG
Views: 3576
Size:  14.1 KB
smokeylt is offline   Reply With Quote
Old 10-18-2012, 04:49 PM   #6
Spektrum
 
Spektrum's Avatar
 
Drives: 2013 2SS 1LE
Join Date: Oct 2012
Location: Behind you!
Posts: 488
Gas caps are usually attributed to a Large (Gross) Evap Leak, as someone stated above. Usually small leaks could be related to a bad hose or a solenoid that isn't opening or closing properly. A technician will be able to use a diagnostic tool to operate all the solenoids within the system to make sure they're activating/responding. Also they may run smoke through the system to check for visible leaks.

EVAP codes are the harder of the common CEL codes to diagnose, in my opinion.

If I'm repeating the comments of others, sorry. A lot of the EVAP codes in GM's that run through my shop are related to a faulty vent solenoid. I've even installed new ones that test bad as well.
Spektrum is offline   Reply With Quote
Old 10-19-2012, 09:26 AM   #7
wiruth
 
Drives: 2012 Camaro SS
Join Date: Dec 2011
Location: Tulsa
Posts: 13
I have the same problem on my 2012 SS with 9100 miles. Taking it to the dealer on Monday. Will post the findings.
wiruth is offline   Reply With Quote
Old 10-24-2012, 10:11 PM   #8
Coyotekiller
Account Suspended
 
Drives: 2012 AGM 2SS
Join Date: Feb 2012
Location: Beaufort, NC
Posts: 1,383
Mine did this the other day. Went by advance auto, read the code (po442) and cleared them both. Asked the guys inside and they said to check the gas cap. I took it off, double checked it, and retightened it. No light since, but that was only 4 days ago.
Coyotekiller is offline   Reply With Quote
Old 10-25-2012, 02:06 PM   #9
wiruth
 
Drives: 2012 Camaro SS
Join Date: Dec 2011
Location: Tulsa
Posts: 13
It was the vent valve at the rear of the car. They replaced it without removing the rear bumper. It also is running better. with the problem, it ran like it had a slight vacume leak. The low end is stronger and smoother now. They also reprogramed my air bag under a recall.
wiruth is offline   Reply With Quote
Old 10-25-2012, 03:13 PM   #10
Coyotekiller
Account Suspended
 
Drives: 2012 AGM 2SS
Join Date: Feb 2012
Location: Beaufort, NC
Posts: 1,383
Quote:
Originally Posted by wiruth View Post
It was the vent valve at the rear of the car. They replaced it without removing the rear bumper. It also is running better. with the problem, it ran like it had a slight vacume leak. The low end is stronger and smoother now. They also reprogramed my air bag under a recall.
I wonder if this could be why my car idles like its retarded...
Coyotekiller is offline   Reply With Quote
Old 10-25-2012, 03:50 PM   #11
GaBoy25


 
GaBoy25's Avatar
 
Drives: 2010 SS/RS M6/2500HD Lmm LTZ
Join Date: Apr 2012
Location: South Georgia
Posts: 2,543
Quote:
Originally Posted by Coyotekiller View Post
I wonder if this could be why my car idles like its retarded...
Epic post of the week!
__________________
FASTER than my SS....for now

2500HD (with a couple parts)



Quote:
Originally Posted by Coyotekiller View Post
I wonder if this could be why my car idles like its retarded...
GaBoy25 is offline   Reply With Quote
Old 10-25-2012, 04:09 PM   #12
ROD_SS

 
ROD_SS's Avatar
 
Drives: 2013 1SS Camaro and a truck
Join Date: Apr 2011
Location: San Antonio,TX
Posts: 1,080
Is this for all Camaro SS? Seem like everyone that posted has one
__________________
ADM tuned (465 rwhp / 442 torque) Mods- CAI, kooks long tube headers, & ADM stage 2 cam
ROD_SS is offline   Reply With Quote
Old 10-26-2012, 05:32 AM   #13
Coyotekiller
Account Suspended
 
Drives: 2012 AGM 2SS
Join Date: Feb 2012
Location: Beaufort, NC
Posts: 1,383
Quote:
Originally Posted by GaBoy25 View Post
Epic post of the week!
Lol

I'm actually curious though too. The idle has always stumbled around on my car and I have tried to fix it a few different ways. Maybe this will help it out. It's just as likely to fix it as the rest of the stuff I tried.
Coyotekiller is offline   Reply With Quote
Old 10-26-2012, 08:30 PM   #14
wiruth
 
Drives: 2012 Camaro SS
Join Date: Dec 2011
Location: Tulsa
Posts: 13
Maybe? No doubt, mine is running much better at the low end. Idles much smoother.
wiruth is offline   Reply With Quote
 
Reply

Tags
check engine light, emission, evaporative, p code, troubleshoot

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
check eng light 2011 m-6 ss flem 5th Gen Camaro SS LS LT General Discussions 2 04-30-2011 08:51 AM
Check engine light chevyss Tuning / Diagnostics -- engine and transmission 12 04-20-2011 09:39 PM
check engine light. code p0453 stonecoldvenom Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 8 03-23-2011 01:28 PM
Question about Check engine light Alain Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 18 03-11-2011 11:42 AM
Voice Your Comments/Suggestions/Input for Focus Group on 2010 Camaro Mr. Wyndham 5th Gen Camaro SS LS LT General Discussions 236 04-22-2008 12:43 AM


All times are GMT -5. The time now is 06:09 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.