Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
ADM PERFORMANCE
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Forced Induction - V8


Reply
 
Thread Tools
Old 12-29-2012, 09:19 PM   #43
CamaroSS45
Annihilator
 
CamaroSS45's Avatar
 
Drives: 2012 45th ERL-427 F1X
Join Date: Aug 2011
Location: KY
Posts: 335
Could you guys that battled thru this advise on the "correct wiring" per Aeromoitive that worked out for you. We are in an install now and would like to avoid the trouble if we can - and it's occuring during the Holidays. It would be "very much" appreciated on the wiring routes / connections that covered you.

Much thanks! Plz....

Quote:
Originally Posted by incon3037r View Post
I've had all of these problems as well. Aeromotive directions to wire the FPCM were wrong and when my mechanic contacted them to find the correct way, it took several days and being told several different wrong ways to wire it before the correct information was given. Then we were given the run around on which MSD tach adapter that was needed to find a signal for the FPCM. MSD would say to contact Aeromotive and vice versa.

Currently everything is working fine with the addition of the FPCM and MSD tach box. I was not advised on installing a cooler on the returne side but will do so. The fuel pump appears to be nicely made, but the trouble and all of the additional parts needed to install makes it a head ache. If this new unit doesn't hold up, I'll move onto the Squash setup.

It also sucks when you have to pay labor to remove and install a new pump because it was damaged from the manufacturer.
__________________
ERL M3 Superdeck 427 Forged, Dragon Slayer Crank, Black Label Heads : ProCharger F1X Cog - Holley HighRam : Jakes4L80e CircleD - DSS 9" 1400 axles/shaft, BMR Suspension : Extreme Innovations 15 : Squash, Bosch 127lb FI : ALKY Twin Meth
CamaroSS45 is offline   Reply With Quote
Old 12-30-2012, 02:07 AM   #44
incon3037r
GMHIC
 
incon3037r's Avatar
 
Drives: 2008 Pontiac G8 GT
Join Date: Apr 2010
Location: Las Vegas
Posts: 94
Quote:
Originally Posted by CamaroSS45 View Post
Could you guys that battled thru this advise on the "correct wiring" per Aeromoitive that worked out for you. We are in an install now and would like to avoid the trouble if we can - and it's occuring during the Holidays. It would be "very much" appreciated on the wiring routes / connections that covered you.

Much thanks! Plz....
I'll see if my mechanic is available over the holiday and ask him how he wired the A1000, fuel pump controller and MSD tach box, then post what I find out. I'll also take photos if possible.
__________________
ProCharger F-1D, Treadstone TR1235 FMIC, Kooks 1 7/8 LTH,Corsa catback, New Era (228/240) cam, Yella Terra 1.7 Rockers, GMPP LS3 CNC heads, RX catch can, Aeromotive A1000, FAST fuel rails, FAST FPR, FIC 1000cc injectors, Yank SS2800, Camaro trans pan/filter, Earl's trans cooler
736 RWHP/642 LBFT 91oct 15psi
730 RWHP/621 LBFT E85 13psi
695 RWHP/603 LBFT E85 11psi

incon3037r is offline   Reply With Quote
Old 12-30-2012, 03:31 AM   #45
stevieturbo
 
Drives: Slow
Join Date: Nov 2010
Location: Northern Ireland
Posts: 525
Surely the wiring cant be that difficult ? It's only a fuel pump
__________________
got boosted
http://www.youtube.com/watch?v=XgWRCDtiTQ0

Never trust or buy from AES Racing.
stevieturbo is offline   Reply With Quote
Old 12-30-2012, 03:05 PM   #46
realcanuk
 
realcanuk's Avatar
 
Drives: 2007 Corvette C6 983 RWHP
Join Date: Dec 2011
Location: Montreal, Canada
Posts: 640
My knowledge of these systems is very limited so I dont know if this is releveant, but its interesting.

http://forums.corvetteforum.com/c6-f...-creation.html
__________________
2007 C6 vert, auto, F55, LT3
LME LS402 , WCCH 245 Heads, Pat G. Custom cam
YSI / 3.0 pulley, ARH 1 7/8 headers, NPP
Dewitts / dual spals, A&A dual pump fuel system.
3.42 polished gears, hardened shafts, Alky control meth, Cartech line lock, ECS axle loops, Trans brace, 6L80 built by me.
ID 1000 injectors, comp rockers, Morel lifters, BT springs, Trend 3/8 pushrods, ATI 10% OD Damper
Circle D Triple Disc stall
1009 RWHP @ 7000, 817 RWTQ @ 6000, Built & Tuned by Seth at FEDERAL PERFORMANCE
realcanuk is offline   Reply With Quote
Old 12-30-2012, 03:21 PM   #47
CamaroSS45
Annihilator
 
CamaroSS45's Avatar
 
Drives: 2012 45th ERL-427 F1X
Join Date: Aug 2011
Location: KY
Posts: 335
Quote:
Originally Posted by realcanuk View Post
My knowledge of these systems is very limited so I dont know if this is releveant, but its interesting.

http://forums.corvetteforum.com/c6-f...-creation.html
All of this is needless to say - inspiring, encouraging, and ..... freakin scary!!! I am curious for more good news if any exists - or insight from Aeromotive.

I know they are using different pumps and technology but are the pump for the COPO so it begs curiosity why the trouble here.? ... ?
__________________
ERL M3 Superdeck 427 Forged, Dragon Slayer Crank, Black Label Heads : ProCharger F1X Cog - Holley HighRam : Jakes4L80e CircleD - DSS 9" 1400 axles/shaft, BMR Suspension : Extreme Innovations 15 : Squash, Bosch 127lb FI : ALKY Twin Meth
CamaroSS45 is offline   Reply With Quote
Old 12-30-2012, 03:23 PM   #48
stevieturbo
 
Drives: Slow
Join Date: Nov 2010
Location: Northern Ireland
Posts: 525
It is indeed ! more info needed on that one.
__________________
got boosted
http://www.youtube.com/watch?v=XgWRCDtiTQ0

Never trust or buy from AES Racing.
stevieturbo is offline   Reply With Quote
Old 12-30-2012, 03:35 PM   #49
saccrestorations
 
Drives: Camaro
Join Date: Dec 2012
Location: Murrieta
Posts: 15
You have to wonder why so many people are having problems with Aeromotive. I was going to buy the complete fuel system from them but now I don't think I will. I called them to talk about creating a fuel system that would meet the requirements for an LS9. They suggested I transplant a complete ZR1 fuel system into my car. Are you kidding me!!! I won't be giving them any of my business now, or in the future...
saccrestorations is offline   Reply With Quote
Old 12-30-2012, 03:48 PM   #50
CamaroSS45
Annihilator
 
CamaroSS45's Avatar
 
Drives: 2012 45th ERL-427 F1X
Join Date: Aug 2011
Location: KY
Posts: 335
Quote:
Originally Posted by Matt @ RX View Post
Garbage... 80 street miles on it and a few track passes, two 9-second passes, most were aborts from traction woes....

Made a single dyno pass last night on my combo, at 6100RPM's it went to ~20psi and crapped the bed. Screwed the regulator all the way down just to see, now the pump even with regulator all the way in makes maybe 40psi tops at idle. I have mine completely isolated with a single relay, running 10ga wire. I've installed probably 200+ of their series pumps in numerous applications (All externals).

Maybe I have a problem with the internal line, right now do not know what went wrong, frankly don't care I'll never use another Aeromotive series internal pump again.

Made 737rwhp through the unlocked 4l60E at 16psi @ 6100rpms.. Would have cracked 800+ on the low boost if I could have made a pass to 72.
Matt -

Thanks for the post here .... and you know I am in the midst of a pretty large build as well. We are just working thru the tune and shortly to WOT Dyno runs. You, like many here, know their $hit so don't believe this to be a farce - and plan to ping Aeromotive tomorrow ..... But you know the players - industry - people..... What did they tell you and what route are you taking?

I am praying there was a bad batch of these but boy we have a small group with a common theme going here and if I had to time my purchase - it was likely at the same time yours was.

Appreciate the insight and some enlightenment would be nice from the manufacturer...... Again - they make a good product as we know and if this is a flop - shocked they are not addressing or jumping in here.

Like your install - we'd double covered all bases and don't even have an issue "yet" but much like a NW102 throttle body thread I am watching - I like to know where the storm may be before it hits.

Anyone with enlightenment - jump in - share and also add ...

Thx
__________________
ERL M3 Superdeck 427 Forged, Dragon Slayer Crank, Black Label Heads : ProCharger F1X Cog - Holley HighRam : Jakes4L80e CircleD - DSS 9" 1400 axles/shaft, BMR Suspension : Extreme Innovations 15 : Squash, Bosch 127lb FI : ALKY Twin Meth
CamaroSS45 is offline   Reply With Quote
Old 12-30-2012, 04:49 PM   #51
Matt @ FSP
 
Matt @ FSP's Avatar
 
Drives: 2011 Camaro SS
Join Date: Dec 2012
Location: Bradenton, FL
Posts: 2,612
Quote:
Originally Posted by CamaroSS45 View Post
Matt -

Thanks for the post here .... and you know I am in the midst of a pretty large build as well. We are just working thru the tune and shortly to WOT Dyno runs. You, like many here, know their $hit so don't believe this to be a farce - and plan to ping Aeromotive tomorrow ..... But you know the players - industry - people..... What did they tell you and what route are you taking?

I am praying there was a bad batch of these but boy we have a small group with a common theme going here and if I had to time my purchase - it was likely at the same time yours was.

Appreciate the insight and some enlightenment would be nice from the manufacturer...... Again - they make a good product as we know and if this is a flop - shocked they are not addressing or jumping in here.

Like your install - we'd double covered all bases and don't even have an issue "yet" but much like a NW102 throttle body thread I am watching - I like to know where the storm may be before it hits.

Anyone with enlightenment - jump in - share and also add ...

Thx
Hey bud,

This is actually Matt, formerly of RX ... Mine worked fine for about 40 street miles and 10'ish or so track passes. Then the fuel pressure dropped on me at idle to nearly 20psi, I knew there was a problem at that point. I cranked up the regulator just to get it moved around the shop and then onto the dyno, at 737rwhp at 6100rpm's it came down to 20psi and we shut her down. I drove the car back from the shop to home, pump was terribly loud (Overheating is my bet) and killed on me at the CVS. It did restart a few hours later and is running now..

I got with Andy @ Squash and he sent over his double pumper return style system. We are going to swap the Aeromotive soon for the Squash and I'll be back out.

At this point I cannot tell you what failed, I do not care really what failed because I cannot take the chance of a failure on my combination (Or any motor), so I've decided to ditch it. I'll let you know if we see anything when we pull it apart, could be that short EFI fuel line ate through in the tank who knows. I just know with the Squash I'll be all se to go!

I owned a full fabrication shop up north for a bunch of years, all we used for external pumps were Aeromotive or Weldon. I can say I have had VERY minimal Aeromotive failures in the past, but that is on their external pumps. I guess the internal pumps just need to be addressed. So you know I purchased mine last year about this time, but the car never ran until this October with the new pump. So if there is a common bad batch maybe it is fixed?

- Matt
Matt @ FSP is offline   Reply With Quote
Old 12-30-2012, 04:53 PM   #52
SSE 4 2SS
Boosted Moderator
 
SSE 4 2SS's Avatar
 
Drives: Bone Stock LS3
Join Date: Sep 2009
Location: Kyle Tx
Posts: 14,235
Send a message via AIM to SSE 4 2SS Send a message via Yahoo to SSE 4 2SS
Quote:
Originally Posted by Matt @ FSP View Post
Hey bud,

This is actually Matt, formerly of RX ... Mine worked fine for about 40 street miles and 10'ish or so track passes. Then the fuel pressure dropped on me at idle to nearly 20psi, I knew there was a problem at that point. I cranked up the regulator just to get it moved around the shop and then onto the dyno, at 737rwhp at 6100rpm's it came down to 20psi and we shut her down. I drove the car back from the shop to home, pump was terribly loud (Overheating is my bet) and killed on me at the CVS. It did restart a few hours later and is running now..

I got with Andy @ Squash and he sent over his double pumper return style system. We are going to swap the Aeromotive soon for the Squash and I'll be back out.

At this point I cannot tell you what failed, I do not care really what failed because I cannot take the chance of a failure on my combination (Or any motor), so I've decided to ditch it. I'll let you know if we see anything when we pull it apart, could be that short EFI fuel line ate through in the tank who knows. I just know with the Squash I'll be all se to go!

I owned a full fabrication shop up north for a bunch of years, all we used for external pumps were Aeromotive or Weldon. I can say I have had VERY minimal Aeromotive failures in the past, but that is on their external pumps. I guess the internal pumps just need to be addressed. So you know I purchased mine last year about this time, but the car never ran until this October with the new pump. So if there is a common bad batch maybe it is fixed?

- Matt
After the money I lost, I'll never go back to Aeromotive... Fortunately my car was idling when the fuel pressure dropped to 2 lbs and the car died...

I now have the Lingenfelter duals in the tank feeding a sump tank or cell, with an external Weldon for the rails... No worries anymore...
__________________
If the car feels like it is on rails, you are probably driving too slow. -Ross Bentley

Horsepower is how fast you hit the wall.
Torque is how far you take the wall with you.

“If everything seems under control, you're just not going fast enough.” Mario Andretti

If you can turn, you ain't going fast enough...
SSE 4 2SS is offline   Reply With Quote
Old 01-15-2013, 07:22 PM   #53
Matt @ FSP
 
Matt @ FSP's Avatar
 
Drives: 2011 Camaro SS
Join Date: Dec 2012
Location: Bradenton, FL
Posts: 2,612
Mine is pulled out now.. The internal hose ruptured, fixed already but it's going up for sale...

Real happy with the Squash!
Matt @ FSP is offline   Reply With Quote
Old 06-27-2013, 11:47 AM   #54
CamaroSS45
Annihilator
 
CamaroSS45's Avatar
 
Drives: 2012 45th ERL-427 F1X
Join Date: Aug 2011
Location: KY
Posts: 335
? on wiring .... of Aeromotive and FPCM trigger.

Guys -

I am still running the Stealth and perhaps its new / refreshed / or my luck has not run out yet - but working solid "so far for me" and we are doing 894 rwhp / 899 ft-lb and several passes.... However - when I see a thread like this - I never forget it and assume my time will come..... There is far too much braintrust here to think you will just get lucky

For now my question is this, and really hope someone can help me - Matt is working this as well. But the way Aeromotive has their system run - and also Squash and others "I believe" if hot for the most part and surrenders the safety controls existent in the FPCM in the event of failure, and fuel will continue to gush.

Could someone please point me to the proper pinout to use the hot or ground and leverage this in our setup to maintain safety? I have searched like crazy but the way the Aeromotive is connected so it behaves just like the factory pump from an on / off / safety standpoint.

Many thanks to all
__________________
ERL M3 Superdeck 427 Forged, Dragon Slayer Crank, Black Label Heads : ProCharger F1X Cog - Holley HighRam : Jakes4L80e CircleD - DSS 9" 1400 axles/shaft, BMR Suspension : Extreme Innovations 15 : Squash, Bosch 127lb FI : ALKY Twin Meth
CamaroSS45 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:00 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.