Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
ADM PERFORMANCE
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Forced Induction - V6


Reply
 
Thread Tools
Old 03-20-2013, 02:17 PM   #43
Yohan
 
Drives: 2012 Camaro V6 1LT
Join Date: Jun 2012
Location: Fort Lauderdale, FL
Posts: 287
Saw the car upfront and personal last Friday at Towers meetup. No way anyone could tell it was in an accident like that. Car looked bada$$, and that IPF S/C on board has to be the cleanest sleekest S/C product in market. Congrats on getting the beast back!
__________________
[C.A.I. intake | VMax TB | Solo Mach X-LLT Catback | Solo High Flow Cats | TSW Interlagos 20x9 Fronts, 20x10 Rears w/ Nitto Invos]
Yohan is offline   Reply With Quote
Old 03-20-2013, 03:48 PM   #44
lscamaro


 
lscamaro's Avatar
 
Drives: 2011 CGM Camaro LS A6
Join Date: Jan 2011
Location: San Antonio, Texas
Posts: 10,310
Glad to hear the car is doing well!
__________________

Click Picture for Build Thread
lscamaro is offline   Reply With Quote
Old 03-20-2013, 05:24 PM   #45
blackTT600

 
Drives: 2011 2LT M6 SC
Join Date: Jan 2011
Location: South Florida
Posts: 919
Quote:
Originally Posted by Yohan View Post
Saw the car upfront and personal last Friday at Towers meetup. No way anyone could tell it was in an accident like that. Car looked bada$$, and that IPF S/C on board has to be the cleanest sleekest S/C product in market. Congrats on getting the beast back!
Thanks bro, It was nice meeting you at the show. I added a few small mods to her over the weekend. its never ending... blacked out the side indicators, and added some glow. Ill add some pix at a later date.
blackTT600 is offline   Reply With Quote
Old 03-20-2013, 05:25 PM   #46
blackTT600

 
Drives: 2011 2LT M6 SC
Join Date: Jan 2011
Location: South Florida
Posts: 919
Quote:
Originally Posted by lscamaro View Post
Glad to hear the car is doing well!
me too. it took WAY TO LONG
blackTT600 is offline   Reply With Quote
Old 03-20-2013, 08:14 PM   #47
Macrackie
 
Macrackie's Avatar
 
Drives: 2011 Camaro LS Stripper model
Join Date: Feb 2011
Location: South Beloit IL
Posts: 641
First time I have checked in on this thread in a long time I guess. Glad you got your ride back.

Looking over the photos from the accident can anybody say "fastest rear bumper removal in the great florida state". Figured I was safe to say this now that you got her back and in great shape.
Macrackie is offline   Reply With Quote
Old 07-17-2013, 08:56 AM   #48
blackTT600

 
Drives: 2011 2LT M6 SC
Join Date: Jan 2011
Location: South Florida
Posts: 919
http://s168.photobucket.com/user/znn...?sort=3&page=1
blackTT600 is offline   Reply With Quote
Old 07-18-2013, 09:04 AM   #49
BaylorCamaro
Track > 1/4 Mile
 
BaylorCamaro's Avatar
 
Drives: 2016 C7 Z51
Join Date: Sep 2009
Location: League City, TX
Posts: 6,054
Quote:
Originally Posted by blackTT600 View Post
Cool pics!

Sent from my SAMSUNG Galaxy S III using telekinesis.
__________________
BaylorCamaro is offline   Reply With Quote
Old 07-18-2013, 09:10 AM   #50
blackTT600

 
Drives: 2011 2LT M6 SC
Join Date: Jan 2011
Location: South Florida
Posts: 919
thanks man!
blackTT600 is offline   Reply With Quote
Old 07-18-2013, 11:08 AM   #51
butters
It's not the batmobile!
 
butters's Avatar
 
Drives: 2012 Camaro LFX
Join Date: Jul 2011
Location: Chicago, IL
Posts: 1,094
Right on man!
butters is offline   Reply With Quote
Old 08-26-2014, 09:12 PM   #52
blackTT600

 
Drives: 2011 2LT M6 SC
Join Date: Jan 2011
Location: South Florida
Posts: 919
Good evening Ladies and Gents... I would like to just bring every one up to date on my build.
Fists off it is (WAS) a 2011 2LT RS M6.
I have the IPF kit, BMR Sways, and full BMR race bushings. I upgraded my breaks to SS(mine are 05 CTS V, but same as SS) up front, and then Pads, Lines, and Rotors all around. I have my Clutch and Break fluid separated. ARH LT headers no cats, Solo exhaust. I have a fully custom oil cooler setup. I made a plenum placer. TSW Nurburgring and Nitto NT555's all around. I have a ZL1 front clip, with a VIS AMS full carbon fiber hood. I just picked her up from Redline Motorsports here in pompano beach where some of the above was just done. As well as a full custom Dyno tune with HPTuners softwhere. She made 428.7HP and like 360LBs TQ. Also the car drives so well. Better than it has sense the initial install for sure.

Now its not perfect I have a rubbing sound that is concerning, and it sounds to me almost as if the blow off valve is leaking boost. I kind of hear this low baffled shuttering sound. Lastly and this is a big one, the intake keeps popping off the SC head unit. Has happened twice in like maybe 10 miles, engine shuts down because the MAF sees no air flow even though the engine is receiving boost. This left me stranded for like 5 minutes before I decided to pop the hood and BAM.

So have any of you had this intake pop off problem? I just put it back on it all is well, I tightened it pretty tight. Im thinking new better boost hose clamps but idk? If you have had this problem please let me know how you fixed it.

Thanks for reading. Ill post some pictures after I spend some loving time cleaning her.

Zinn
blackTT600 is offline   Reply With Quote
Old 08-26-2014, 09:49 PM   #53
MagnumForceGB


 
MagnumForceGB's Avatar
 
Drives: Fastest 2010 Camaro V6
Join Date: Apr 2010
Location: Newcastle, OK
Posts: 3,148
Jack the front end up, remove the wheel, the wheel liner, and remove the loosen the bolt holding the metal intake pipe. Push the top of the intake pipe where the silicon elbow hooks into the supercharger then tighten the bolt down. That should prevent it from moving away from the supercharger.

Had the same thing happen to me a long time ago.
__________________
Camaro V6 = 11.752 @ 117.27
MagnumForceGB is online now   Reply With Quote
Old 08-26-2014, 10:16 PM   #54
blackTT600

 
Drives: 2011 2LT M6 SC
Join Date: Jan 2011
Location: South Florida
Posts: 919
Ill try that thank you! He said it was only making albs of boost. You know what would do that?
blackTT600 is offline   Reply With Quote
Old 08-26-2014, 11:06 PM   #55
KMPrenger


 
KMPrenger's Avatar
 
Drives: 16 SS Camaro, 06 Colorado
Join Date: May 2009
Location: Jefferson City, Missouri
Posts: 12,335
428HP....nice. That's a great number for the IPF kit. If you have the dyno sheet you should add your info to the forced induction sticky thread.
__________________
2016 Camaro 1SS - 8-speed - NPP - Black bowties
2010 Camaro 1LT V6 (Sold. I will miss her!)
KMPrenger is offline   Reply With Quote
Old 08-26-2014, 11:53 PM   #56
gutterball

 
gutterball's Avatar
 
Drives: 2011 1LS M6 Supercharged
Join Date: Feb 2011
Location: New Britain, Ct
Posts: 886
Send a message via AIM to gutterball
Had the same thing happen to me, when they put the tube in, they inserted it to much on the bottom, preventing the top from having enough movement, also my blow off valve was fluttering when it was open, this was cured by going to a bigger blow off valve.
gutterball is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:39 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.