Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
BeckyD@RodgersChevrolet
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Forced Induction - V8

Forced Induction - V8 V8 Supercharger, turbo, nitrous discussions

Reply
 
Thread Tools
Old 03-26-2013, 01:57 PM   #351
tramtwo


 
tramtwo's Avatar
 
Drives: 2013 1LE
Join Date: Jul 2011
Location: N'Awlinz
Posts: 6,545


Now THAT is just bad assed. Congratz on COTW!!
__________________
tramtwo is offline   Reply With Quote
Old 03-26-2013, 02:57 PM   #352
akCamaross
 
akCamaross's Avatar
 
Drives: 2011 Camaro 2SS
Join Date: May 2012
Location: Huntingtown, Maryland
Posts: 422
Congrats man, i have followed your whole build from the beginning.
__________________
2011 Camaro 2SS - SIM - M6 + Mods haha
akCamaross is offline   Reply With Quote
Old 03-26-2013, 04:36 PM   #353
Blackone
 
Blackone's Avatar
 
Drives: 2011er SS in black!...what else?
Join Date: Nov 2011
Location: Germany
Posts: 701
congrats on cotw
__________________
Blackone is offline   Reply With Quote
Old 03-27-2013, 09:32 AM   #354
RED DEMON SS
OFF THE CHAIN
 
RED DEMON SS's Avatar
 
Drives: RED DEMON!
Join Date: Sep 2011
Location: PNW MISFIT
Posts: 8,339
Congratulations on COTW, well deserved for your BEAST!
__________________
RED DEMON SS is offline   Reply With Quote
Old 03-27-2013, 01:53 PM   #355
jamesr
 
jamesr's Avatar
 
Drives: 2012 Camaro ss
Join Date: Nov 2012
Location: Topeka,Kansas
Posts: 92
Where and when is KC2K13 ?
jamesr is offline   Reply With Quote
Old 03-27-2013, 02:21 PM   #356
LeanPocket
 
Drives: 2010 2SS
Join Date: Jan 2013
Location: Corpus Christi TX
Posts: 628
you tempted to build up a z2/8
LeanPocket is offline   Reply With Quote
Old 03-27-2013, 02:56 PM   #357
stangkilr
 
stangkilr's Avatar
 
Drives: 2010 Camaro SS | 2013 Camaro 1LE
Join Date: Jan 2011
Location: Missouri
Posts: 620
Quote:
Originally Posted by jamesr View Post
Where and when is KC2K13 ?
May 18th in Kansas City Mo
__________________
http://www.camaro5.com/forums/image.php?type=sigpic&userid=37570&dateline=138293  2783
2010 Camaro SS CGM |LY6 6.0L | E85 | x275 88mm turbo/ TH400/ Gforce 9 inch

Youtube "stangkilr99"
stangkilr is offline   Reply With Quote
Old 03-27-2013, 04:07 PM   #358
PHEOX
 
Drives: '06 Jeep Wrangler
Join Date: Dec 2009
Location: Cypress, Texas
Posts: 629
First off, I haven't seen anything on spring rates? What are you running, more so in the rear?
And when people ask you how much power you make, simply reply with, "All of it."
__________________
Just Empties Every Pocket
PHEOX is offline   Reply With Quote
Old 03-27-2013, 07:45 PM   #359
Pro Stock John
Writer
 
Pro Stock John's Avatar
 
Drives: 2010 SS / 1951 Mercury
Join Date: May 2009
Location: Chicago, IL
Posts: 4,710
Thrust bearing?

That can go if you are too long on the brake, have too much line pressure to the converter. etc....
__________________
PROJECT HEAVY CHEVY: 2010 Camaro SS/RS |Mods for the Masses Articles
13.15@106 1.95 | 100% Stock
12.37@112 1.85 | Headers, Cats | 555R DR | CAI | UDP | Tune
12.06@113 1.70 | +NT05R 18s | + Circle D 3200
11.90@112 1.60 | + 3.91s | +Race Star 17x7s
Mods: GPI Tune | Bo's PTB | Kooks LTs | Hooker Maxflows | Circle D 3200 | New Era OTR | RCR AirRam Manifold | Powerbond UDP | 3.91s
Pro Stock John is online now   Reply With Quote
Old 03-27-2013, 07:59 PM   #360
Camper
Banned
 
Drives: 10' 2SS LS3 M6
Join Date: May 2012
Location: Phoenix,AZ
Posts: 1,394
Quote:
Originally Posted by stangkilr View Post
Thanks guys. Going to start working on the car again. I think my bad transmission I got blew the thrust bearing out of the motor. Sucks because its nothing I could have prevented. Transmission was missing two thrust washers on the rear tail shaft/drum. Caused everything to slide back and fourth. Going to try and have it back together for my HUGE event I am hosting in Kansas City Mo called KC2K13. You all should come out.
when is the event?
Camper is offline   Reply With Quote
Old 03-27-2013, 09:24 PM   #361
stangkilr
 
stangkilr's Avatar
 
Drives: 2010 Camaro SS | 2013 Camaro 1LE
Join Date: Jan 2011
Location: Missouri
Posts: 620
Quote:
Originally Posted by Pro Stock John View Post
Thrust bearing?

That can go if you are too long on the brake, have too much line pressure to the converter. etc....
Or when the transmission is missing two thrust bearings causing play in the whole case? lol
__________________
http://www.camaro5.com/forums/image.php?type=sigpic&userid=37570&dateline=138293  2783
2010 Camaro SS CGM |LY6 6.0L | E85 | x275 88mm turbo/ TH400/ Gforce 9 inch

Youtube "stangkilr99"
stangkilr is offline   Reply With Quote
Old 03-27-2013, 09:24 PM   #362
stangkilr
 
stangkilr's Avatar
 
Drives: 2010 Camaro SS | 2013 Camaro 1LE
Join Date: Jan 2011
Location: Missouri
Posts: 620
Quote:
Originally Posted by Camper View Post
when is the event?
May 17-18th
__________________
http://www.camaro5.com/forums/image.php?type=sigpic&userid=37570&dateline=138293  2783
2010 Camaro SS CGM |LY6 6.0L | E85 | x275 88mm turbo/ TH400/ Gforce 9 inch

Youtube "stangkilr99"
stangkilr is offline   Reply With Quote
Old 03-28-2013, 09:26 AM   #363
Deke736
COTW 12/3/12
 
Deke736's Avatar
 
Drives: 2012 Ashen Gray ZL1
Join Date: Aug 2011
Location: Glen Carbon, IL
Posts: 3,149
Congrats on COTW! Car is SICK!!
__________________
Deke736 is offline   Reply With Quote
Old 03-29-2013, 07:37 AM   #364
se7en

 
Drives: 87 Pinto on 32's
Join Date: Oct 2009
Location: Southern Illinois
Posts: 1,649
I just spent almost an hour reading this whole thread. What a build and from your garage mainly from what it looks.....makes it that more cool as can be. I'm amazed with the knowledge and expertise that it took to go into this build. Just curious, but how did you get into doing builds like this yourself?

I also have the GFORCE 9" and couldnt be happier!! You will tear everything up several times before you have any problems out of that rear-end.
se7en is offline   Reply With Quote
Old 03-30-2013, 05:37 PM   #365
stangkilr
 
stangkilr's Avatar
 
Drives: 2010 Camaro SS | 2013 Camaro 1LE
Join Date: Jan 2011
Location: Missouri
Posts: 620
Quote:
Originally Posted by se7en View Post
I just spent almost an hour reading this whole thread. What a build and from your garage mainly from what it looks.....makes it that more cool as can be. I'm amazed with the knowledge and expertise that it took to go into this build. Just curious, but how did you get into doing builds like this yourself?

I also have the GFORCE 9" and couldnt be happier!! You will tear everything up several times before you have any problems out of that rear-end.
Well it all started with my last car (2002 Z28) that became internet famous for how clean/fast it was. I have always been a fan of clean and simple setups and when I switched to a turbo setup I was afraid I would lose that look. I am lucky to have a friend thats very good at fabrication from his garage. He had the same tastes as I do. I put my input on how I want it and he makes it happen. From that point its all me and I put the rest of the puzzle pieces together to make a very fast car I can drive anywhere and take to car shows.
__________________
http://www.camaro5.com/forums/image.php?type=sigpic&userid=37570&dateline=138293  2783
2010 Camaro SS CGM |LY6 6.0L | E85 | x275 88mm turbo/ TH400/ Gforce 9 inch

Youtube "stangkilr99"
stangkilr is offline   Reply With Quote
Old 03-30-2013, 05:38 PM   #366
stangkilr
 
stangkilr's Avatar
 
Drives: 2010 Camaro SS | 2013 Camaro 1LE
Join Date: Jan 2011
Location: Missouri
Posts: 620
Here are the details on my car meet I am having in May. If you missed TX2K13 then come to this.
https://www.facebook.com/events/516802715016956/
__________________
http://www.camaro5.com/forums/image.php?type=sigpic&userid=37570&dateline=138293  2783
2010 Camaro SS CGM |LY6 6.0L | E85 | x275 88mm turbo/ TH400/ Gforce 9 inch

Youtube "stangkilr99"
stangkilr is offline   Reply With Quote
Old 04-05-2013, 09:56 AM   #367
stangkilr
 
stangkilr's Avatar
 
Drives: 2010 Camaro SS | 2013 Camaro 1LE
Join Date: Jan 2011
Location: Missouri
Posts: 620
Thrust bearing in the motor is what failed.
__________________
http://www.camaro5.com/forums/image.php?type=sigpic&userid=37570&dateline=138293  2783
2010 Camaro SS CGM |LY6 6.0L | E85 | x275 88mm turbo/ TH400/ Gforce 9 inch

Youtube "stangkilr99"
stangkilr is offline   Reply With Quote
Old 04-05-2013, 10:10 AM   #368
BlkSlvrdo129
 
Drives: 2008 Silverado
Join Date: Dec 2010
Location: Canada
Posts: 98
Quote:
Originally Posted by stangkilr View Post
Thrust bearing in the motor is what failed.
Couple things come to mind; have you been spooling up against the converter frequently, and do you know what the crank endplay was set at? There's a guy on Tech with a 408 single turbo trans am that's gone through 2 thrust bearings so far.
BlkSlvrdo129 is offline   Reply With Quote
Old 04-05-2013, 10:27 AM   #369
stangkilr
 
stangkilr's Avatar
 
Drives: 2010 Camaro SS | 2013 Camaro 1LE
Join Date: Jan 2011
Location: Missouri
Posts: 620
Quote:
Originally Posted by BlkSlvrdo129 View Post
Couple things come to mind; have you been spooling up against the converter frequently, and do you know what the crank endplay was set at? There's a guy on Tech with a 408 single turbo trans am that's gone through 2 thrust bearings so far.
Eh, this was caused by the transmission missing two thrust washers causing movement in the whole case.
__________________
http://www.camaro5.com/forums/image.php?type=sigpic&userid=37570&dateline=138293  2783
2010 Camaro SS CGM |LY6 6.0L | E85 | x275 88mm turbo/ TH400/ Gforce 9 inch

Youtube "stangkilr99"
stangkilr is offline   Reply With Quote
Old 04-05-2013, 10:31 AM   #370
willhe64

 
willhe64's Avatar
 
Drives: 2012 45th Vert, 2011 4x4, 9sec Vega
Join Date: Mar 2012
Location: Canada
Posts: 1,905
Quote:
Originally Posted by BlkSlvrdo129 View Post
do you know what the crank endplay was set at?

started at 0.008" and ended at 0.400"
__________________
I feel it only fair to warn you, I have a black belt in CAPS LOCK.
willhe64 is offline   Reply With Quote
Old 04-05-2013, 10:50 AM   #371
BlkSlvrdo129
 
Drives: 2008 Silverado
Join Date: Dec 2010
Location: Canada
Posts: 98
Quote:
Originally Posted by stangkilr View Post
Eh, this was caused by the transmission missing two thrust washers causing movement in the whole case.
Ah, missed that part. Pays to read back I suppose!
BlkSlvrdo129 is offline   Reply With Quote
Old 04-05-2013, 10:52 AM   #372
stangkilr
 
stangkilr's Avatar
 
Drives: 2010 Camaro SS | 2013 Camaro 1LE
Join Date: Jan 2011
Location: Missouri
Posts: 620
Quote:
Originally Posted by willhe64 View Post
started at 0.008" and ended at 0.400"
__________________
http://www.camaro5.com/forums/image.php?type=sigpic&userid=37570&dateline=138293  2783
2010 Camaro SS CGM |LY6 6.0L | E85 | x275 88mm turbo/ TH400/ Gforce 9 inch

Youtube "stangkilr99"
stangkilr is offline   Reply With Quote
Old 04-05-2013, 10:56 AM   #373
BlkSlvrdo129
 
Drives: 2008 Silverado
Join Date: Dec 2010
Location: Canada
Posts: 98
How does the crank look?
BlkSlvrdo129 is offline   Reply With Quote
Old 04-17-2013, 10:14 PM   #374
thahemp
Geek
 
thahemp's Avatar
 
Drives: 2012 Black LS3
Join Date: Jan 2012
Location: Derby, KS
Posts: 4,202
Just bringing this back from page 2...

I hope all is well.
__________________
01000111011011110110111101100100001000000110110001 11010101100011011010110010000001110111011010010111 01000110100000100000011101000110100001101001011100 110010000001101111011011100110010100100001

x = ac97968bd3df8f968c8cd3df998a9c94d3df9c8a918bd3df9c 909c94df8c8a9c949a8dd3df92908b979a8ddf998a9c949a8d d3df8b968b8cd1
x = ~x
thahemp is offline   Reply With Quote
Old 04-18-2013, 04:06 PM   #375
stangkilr
 
stangkilr's Avatar
 
Drives: 2010 Camaro SS | 2013 Camaro 1LE
Join Date: Jan 2011
Location: Missouri
Posts: 620
Engine is being fixed now. Needed a new crank and block. I should have it back in a week or so.
__________________
http://www.camaro5.com/forums/image.php?type=sigpic&userid=37570&dateline=138293  2783
2010 Camaro SS CGM |LY6 6.0L | E85 | x275 88mm turbo/ TH400/ Gforce 9 inch

Youtube "stangkilr99"
stangkilr is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.