Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Cam Motion
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V6 LLT Engine, Exhaust, and Bolt-Ons

Camaro V6 LLT Engine, Exhaust, and Bolt-Ons Bolt-Ons | Intakes | Exhaust

Reply
 
Thread Tools
Old 03-29-2013, 11:04 PM   #1
J_Vibe92

 
J_Vibe92's Avatar
 
Drives: 2011 Chevy Camaro LS (LLT)
Join Date: Dec 2012
Location: Houston
Posts: 1,738
Vmax Black ICE issues and Review

I just installed the black ice here is my review and issues i had.


First off the back bolts are not as hard as it seems, just work at it and it will come off. Now after installing the permatex, i let it sit for about 10 minutes then i put the IM back on and waited about 1 hour and a half and test drove it. Here is where i had a problem.


the very back bolt apparently wasnt screwed all the way and my engine turned on and died before it could choke. I got some smoke too. NOTE TO EVERYONE MAKE SURE YOU TIGHTEN THE BACK BOLT THAT GOES IN VERTICAL OR YOU WILL FREAK OUT WHEN YOU TURN ON THE ENGINE!!!!

Well I found it and retighten it. Also I broke a plenum bolt at 8lbft of TQ. so I guess I had a weak one. I torqued the big bolts to 18lb and the plenum ones to 10 and some 9 isssh. now i gotta take it somewhere to get the bolt out :(((((((((((((((((((((


well all in all, it was a interesting hands on job today. My engine had NO oil and only put in a catch can from Elite at 25K miles. Literally no oil at all. I was real happy.


IF anyone wants to know i got mine from SW Speeed from Ivan and he helped me out and is probably the best guy to contact with any problems. THANK YOU IVAN!


Well theres my review. next mod, headers from BBK
__________________
Performance Mods: Vararam Intake, MRTv2.0 exhaust, Elite Engineering CC, Vmax Black Iceolator, Vmax Ported TB, OBX LT Headers w/ no CATS, LMR Tune
Visual mods: Eagle Eyes w/5k hids, Custom Hood Spears, Heritage Grille, Stage 2 LED Dome lights,Transformer Emblems, PD Bezels, 19in Chevy rims with pirellis, Blue painted calipers, GM GFX Front Splitter, 35/20 % Tint, TailLight Tint(charcoal)
1/4 Mile: 13.65 sec @ 102.53 mph
J_Vibe92 is offline   Reply With Quote
Old 03-29-2013, 11:12 PM   #2
bandier
Got mine!
 
bandier's Avatar
 
Drives: 2010 Camaro 2LT - Yellow w/ Stripes
Join Date: Mar 2011
Location: Fallbrook, CA
Posts: 934
that's it??? you gotta say what the car ran like after you put it on.
bandier is offline   Reply With Quote
Old 03-29-2013, 11:14 PM   #3
J_Vibe92

 
J_Vibe92's Avatar
 
Drives: 2011 Chevy Camaro LS (LLT)
Join Date: Dec 2012
Location: Houston
Posts: 1,738
My bad, i thought i said it haha I just wrote this really quick. Well my first impression was it pulled pretty good after 30 mph. what really matters was after about 15 min of HARD pulling, back and forth from highways and stoplights, the IM was only at 101 F while before it was over 140F after a 15 min hard run.
__________________
Performance Mods: Vararam Intake, MRTv2.0 exhaust, Elite Engineering CC, Vmax Black Iceolator, Vmax Ported TB, OBX LT Headers w/ no CATS, LMR Tune
Visual mods: Eagle Eyes w/5k hids, Custom Hood Spears, Heritage Grille, Stage 2 LED Dome lights,Transformer Emblems, PD Bezels, 19in Chevy rims with pirellis, Blue painted calipers, GM GFX Front Splitter, 35/20 % Tint, TailLight Tint(charcoal)
1/4 Mile: 13.65 sec @ 102.53 mph
J_Vibe92 is offline   Reply With Quote
Old 03-29-2013, 11:42 PM   #4
J_Vibe92

 
J_Vibe92's Avatar
 
Drives: 2011 Chevy Camaro LS (LLT)
Join Date: Dec 2012
Location: Houston
Posts: 1,738
Curiosity since the Throttle body bolt was not resused, i just deleted the mount thing that connect the throttle body to the engine i guess. is that okay?
__________________
Performance Mods: Vararam Intake, MRTv2.0 exhaust, Elite Engineering CC, Vmax Black Iceolator, Vmax Ported TB, OBX LT Headers w/ no CATS, LMR Tune
Visual mods: Eagle Eyes w/5k hids, Custom Hood Spears, Heritage Grille, Stage 2 LED Dome lights,Transformer Emblems, PD Bezels, 19in Chevy rims with pirellis, Blue painted calipers, GM GFX Front Splitter, 35/20 % Tint, TailLight Tint(charcoal)
1/4 Mile: 13.65 sec @ 102.53 mph
J_Vibe92 is offline   Reply With Quote
Old 03-29-2013, 11:54 PM   #5
its a syn
B.O.D. 02/16/10
 
its a syn's Avatar
 
Drives: 2010 Synergy Green SE
Join Date: Jun 2010
Location: Albia,Iowa
Posts: 3,215
Quote:
Originally Posted by J_Vibe92 View Post
Curiosity since the Throttle body bolt was not resused, i just deleted the mount thing that connect the throttle body to the engine i guess. is that okay?
yup.
__________________
its a syn is offline   Reply With Quote
Old 03-29-2013, 11:58 PM   #6
J_Vibe92

 
J_Vibe92's Avatar
 
Drives: 2011 Chevy Camaro LS (LLT)
Join Date: Dec 2012
Location: Houston
Posts: 1,738
Ok good. lol
__________________
Performance Mods: Vararam Intake, MRTv2.0 exhaust, Elite Engineering CC, Vmax Black Iceolator, Vmax Ported TB, OBX LT Headers w/ no CATS, LMR Tune
Visual mods: Eagle Eyes w/5k hids, Custom Hood Spears, Heritage Grille, Stage 2 LED Dome lights,Transformer Emblems, PD Bezels, 19in Chevy rims with pirellis, Blue painted calipers, GM GFX Front Splitter, 35/20 % Tint, TailLight Tint(charcoal)
1/4 Mile: 13.65 sec @ 102.53 mph
J_Vibe92 is offline   Reply With Quote
Old 03-29-2013, 11:59 PM   #7
its a syn
B.O.D. 02/16/10
 
its a syn's Avatar
 
Drives: 2010 Synergy Green SE
Join Date: Jun 2010
Location: Albia,Iowa
Posts: 3,215
I threw mine in with any other extra parts I've amassed with my different mods.
__________________
its a syn is offline   Reply With Quote
Old 03-30-2013, 12:14 AM   #8
Lil' Nasty
Emerald Coast Camaros
 
Lil' Nasty's Avatar
 
Drives: Supercharged V6
Join Date: Jul 2010
Location: Florida
Posts: 5,093
Just make sure it's not threaded longer than the bolt you broke
__________________
Lil' Nasty is offline   Reply With Quote
Old 03-30-2013, 07:12 AM   #9
rtcat600man
having FUN now 13.66@101
 
rtcat600man's Avatar
 
Drives: 2010 2LT IOM
Join Date: Nov 2009
Location: Clarkston, Michigan
Posts: 7,790
Congrats on the install. Sorry to hear about the broken bolt. Odd that a plenum bolt broke so easy. I had tighten mine probably too much as I was trying to torque them to speck, but at such a low number the TQ wrench was not doing it's "click" when there sound.

You can buy a set of easy out's to try and pull that broken bolt out. Do a search on the internet for broken bolts and easy outs. Pretty easy to do. And since the bolt was out already once, and not in there to tight, should come right back out. Good Luck, keep us informed on how it goes.
__________________
rtcat600man is offline   Reply With Quote
Old 04-01-2013, 01:57 PM   #10
Ivan @ Southwest Speed
Southwestspeed.net

 
Ivan @ Southwest Speed's Avatar
 
Drives: '10 2SS/RS, '96 Z28
Join Date: May 2009
Location: Rio Rancho, NM
Posts: 11,650
Quote:
Originally Posted by J_Vibe92 View Post
I just installed the black ice here is my review and issues i had.


First off the back bolts are not as hard as it seems, just work at it and it will come off. Now after installing the permatex, i let it sit for about 10 minutes then i put the IM back on and waited about 1 hour and a half and test drove it. Here is where i had a problem.


the very back bolt apparently wasnt screwed all the way and my engine turned on and died before it could choke. I got some smoke too. NOTE TO EVERYONE MAKE SURE YOU TIGHTEN THE BACK BOLT THAT GOES IN VERTICAL OR YOU WILL FREAK OUT WHEN YOU TURN ON THE ENGINE!!!!

Well I found it and retighten it. Also I broke a plenum bolt at 8lbft of TQ. so I guess I had a weak one. I torqued the big bolts to 18lb and the plenum ones to 10 and some 9 isssh. now i gotta take it somewhere to get the bolt out :(((((((((((((((((((((


well all in all, it was a interesting hands on job today. My engine had NO oil and only put in a catch can from Elite at 25K miles. Literally no oil at all. I was real happy.


IF anyone wants to know i got mine from SW Speeed from Ivan and he helped me out and is probably the best guy to contact with any problems. THANK YOU IVAN!


Well theres my review. next mod, headers from BBK
You're welcome! Thank you and sorry to hear about your bolt issue.

If you need a replacement, drop me a PM and I'll send one out for ya. In case.

Again, really appreciate the time you took to mention us. Means alot.
Ivan & the SWS Team!
Ivan @ Southwest Speed is offline   Reply With Quote
Old 04-01-2013, 02:38 PM   #11
SC2150
Account Suspended
 
Drives: 2012 Camaro RS, RX supercharged
Join Date: Dec 2009
Location: Bradenton, FL
Posts: 6,080
When you have the IM off, did you shine a light in the intake ports of the cylinder heads to look at your intake valves? Good job on all!

SC2150 is offline   Reply With Quote
Old 04-01-2013, 02:50 PM   #12
J_Vibe92

 
J_Vibe92's Avatar
 
Drives: 2011 Chevy Camaro LS (LLT)
Join Date: Dec 2012
Location: Houston
Posts: 1,738
Yeah. all spotless, literally
__________________
Performance Mods: Vararam Intake, MRTv2.0 exhaust, Elite Engineering CC, Vmax Black Iceolator, Vmax Ported TB, OBX LT Headers w/ no CATS, LMR Tune
Visual mods: Eagle Eyes w/5k hids, Custom Hood Spears, Heritage Grille, Stage 2 LED Dome lights,Transformer Emblems, PD Bezels, 19in Chevy rims with pirellis, Blue painted calipers, GM GFX Front Splitter, 35/20 % Tint, TailLight Tint(charcoal)
1/4 Mile: 13.65 sec @ 102.53 mph
J_Vibe92 is offline   Reply With Quote
Old 04-01-2013, 06:43 PM   #13
pgustavson
does NOT drive a "'vert"
 
pgustavson's Avatar
 
Drives: 2011 2LT Convertible
Join Date: Feb 2012
Location: Gambrills, MD
Posts: 1,311
Did you install a plenum spacer too? Otherwise, why were plenum cover bolts removed?
__________________
Vararam | Vmax Ported TB | Ported IM | Vmax Black ICE-olator
pgustavson is offline   Reply With Quote
Old 04-01-2013, 09:33 PM   #14
J_Vibe92

 
J_Vibe92's Avatar
 
Drives: 2011 Chevy Camaro LS (LLT)
Join Date: Dec 2012
Location: Houston
Posts: 1,738
no i didnt install the plenum spacer and i removed them to get a full inspection of how much oil i have in my car. that an you have to remove most of them anyways
__________________
Performance Mods: Vararam Intake, MRTv2.0 exhaust, Elite Engineering CC, Vmax Black Iceolator, Vmax Ported TB, OBX LT Headers w/ no CATS, LMR Tune
Visual mods: Eagle Eyes w/5k hids, Custom Hood Spears, Heritage Grille, Stage 2 LED Dome lights,Transformer Emblems, PD Bezels, 19in Chevy rims with pirellis, Blue painted calipers, GM GFX Front Splitter, 35/20 % Tint, TailLight Tint(charcoal)
1/4 Mile: 13.65 sec @ 102.53 mph
J_Vibe92 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:31 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.