Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Phastek Performance
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 06-30-2009, 09:31 PM   #1
camaroguy
MJ is finally home!
 
camaroguy's Avatar
 
Drives: 2010 CGM 2SS/RS Camaro M6
Join Date: Jan 2009
Location: Olathe, KS
Posts: 219
2010 Camaro Launch Control = Transmission Failure

Ah, such much fun driving my Camaro. Took my neighbor out tonight for a ride and decided to hit the mall parking lot for a quick burnout. Well, didn't get to do the burnout, instead I decided to try out the Launch Control... So I get it into Competitive mode, mash the accelerator to the floor. I check, and its holding about 4200 rpms like it shoud.... Every thing looks fine and dandy... Dump the clutch... BAMMMMMMM!

Now here I am with my neighbor friend, and the first thing he says... " oh shit!, you're done...".... As far as I can tell, the tremec didn't hold up to the dump of the clutch. I can't get the camaro to move in gear now at all.. Leaking trans fluid going everywhere on the ground.... called onstar.. Get everything set up to get it towed back to the dealer right now. I am sure the tremec's tail shaft snapped..

So much for launch control... Maybe if I had slippery tires, it wouldn't of been a problem.. Oh, and while waiting for the Tow truck guy, here comes this ricer into the parking lot doing donuts and just making me feel worse about the whole situation.. I still love the Camaro though.. Now I have to sit and wait while I figure out what the dealer is going to do about it.

Anybody else's M6 transmission broke yet from burnouts/ launch control?
camaroguy is offline   Reply With Quote
Old 06-30-2009, 09:33 PM   #2
ljustin293


 
ljustin293's Avatar
 
Drives: 2010 VR CAMARO 2SS/RS
Join Date: Aug 2008
Location: GA
Posts: 15,089
there was just a thread on here about something loose on the tranny...that might be what happened to yours...I hate to hear it for you..hopefully it can be fixed soon
ljustin293 is offline   Reply With Quote
Old 06-30-2009, 09:36 PM   #3
Paperer
Ragin' Cajun
 
Paperer's Avatar
 
Drives: '02 Camaro SS - '10 CGM 2SS/RS
Join Date: Jul 2008
Location: Texas/Oklahoma
Posts: 1,170
Damn man, that sucks. I wish the best for you and your car. Is there any video of anyone doing a successful launch??
__________________
http://img.photobucket.com/albums/v202/paper2302/Siggy.jpg
Paperer is offline   Reply With Quote
Old 06-30-2009, 09:36 PM   #4
ljustin293


 
ljustin293's Avatar
 
Drives: 2010 VR CAMARO 2SS/RS
Join Date: Aug 2008
Location: GA
Posts: 15,089
here is that other thread http://www.camaro5.com/forums/showthread.php?t=29895
ljustin293 is offline   Reply With Quote
Old 06-30-2009, 09:37 PM   #5
BackinBlackSS/RS
Go Blue!!!!!
 
BackinBlackSS/RS's Avatar
 
Drives: 2012 Cruze LT
Join Date: Mar 2009
Location: Indiana
Posts: 23,365
OMG that is terrible. Kinda scary considering it is something that is built in to the
traction control system and is something they tell you you can do. Let us know
what happened. Sorry, I feel bad for you and your baby. :(
BackinBlackSS/RS is offline   Reply With Quote
Old 06-30-2009, 09:38 PM   #6
coolman
Guest
 

Join Date: Jun 2009
Location: PA
Posts: 4,871
Sounds like it's becoming a growing problem , and don't even need to be hard on it.
coolman is offline   Reply With Quote
Old 06-30-2009, 09:43 PM   #7
mlee
H-Town Camaro Club
 
mlee's Avatar
 
Drives: Number Twenty-Three
Join Date: Oct 2008
Location: Conroe, TX
Posts: 24,411
Something had to be wrong with it... I've seen plenty of good launches... At least you'll get it fixed early when they can't give you any grief... or shouldn't give you any grief...
__________________
.
mlee is offline   Reply With Quote
Old 06-30-2009, 09:44 PM   #8
ibznu2010
 
ibznu2010's Avatar
 
Drives: 2010 blk 2SS RS polished wheel
Join Date: Mar 2009
Location: Sylvester Georgia
Posts: 158
Sounds like manual is having trouble like under power autos. wtf Gm. i did not pay 40 gran for this shit.
ibznu2010 is offline   Reply With Quote
Old 06-30-2009, 09:54 PM   #9
camaroguy
MJ is finally home!
 
camaroguy's Avatar
 
Drives: 2010 CGM 2SS/RS Camaro M6
Join Date: Jan 2009
Location: Olathe, KS
Posts: 219
Yeah, there must of been a weak part in the transmission to just break like that.. I am assuming something broke anyways due to the loud BAMM noise.. Can't really fault GM for it though since Tremec makes the unit... I'll find out more tomorrow when I call the dealer
camaroguy is offline   Reply With Quote
Old 06-30-2009, 09:59 PM   #10
mlee
H-Town Camaro Club
 
mlee's Avatar
 
Drives: Number Twenty-Three
Join Date: Oct 2008
Location: Conroe, TX
Posts: 24,411
Quote:
Originally Posted by camaroguy View Post
Yeah, there must of been a weak part in the transmission to just break like that.. I am assuming something broke anyways due to the loud BAMM noise.. Can't really fault GM for it though since Tremec makes the unit... I'll find out more tomorrow when I call the dealer
Good luck and hope they get parts quickly...
__________________
.
mlee is offline   Reply With Quote
Old 06-30-2009, 10:13 PM   #11
fazm
 
Drives: ex-500hp v6 mustang
Join Date: Oct 2008
Location: arizona
Posts: 606
cant fault gm for the unit, but you can fault them for picking the unit
fazm is offline   Reply With Quote
Old 07-01-2009, 10:15 AM   #12
JDBeck23

 
Drives: 2010 Camaro, 2SS/RS
Join Date: May 2009
Location: King George, Va
Posts: 877
Just posted on the similar thread, but I'll reiterate... The LS3 and MN6 are not new parts... they've been on the C6 Vettes for a while now... any issues we experience with them, the C6 guys have already seen it too, and there's bound to be more parts availability for the tranny and motor than for the rest of the Camaro.

Im just sayin, it sucks dude... but it's not the end of the world... it could be worse, you could be waiting for parts that are only on the camaro... and since the factory hasnt caught up yet, you'd be waiting for a while.

Problems happen, give GM a chance to fix it before we all start jumping on the "quality control" bandwagon.
__________________

2010 2SS/RS CGM
American Racing Headers, Magnaflow axle back, Roto-Fab CAI, Audio Integrations Sub box, Alpine Type R 10, Alpine MRP-500 amp, Pro Clips iPhone Mount
JDBeck23 is offline   Reply With Quote
Old 07-01-2009, 10:44 AM   #13
camaroguy
MJ is finally home!
 
camaroguy's Avatar
 
Drives: 2010 CGM 2SS/RS Camaro M6
Join Date: Jan 2009
Location: Olathe, KS
Posts: 219
Dude, what are you talking about? You get this thread confused with another??
camaroguy is offline   Reply With Quote
Old 07-01-2009, 10:48 AM   #14
UCF w00t
Geek
 
UCF w00t's Avatar
 
Drives: IOM 2010 Camaro 2SS
Join Date: Oct 2008
Location: Orlando
Posts: 4,456
It's not the fault of launch control, it's a problem with the output shaft of cars built in the mid 16thousands.

http://www.camaro5.com/forums/showthread.php?t=29895

http://www.camaro5.com/forums/showth...383#post634383

http://www.camaro5.com/forums/showthread.php?t=29989

GM is aware of the problem and apparently re-routed some cars to Detroit to get fixed after build but before delivery. Hopefully they get you a new transmission soon.

This makes #4 I believe, all built very close to each other.
UCF w00t is offline   Reply With Quote
Old 07-01-2009, 10:48 AM   #15
1320junkie
Account Suspended
 
Drives: The Imperial Army
Join Date: Feb 2009
Location: The Darkside
Posts: 15,898
Quote:
Originally Posted by fazm View Post
cant fault gm for the unit, but you can fault them for picking the unit
There are wayyy more that are holding up than that are breaking..perfection is nowhere to be found
1320junkie is offline   Reply With Quote
Old 07-01-2009, 10:53 AM   #16
UCF w00t
Geek
 
UCF w00t's Avatar
 
Drives: IOM 2010 Camaro 2SS
Join Date: Oct 2008
Location: Orlando
Posts: 4,456
Quote:
Originally Posted by fazm View Post
cant fault gm for the unit, but you can fault them for picking the unit
Hey mustang boy, the TR6060 is used by the GT500, Corvette, Viper SRT10, Challenger, and others. You really wanna fault GM for picking the TR6060?
UCF w00t is offline   Reply With Quote
Old 07-01-2009, 10:59 AM   #17
2010SLVRBULIT


 
2010SLVRBULIT's Avatar
 
Drives: G5 & C6
Join Date: Apr 2009
Location: MARS
Posts: 6,908
WTF?..beginning to find 'lemons' in this fruitbasket..oh wow..maybe QC is shit up there after all..
2010SLVRBULIT is offline   Reply With Quote
Old 07-01-2009, 11:02 AM   #18
camaroguy
MJ is finally home!
 
camaroguy's Avatar
 
Drives: 2010 CGM 2SS/RS Camaro M6
Join Date: Jan 2009
Location: Olathe, KS
Posts: 219
Its just a quality control issue from Tremec. Won't cost GM anything, just send them back to Tremec for exchange. I'm not worried about it and I know its not a fault of GM and the launch control feature, however, will I try it again? I don't think so... lol I think I will only do full throttle rolling starts from now on...
camaroguy is offline   Reply With Quote
Old 07-01-2009, 11:03 AM   #19
garagelogic
Account Suspended
 
Drives: 2010 Shelby GT500
Join Date: Jul 2008
Location: Tennessee
Posts: 1,687
Quote:
Originally Posted by UCF w00t View Post
Hey mustang boy, the TR6060 is used by the GT500, Corvette, Viper SRT10, Challenger, and others. You really wanna fault GM for picking the TR6060?
Same tranny, but maybe not the same specs. I know there is a difference between the T6060 in the Viper and what's in my car. Input shafts and outputs shafts are likely different, too.
garagelogic is offline   Reply With Quote
Old 07-01-2009, 11:03 AM   #20
Unfair
Banned
 
Drives: 2001 Camaro SS
Join Date: Jun 2009
Location: Chicago, IL
Posts: 754


GM, it's sad to know after all the QC holds things like this still happen to paying customers. i guess you can say it's a tremec issue, but it's gm's responsibility to make sure everything passes QC. idk just venting it sucks to see good customers getting screwed.
Unfair is offline   Reply With Quote
Old 07-01-2009, 11:15 AM   #21
UCF w00t
Geek
 
UCF w00t's Avatar
 
Drives: IOM 2010 Camaro 2SS
Join Date: Oct 2008
Location: Orlando
Posts: 4,456
Quote:
Originally Posted by Unfair View Post


GM, it's sad to know after all the QC holds things like this still happen to paying customers. i guess you can say it's a tremec issue, but it's gm's responsibility to make sure everything passes QC. idk just venting it sucks to see good customers getting screwed.
Stuff like this always happens in any manufacturing process. The only way to test would be to do burnouts and hard launches in the parking lot before they're put on the train. Would you like them to do that? I don't see how customers are getting screwed. They're being taken care of. If GM said "your fault, not covered under warranty" that would be a different situation.
UCF w00t is offline   Reply With Quote
Old 07-01-2009, 11:24 AM   #22
camaroguy
MJ is finally home!
 
camaroguy's Avatar
 
Drives: 2010 CGM 2SS/RS Camaro M6
Join Date: Jan 2009
Location: Olathe, KS
Posts: 219
Yeah, my dealer is taking care of me.. I talked to the service manager this morning and told him that I dumped the clutch doing a launch and the damn thing snapped. He kept saying he was sorry to hear about it and that they will start on it this afternoon.
camaroguy is offline   Reply With Quote
Old 07-01-2009, 11:27 AM   #23
Rogue Leader
Iatefiberglassinsulation
 
Rogue Leader's Avatar
 
Drives: 2010 Camaro 2SS M6
Join Date: Oct 2008
Location: Long Island
Posts: 3,590
Quote:
Originally Posted by UCF w00t View Post
Stuff like this always happens in any manufacturing process. The only way to test would be to do burnouts and hard launches in the parking lot before they're put on the train. Would you like them to do that? I don't see how customers are getting screwed. They're being taken care of. If GM said "your fault, not covered under warranty" that would be a different situation.
Dude you have a VIN! congrats! Hope you get your car soon!

That said this problem could NEVER be caught in QC unless they had someone go out and launch every car. It sucks but it happens, at least they are stepping up and fixing it imemdiately.
__________________
I'm Brick Tamland. People seem to like me because I am polite and I am rarely late. I like to eat ice cream and I really enjoy a nice pair of slacks. Years later, a doctor will tell me that I have an I.Q. of 48 and am what some people call mentally retarded.

2010 Chevrolet Camaro SS - Daily Driver
2008 Chevy Silverado 2500 HD LT 6.0 - Tow Vehicle
1993 Volkswagen Fox - Race Car (yes seriously)

"Like" my race team on Facebook: http://www.facebook.com/farfrumwinnin
Rogue Leader is offline   Reply With Quote
Old 07-01-2009, 11:32 AM   #24
Adam
You Said Member
 
Drives: 2010 SIM 2LT Auto RS
Join Date: Feb 2009
Location: Why is this required?
Posts: 326
your story made me lol. I mean, I know v8 guys maybe have a different mentality, but pulling into a mall to do a burnout? seriously?
Adam is offline   Reply With Quote
Old 07-01-2009, 11:34 AM   #25
UCF w00t
Geek
 
UCF w00t's Avatar
 
Drives: IOM 2010 Camaro 2SS
Join Date: Oct 2008
Location: Orlando
Posts: 4,456
Quote:
Originally Posted by Rogue Leader View Post
Dude you have a VIN! congrats! Hope you get your car soon!
I should have it tomorrow or Friday. Fingers crossed.
UCF w00t is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
V8 Camaro Performance Upgrades List Milk 1027 Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 85 11-11-2013 12:48 PM
Official Camaro Convertible CONCEPT Press Release Tran Camaro Convertible Forum 12 11-18-2009 07:05 PM
2010 Camaro Pricing for Canada Announced garfin Camaro Price | Ordering | Tracking | Dealers Discussions 503 05-24-2009 04:59 PM
Excitement Builds for 2010 Chevrolet Camaro camaro5 5th Gen Camaro SS LS LT General Discussions 2 11-02-2008 01:54 AM
2010 Chevy Camaro to offer two V6s at launch; Z28 to trump SS? radz28 Camaro ZL1 Forum - ZL1 Specific Topics 51 06-23-2008 12:12 PM


All times are GMT -5. The time now is 04:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.