Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
JDP Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Forced Induction - V8


Reply
 
Thread Tools
Old 03-30-2013, 05:37 PM   #365
stangkilr
 
stangkilr's Avatar
 
Drives: 2010 Camaro SS | 2013 Camaro 1LE
Join Date: Jan 2011
Location: Missouri
Posts: 618
Quote:
Originally Posted by se7en View Post
I just spent almost an hour reading this whole thread. What a build and from your garage mainly from what it looks.....makes it that more cool as can be. I'm amazed with the knowledge and expertise that it took to go into this build. Just curious, but how did you get into doing builds like this yourself?

I also have the GFORCE 9" and couldnt be happier!! You will tear everything up several times before you have any problems out of that rear-end.
Well it all started with my last car (2002 Z28) that became internet famous for how clean/fast it was. I have always been a fan of clean and simple setups and when I switched to a turbo setup I was afraid I would lose that look. I am lucky to have a friend thats very good at fabrication from his garage. He had the same tastes as I do. I put my input on how I want it and he makes it happen. From that point its all me and I put the rest of the puzzle pieces together to make a very fast car I can drive anywhere and take to car shows.
__________________
http://www.camaro5.com/forums/image.php?type=sigpic&userid=37570&dateline=138293  2783
2010 Camaro SS CGM |LY6 6.0L | E85 | x275 88mm turbo/ TH400/ Gforce 9 inch

Youtube "stangkilr99"
stangkilr is offline   Reply With Quote
Old 03-30-2013, 05:38 PM   #366
stangkilr
 
stangkilr's Avatar
 
Drives: 2010 Camaro SS | 2013 Camaro 1LE
Join Date: Jan 2011
Location: Missouri
Posts: 618
Here are the details on my car meet I am having in May. If you missed TX2K13 then come to this.
https://www.facebook.com/events/516802715016956/
__________________
http://www.camaro5.com/forums/image.php?type=sigpic&userid=37570&dateline=138293  2783
2010 Camaro SS CGM |LY6 6.0L | E85 | x275 88mm turbo/ TH400/ Gforce 9 inch

Youtube "stangkilr99"
stangkilr is offline   Reply With Quote
Old 04-05-2013, 09:56 AM   #367
stangkilr
 
stangkilr's Avatar
 
Drives: 2010 Camaro SS | 2013 Camaro 1LE
Join Date: Jan 2011
Location: Missouri
Posts: 618
Thrust bearing in the motor is what failed.
__________________
http://www.camaro5.com/forums/image.php?type=sigpic&userid=37570&dateline=138293  2783
2010 Camaro SS CGM |LY6 6.0L | E85 | x275 88mm turbo/ TH400/ Gforce 9 inch

Youtube "stangkilr99"
stangkilr is offline   Reply With Quote
Old 04-05-2013, 10:10 AM   #368
BlkSlvrdo129
 
Drives: 2008 Silverado
Join Date: Dec 2010
Location: Canada
Posts: 98
Quote:
Originally Posted by stangkilr View Post
Thrust bearing in the motor is what failed.
Couple things come to mind; have you been spooling up against the converter frequently, and do you know what the crank endplay was set at? There's a guy on Tech with a 408 single turbo trans am that's gone through 2 thrust bearings so far.
BlkSlvrdo129 is offline   Reply With Quote
Old 04-05-2013, 10:27 AM   #369
stangkilr
 
stangkilr's Avatar
 
Drives: 2010 Camaro SS | 2013 Camaro 1LE
Join Date: Jan 2011
Location: Missouri
Posts: 618
Quote:
Originally Posted by BlkSlvrdo129 View Post
Couple things come to mind; have you been spooling up against the converter frequently, and do you know what the crank endplay was set at? There's a guy on Tech with a 408 single turbo trans am that's gone through 2 thrust bearings so far.
Eh, this was caused by the transmission missing two thrust washers causing movement in the whole case.
__________________
http://www.camaro5.com/forums/image.php?type=sigpic&userid=37570&dateline=138293  2783
2010 Camaro SS CGM |LY6 6.0L | E85 | x275 88mm turbo/ TH400/ Gforce 9 inch

Youtube "stangkilr99"
stangkilr is offline   Reply With Quote
Old 04-05-2013, 10:31 AM   #370
willhe64

 
willhe64's Avatar
 
Drives: 2012 45th Vert, 2011 4x4, 9sec Vega
Join Date: Mar 2012
Location: Canada
Posts: 2,184
Quote:
Originally Posted by BlkSlvrdo129 View Post
do you know what the crank endplay was set at?

started at 0.008" and ended at 0.400"
__________________
I feel it only fair to warn you, I have a black belt in CAPS LOCK.
willhe64 is offline   Reply With Quote
Old 04-05-2013, 10:50 AM   #371
BlkSlvrdo129
 
Drives: 2008 Silverado
Join Date: Dec 2010
Location: Canada
Posts: 98
Quote:
Originally Posted by stangkilr View Post
Eh, this was caused by the transmission missing two thrust washers causing movement in the whole case.
Ah, missed that part. Pays to read back I suppose!
BlkSlvrdo129 is offline   Reply With Quote
Old 04-05-2013, 10:52 AM   #372
stangkilr
 
stangkilr's Avatar
 
Drives: 2010 Camaro SS | 2013 Camaro 1LE
Join Date: Jan 2011
Location: Missouri
Posts: 618
Quote:
Originally Posted by willhe64 View Post
started at 0.008" and ended at 0.400"
__________________
http://www.camaro5.com/forums/image.php?type=sigpic&userid=37570&dateline=138293  2783
2010 Camaro SS CGM |LY6 6.0L | E85 | x275 88mm turbo/ TH400/ Gforce 9 inch

Youtube "stangkilr99"
stangkilr is offline   Reply With Quote
Old 04-05-2013, 10:56 AM   #373
BlkSlvrdo129
 
Drives: 2008 Silverado
Join Date: Dec 2010
Location: Canada
Posts: 98
How does the crank look?
BlkSlvrdo129 is offline   Reply With Quote
Old 04-17-2013, 10:14 PM   #374
thahemp
Geek
 
thahemp's Avatar
 
Drives: 2012 Black LS3
Join Date: Jan 2012
Location: Derby, KS
Posts: 4,341
Just bringing this back from page 2...

I hope all is well.
__________________
01000111011011110110111101100100001000000110110001 11010101100011011010110010000001110111011010010111 01000110100000100000011101000110100001101001011100 110010000001101111011011100110010100100001

x = ac97968bd3df8f968c8cd3df998a9c94d3df9c8a918bd3df9c 909c94df8c8a9c949a8dd3df92908b979a8ddf998a9c949a8d d3df8b968b8cd1
x = ~x
thahemp is offline   Reply With Quote
Old 04-18-2013, 04:06 PM   #375
stangkilr
 
stangkilr's Avatar
 
Drives: 2010 Camaro SS | 2013 Camaro 1LE
Join Date: Jan 2011
Location: Missouri
Posts: 618
Engine is being fixed now. Needed a new crank and block. I should have it back in a week or so.
__________________
http://www.camaro5.com/forums/image.php?type=sigpic&userid=37570&dateline=138293  2783
2010 Camaro SS CGM |LY6 6.0L | E85 | x275 88mm turbo/ TH400/ Gforce 9 inch

Youtube "stangkilr99"
stangkilr is offline   Reply With Quote
Old 04-18-2013, 05:46 PM   #376
RRTX-SS
 
RRTX-SS's Avatar
 
Drives: 2010 2SS/RS M6
Join Date: Oct 2012
Location: East, Tx
Posts: 241
Glad to hear its gettin fixed up for ya looking forward to seeing it at kc2k
__________________
2010 Camaro 2SS/RS
416 CI M6-LS3 Kenne Bell 3.6, Livernois Dual Fuel Pump Kit w/KB BAP, Futral Motorsports Blower Cam, SW 2"Headers, Zl1 Dual Mode Exhaust, Street Slayer Billet Twin-Disc Clutch,PFADT lowering springs and sway bars, Iforged Classic Wheels, AI Meth Injection, rx dual checkvalve catchcan, Innovators West 8-Rib pulley setup....690RWHP/701RWTQ @ 10 PSI-CALIBRATED BY KARGER @ SNL PERFORMANCE

1995 Camaro Z28 LT1 M6
383 Fully Forged shortblock
RRTX-SS is offline   Reply With Quote
Old 04-21-2013, 12:08 AM   #377
driyac

 
driyac's Avatar
 
Drives: 2012 45th Anniversary 2SS
Join Date: Mar 2012
Location: West Chester Ohio
Posts: 1,847
Quote:
Originally Posted by stangkilr View Post
Engine is being fixed now. Needed a new crank and block. I should have it back in a week or so.
They pay for screwing up so badly?
__________________
driyac is offline   Reply With Quote
Old 04-24-2013, 10:37 PM   #378
Col. Brain
 
Drives: 2012 Ram 1980 Malibu
Join Date: Apr 2013
Location: Otherside of the screen
Posts: 359
Quote:
Originally Posted by stangkilr View Post
Thrust bearing in the motor is what failed.
AES = Always Exploding Shit

Actually they do great work and most cars that pop at the track are some seriously fast cars.

Just hear it at the tracks up here a lot.


Killer car and now you have me looking for that cyber grey
Col. Brain is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:46 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.