Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums -
Grabiak Performance Center
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V6 LFX Engine, Exhaust, and Bolt-Ons

Thread Tools
Old 05-02-2013, 03:52 AM   #1
Drives: 2013 Camaro LS M6
Join Date: Mar 2013
Location: Menomonie, WI
Posts: 59
Running rich after tune?

So I got my initial tune from trifecta and data logged after about 100 miles or so and sent it in right away. Drove it for over a week and noticed a really bad miss and stutter under light accel throughout the power band. Also noticed my exhaust tips are caked with black soot. They were clean for 3500 miles before I installed the tune. Any suggestions?
jbrantner24 is offline   Reply With Quote
Old 05-02-2013, 06:51 AM   #2

etmx183's Avatar
Drives: 2012 Camaro 2LT RS, 04 Turbo Busa
Join Date: Mar 2012
Location: Baltimore, Maryland
Posts: 1,409
Need to determine the misfire first. I would suggest install stock tune and check for diagnostic codes.
CAI intake, RX catch can, Nitrous Outlet Plate system, RX Ported Throttle body, APEX air scoop, SOLO HFCs, JacFab ported manifold and upper intake isolator, Solo cat back Mach X system, 3.91 gears, Weld RT-S, 1 piece DSS driveshaft Stall convertor by:CIRCLE D

TUNING BY:MagnumForce / HP Tuners
13.407@101.72 N/A 11/21/2015
12.03@115.69 nitrous
etmx183 is offline   Reply With Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -5. The time now is 05:50 AM.

Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2015, vBulletin Solutions, Inc.