Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
dave@hennessey
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum


Reply
 
Thread Tools
Old 04-29-2013, 05:43 AM   #15
3rdgen3
10-bolt Destroyer
 
3rdgen3's Avatar
 
Drives: 2012 Camaro 2SS/RS - AGM, LS3/6M
Join Date: Jun 2012
Location: Canukistan
Posts: 740
Quote:
Originally Posted by Airmaster View Post
If I have the stock radio in the LS model is there any way to get music to playback through bluetooth. From what I've read and understand only phone calls can be made, but music can't be played through it.

Sorry if its a stupid question....
Music CAN be played from the phone via Bluetooth.

I do it all the time in my 2012 2SS/RS w/ my Samsung Galaxy Nexus i9250 running AOKP 4.2.2 :P


You need to pair 2x different Bluetooth devices. The 'Phone' will be called 'Your Vehicle' and the Bluetooth Music Player will be called 'GMusicConnect'.

First thing I would do is start from scratch. In the phone, go to Settings - Bluetooth. Delete/remove any and all devices.

Now on the radio press the 'Config' button. Scroll down to 'Phone Settings' and 'List devices'. Remove/delete all of them,

Now go to "Pair device" and "Pair as phone", then go to your phone, do a search for available devices, wait until 'Your Vehicle' shows up and pair with it. You gotta be a bit quick on both the phone and the radio as you have a limited amount of time to complete this properly. Once it's paired it'll ask you to type in a security code. The stereo will display that number for you, just type it in on your phone and make sure you save it and tell it to remember and connect automatically.

Once it's paired successfully and you've set up the phones "name", you should get a prompt on your phone right away that says "This device is requesting access to your contact lists, do you want to allow this?" Make sure you say YES and tell it to remember! That's it, now your PHONE will work properly.

Now, plug a USB stick or something into the USB port and once it's done Indexing, press the 'Menu' button and scroll down to "Bluetooth Audio" and press select. Choose 'Connect to a new device' and then go to SETTINGS - BLUETOOTH on your phone and wait for GMusicConnect to pop up. Select it, type in the pairing code it gives you and tell the phone to automatically save and connect.

That's it. Now in order to play the music via bluetooth, thats kind of annoying to do on our stereo. All you gotta do is press the menu button again on the Stereo, highlight bluetooth audio and select it. It should then connect to your phone (make sure bluetooth is on on the phone or else its useless). The stereo should now only be displaying the Bluetooth name of your phone.

Now go into whatever APP you use to play music and press play. It should automatically come out of your stereo now.


Hopefully my instructions make sense, i typed that all off the top of my head from memory
__________________

2012 Camaro 2SS/RS - LS3/TR6060: BTR Stage 4 Cam, 2" Long Tubes, TSP 3" Catback, SLP 25% UDP, CAI Intake, ADM Air Scoop + Washer Relocation, Arun Tuned - 475rwhp 443rwtq
3rdgen3 is offline   Reply With Quote
Old 04-29-2013, 08:07 AM   #16
yellowrs
Account Suspended
 
Drives: 2010 SS 426 V8 M/T
Join Date: Aug 2012
Location: Scottsdale AZ
Posts: 1,376
Quote:
Originally Posted by 3rdgen3 View Post
Music CAN be played from the phone via Bluetooth.

I do it all the time in my 2012 2SS/RS w/ my Samsung Galaxy Nexus i9250 running AOKP 4.2.2 :P


You need to pair 2x different Bluetooth devices. The 'Phone' will be called 'Your Vehicle' and the Bluetooth Music Player will be called 'GMusicConnect'.

First thing I would do is start from scratch. In the phone, go to Settings - Bluetooth. Delete/remove any and all devices.

Now on the radio press the 'Config' button. Scroll down to 'Phone Settings' and 'List devices'. Remove/delete all of them,

Now go to "Pair device" and "Pair as phone", then go to your phone, do a search for available devices, wait until 'Your Vehicle' shows up and pair with it. You gotta be a bit quick on both the phone and the radio as you have a limited amount of time to complete this properly. Once it's paired it'll ask you to type in a security code. The stereo will display that number for you, just type it in on your phone and make sure you save it and tell it to remember and connect automatically.

Once it's paired successfully and you've set up the phones "name", you should get a prompt on your phone right away that says "This device is requesting access to your contact lists, do you want to allow this?" Make sure you say YES and tell it to remember! That's it, now your PHONE will work properly.

Now, plug a USB stick or something into the USB port and once it's done Indexing, press the 'Menu' button and scroll down to "Bluetooth Audio" and press select. Choose 'Connect to a new device' and then go to SETTINGS - BLUETOOTH on your phone and wait for GMusicConnect to pop up. Select it, type in the pairing code it gives you and tell the phone to automatically save and connect.

That's it. Now in order to play the music via bluetooth, thats kind of annoying to do on our stereo. All you gotta do is press the menu button again on the Stereo, highlight bluetooth audio and select it. It should then connect to your phone (make sure bluetooth is on on the phone or else its useless). The stereo should now only be displaying the Bluetooth name of your phone.

Now go into whatever APP you use to play music and press play. It should automatically come out of your stereo now.


Hopefully my instructions make sense, i typed that all off the top of my head from memory

That how I did it!
yellowrs is offline   Reply With Quote
Old 04-29-2013, 04:49 PM   #17
nickswe
A Swede lost in Texas
 
Drives: Camaro ZL1 2014 Black M6
Join Date: Apr 2013
Location: Dallas, TX
Posts: 489
So I've tried to clear everything out both in the car and on the phone. Still the same (as in not being able to make calls or answer calls).

I will try with a different phone and also ask around on Android forums to see if they know of the problem. Maybe it is a driver issue with the phone.
nickswe is offline   Reply With Quote
Old 04-29-2013, 06:08 PM   #18
yellowrs
Account Suspended
 
Drives: 2010 SS 426 V8 M/T
Join Date: Aug 2012
Location: Scottsdale AZ
Posts: 1,376
Quote:
Originally Posted by nickswe View Post
So I've tried to clear everything out both in the car and on the phone. Still the same (as in not being able to make calls or answer calls).

I will try with a different phone and also ask around on Android forums to see if they know of the problem. Maybe it is a driver issue with the phone.
Maybe this will help?



yellowrs is offline   Reply With Quote
Old 05-01-2013, 05:53 PM   #19
GearHeadPeter
US Navy Vet
 
GearHeadPeter's Avatar
 
Drives: 2011 2LT/RS, 65 Mustang GT Fastback
Join Date: Oct 2009
Location: Gilbert, AZ
Posts: 1,568
Quote:
Originally Posted by nickswe View Post
So I've tried to clear everything out both in the car and on the phone. Still the same (as in not being able to make calls or answer calls).

I will try with a different phone and also ask around on Android forums to see if they know of the problem. Maybe it is a driver issue with the phone.
Did you phone get the new Jelly bean OS? If that's the case the bluetooth profile on the phone is newer than what is on your car's OnStar module. GM Infotainment Center knows about the issue with Android phones, Galaxy and the new IPhone 5s, but doesn't have an ETA of the fix.

Read this and see if this is what is happening to you: http://www.camaro5.com/forums/showthread.php?t=289991
__________________
2011 - 2LT/RS - RY, A6, Gray Interior - Team LLT:
3rd Camaro on this forum to have a Mylink installed. Installation by GEN5DIY, Heritage Grill, Lloyds Premium Ebony Camaro RS floor mats, Empire Billet Camaro Black sill plates, AAC: LED footwell & interior lighting, Rear Courtesy Lights, LED side markers/turn signals, Plasma P13W DRl bulbs, Formula 1 Pinnacle Series tint, Roto-Fab Yellow CAI & Fuse cover, Technostalgia Afterburner LED taillights, EmblemPros custom V6 hydrocoated carbon fiber/RY engine cover, Pfadt Sport sway bars, Ofer's Backup Camera, and full Brembo brake conversion.
GearHeadPeter is offline   Reply With Quote
Old 05-01-2013, 10:58 PM   #20
nickswe
A Swede lost in Texas
 
Drives: Camaro ZL1 2014 Black M6
Join Date: Apr 2013
Location: Dallas, TX
Posts: 489
Quote:
Originally Posted by GearHeadPeter View Post
Did you phone get the new Jelly bean OS? If that's the case the bluetooth profile on the phone is newer than what is on your car's OnStar module. GM Infotainment Center knows about the issue with Android phones, Galaxy and the new IPhone 5s, but doesn't have an ETA of the fix.

Read this and see if this is what is happening to you: http://www.camaro5.com/forums/showthread.php?t=289991
Hi,
Yeah I have the latest and greatest... The Android Jelly Bean V4.2.2.

Thank you it appears that person's got the same problem as I.
nickswe is offline   Reply With Quote
Old 05-03-2013, 05:14 PM   #21
GearHeadPeter
US Navy Vet
 
GearHeadPeter's Avatar
 
Drives: 2011 2LT/RS, 65 Mustang GT Fastback
Join Date: Oct 2009
Location: Gilbert, AZ
Posts: 1,568
Quote:
Originally Posted by nickswe View Post
Hi,
Yeah I have the latest and greatest... The Android Jelly Bean V4.2.2.

Thank you it appears that person's got the same problem as I.
That person is me.

Bluetooth works just fine if I call anyone not on Verizon, and even Verizon can't help with that. What's funny is that if you use the steering controls and initiate a call using voice commands Bluetooth is messed up. However, if you dial it from the phone then everything works through Bluetooth in the car. Same thing if I use my call history or phone book.
__________________
2011 - 2LT/RS - RY, A6, Gray Interior - Team LLT:
3rd Camaro on this forum to have a Mylink installed. Installation by GEN5DIY, Heritage Grill, Lloyds Premium Ebony Camaro RS floor mats, Empire Billet Camaro Black sill plates, AAC: LED footwell & interior lighting, Rear Courtesy Lights, LED side markers/turn signals, Plasma P13W DRl bulbs, Formula 1 Pinnacle Series tint, Roto-Fab Yellow CAI & Fuse cover, Technostalgia Afterburner LED taillights, EmblemPros custom V6 hydrocoated carbon fiber/RY engine cover, Pfadt Sport sway bars, Ofer's Backup Camera, and full Brembo brake conversion.
GearHeadPeter is offline   Reply With Quote
Old 05-05-2013, 11:03 PM   #22
Silver-SS
 
Drives: 2012 2SS RS
Join Date: May 2012
Location: Orlando
Posts: 231
Just to make this worse for you to track down, I have a galaxy nexus on 4.2.2 as well and have no problem with phone or aux bluetooth connections. I usually use call list to make calls though. I can never remember to use the correct voice name for my contacts.
Silver-SS is offline   Reply With Quote
Old 05-06-2013, 12:41 AM   #23
nickswe
A Swede lost in Texas
 
Drives: Camaro ZL1 2014 Black M6
Join Date: Apr 2013
Location: Dallas, TX
Posts: 489
Quote:
Originally Posted by Silver-SS View Post
Just to make this worse for you to track down, I have a galaxy nexus on 4.2.2 as well and have no problem with phone or aux bluetooth connections. I usually use call list to make calls though. I can never remember to use the correct voice name for my contacts.
I see... Can you please help me out with some things then...

1. What is the year model of your car? What radio do you have?
2. Can you get song titles on your radio display/HUD from the phone?
3. Can you take a screenshot of your phone on these 2 screens and attach them here:

a. About phone
b. Bluetooth main screen
c. Settings for your Camaro bluetooth pair

As you can see, I only have the profile "Phone audio" available for my Camaro bluetooth. I think that is the problem.
Attached Images
   
__________________
Former owner of a 2012 Camaro SS 45th Anniversary Edition.

Currently driving a 2014 Camaro ZL1 Coupe.
nickswe is offline   Reply With Quote
Old 05-06-2013, 01:16 AM   #24
Mvp_Me
I Use Three Pedals
 
Mvp_Me's Avatar
 
Drives: 2011 VR M6
Join Date: Apr 2013
Location: West Palm Beach, FL
Posts: 776
i just bought a 2011 and my phone works fine via blue tooth but i cant get my music to play via blue tooth, only through the aux cord. honestly at times i wish it worked vice versa.
__________________
Mvp_Me is offline   Reply With Quote
Old 05-06-2013, 01:36 AM   #25
nickswe
A Swede lost in Texas
 
Drives: Camaro ZL1 2014 Black M6
Join Date: Apr 2013
Location: Dallas, TX
Posts: 489
Quote:
Originally Posted by Mvp_Me View Post
i just bought a 2011 and my phone works fine via blue tooth but i cant get my music to play via blue tooth, only through the aux cord. honestly at times i wish it worked vice versa.
You can find info on this forum on that you need to do a second pairing for music to work... Basically you go to AUX mode on your radio, then press the Options button (enter button) and choose Bluetooth, and then pair your phone that way.

Please continue with this problem in another thread as I wish to keep focus on the PHONE issues with Android 4.2.2. Thanks for understanding and best of luck!
__________________
Former owner of a 2012 Camaro SS 45th Anniversary Edition.

Currently driving a 2014 Camaro ZL1 Coupe.
nickswe is offline   Reply With Quote
Old 05-06-2013, 07:55 AM   #26
Silver-SS
 
Drives: 2012 2SS RS
Join Date: May 2012
Location: Orlando
Posts: 231
Its a 2012 2ss rs with BA sound system. I'll have to check about the song names. I believe so with some programs, because I was upset it doesn't with spotify. Hope this helps.
Attached Images
    
Silver-SS is offline   Reply With Quote
Old 05-06-2013, 08:22 AM   #27
GearHeadPeter
US Navy Vet
 
GearHeadPeter's Avatar
 
Drives: 2011 2LT/RS, 65 Mustang GT Fastback
Join Date: Oct 2009
Location: Gilbert, AZ
Posts: 1,568
Quote:
Originally Posted by Silver-SS View Post
Just to make this worse for you to track down, I have a galaxy nexus on 4.2.2 as well and have no problem with phone or aux bluetooth connections. I usually use call list to make calls though. I can never remember to use the correct voice name for my contacts.
If you look I bet your contacts are stored in Gmail, aren't they? When I switched mine over to Gmail then my phone book and call history appeared on the radio.
__________________
2011 - 2LT/RS - RY, A6, Gray Interior - Team LLT:
3rd Camaro on this forum to have a Mylink installed. Installation by GEN5DIY, Heritage Grill, Lloyds Premium Ebony Camaro RS floor mats, Empire Billet Camaro Black sill plates, AAC: LED footwell & interior lighting, Rear Courtesy Lights, LED side markers/turn signals, Plasma P13W DRl bulbs, Formula 1 Pinnacle Series tint, Roto-Fab Yellow CAI & Fuse cover, Technostalgia Afterburner LED taillights, EmblemPros custom V6 hydrocoated carbon fiber/RY engine cover, Pfadt Sport sway bars, Ofer's Backup Camera, and full Brembo brake conversion.
GearHeadPeter is offline   Reply With Quote
Old 05-06-2013, 08:52 AM   #28
Silver-SS
 
Drives: 2012 2SS RS
Join Date: May 2012
Location: Orlando
Posts: 231
Oh BTW the song title and artist don't show up with Bluetooth with anything, just USB does.
Not sure about contacts saved to gmail.
Silver-SS is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:04 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.