Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
RDP Motorsport
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 05-03-2013, 06:51 PM   #1
1MP3RIALCAMARO
 
Drives: 2010 Imperial Blue Camaro 2SS
Join Date: Apr 2013
Location: Titletown
Posts: 20
LOSS OF POWER

Went to pass someone on the highway, down shifted to third and hit the gas.. instant loss of power for about a second or so and then it was like the car came to life... anybody with this issue out there? 2010 2SS with 13K miles. only modification is magnaflow axle back exhaust. nothing else.
1MP3RIALCAMARO is offline   Reply With Quote
Old 05-03-2013, 07:24 PM   #2
JimE

 
JimE's Avatar
 
Drives: 2013 2SS/RS/1LE
Join Date: Apr 2010
Location: St Louis, MO
Posts: 2,156
Hesitation can be caused by any number of things such as bad gas or actual parts issues. It might be time to run some fuel injector cleaner and/or gas treatment through it. You can also have it checked to see if it's throwing any codes.
__________________
Perm-a-grin in place.....
JimE is offline   Reply With Quote
Old 05-03-2013, 07:26 PM   #3
1MP3RIALCAMARO
 
Drives: 2010 Imperial Blue Camaro 2SS
Join Date: Apr 2013
Location: Titletown
Posts: 20
Well where I live you either have to put in 93 with up to 10% ethanol or 91 with no ethanol? Still gas treatment or fuel injector cleaner?
1MP3RIALCAMARO is offline   Reply With Quote
Old 05-03-2013, 07:48 PM   #4
brkntires
Bob
 
brkntires's Avatar
 
Drives: 2012 2SS Synergy Edition 6M
Join Date: Jul 2011
Location: Aloha OR
Posts: 57
Mine has does that when the traction control takes over.

Sent from my Note2 using Tapatalk
__________________
Bob

2012 Victory Red 2SS Synergy Edition M6
brkntires is offline   Reply With Quote
Old 05-03-2013, 07:58 PM   #5
GraySS2011
 
GraySS2011's Avatar
 
Drives: 2011 Cyber Gray 2SS 6 speed
Join Date: Jan 2012
Location: Chelmsford MA
Posts: 349
I felt that once when I hit the rev limiter.
__________________
2011 2SS RSS , MN6, CGM
http://www.angelfire.com/hi/nicecorvette <----- My Cars and Trucks


GraySS2011 is offline   Reply With Quote
Old 05-04-2013, 02:20 AM   #6
1MP3RIALCAMARO
 
Drives: 2010 Imperial Blue Camaro 2SS
Join Date: Apr 2013
Location: Titletown
Posts: 20
It didnt hit rev limiter but I guess I could have possibly lost traction. I just wouldnt think a car with this amount of miles would need injector cleaner or anything.
1MP3RIALCAMARO is offline   Reply With Quote
Old 05-04-2013, 02:25 AM   #7
45thCAMARO 2SS/RS
xquest91x
 
45thCAMARO 2SS/RS's Avatar
 
Drives: 2012 45th Anniversary 2SS/RS
Join Date: Mar 2013
Location: Yuma, AZ
Posts: 348
I know what u mean, I've done that before as well and we think that if we down shift we will get TQ kicking in n just fly away but I get a lil hesitation but it's true it's the traction control taking over but if you do it without traction control it won't do it
45thCAMARO 2SS/RS is offline   Reply With Quote
Old 05-04-2013, 02:32 AM   #8
PalmerGA


 
PalmerGA's Avatar
 
Drives: 2013 SIM 1SS/RS L99
Join Date: May 2012
Location: Southwest GA
Posts: 5,492
Quote:
Originally Posted by 45thCAMARO 2SS/RS View Post
I know what u mean, I've done that before as well and we think that if we down shift we will get TQ kicking in n just fly away but I get a lil hesitation but it's true it's the traction control taking over but if you do it without traction control it won't do it
This is probably it.
__________________
2013 1SS/RS Coupe L99
CAI Air Intake w/ Apex Scoop
VMAX CNC Ported Throttle Body
Solo Axle-Back Exhaust w/ J-pipes
RX Catch Can
Husky Splash Guards
Heritage Grille
Emblem Pros Retro SS Badges
Emblem Pros Custom Retro SS Kickplates
Emblem Pros Under-hood Bowtie
PalmerGA is online now   Reply With Quote
Old 05-04-2013, 03:12 AM   #9
Da Mammer
 
Drives: 2010 camaro SS LSXFoFiddyFo
Join Date: Nov 2012
Location: Pennsyltucky
Posts: 168
+1 traction control/bcm did it. It can cut back your fuel or throttle position and really screw the pooch if you downshift and hit the gas too quick. It calculates the torque and corrects if the "calculated torque" is too high. Quick check try this maneuver again with t/c off if no issue then you know what to do next time. If it falls on its face like Wile E Coyote, then you got a problem.
__________________
LSXTC
Da Mammer is offline   Reply With Quote
Old 05-04-2013, 04:04 AM   #10
2012-1822


 
2012-1822's Avatar
 
Drives: Black ZL1
Join Date: Apr 2013
Location: City of Champions, Alabama
Posts: 3,734
traction control, ZL1 does it from time to time, in the rain for sure, you know like I try and play a little and the car says no, or cornering hard sometimes and wanting to drift a little, cars says no. But yeah, when TC kicks in, it feels like it's bogging and the first few times I was like "why am I losing power."
__________________
Check out Alabama Camaros, for Camaro enthusiasts all around Alabama https://www.facebook.com/groups/1739...group_activity
2012-1822 is offline   Reply With Quote
Old 05-05-2013, 03:03 AM   #11
Chat01
 
Drives: 2013 2SS/RS L99
Join Date: Apr 2013
Location: Pacific NW
Posts: 66
Quote:
Originally Posted by 1MP3RIALCAMARO View Post
Went to pass someone on the highway, down shifted to third and hit the gas.. instant loss of power for about a second or so and then it was like the car came to life... anybody with this issue out there? 2010 2SS with 13K miles. only modification is magnaflow axle back exhaust. nothing else.
Yesterday was the real first time I was able to open my new 2SS up in the week I've had it now. I was doing about 50mph on a straight away and punched the accelerator (mines an automatic). It instantly felt like the engine cut out then came back the same as you described. It freaked me out so I tried it again with the same event, however when it did the same thing I noticed "traction control" flashed on my HUD for a brief second. Safety first I guess
Chat01 is offline   Reply With Quote
Old 05-05-2013, 01:03 PM   #12
rontammy0
Dr feelgood
 
rontammy0's Avatar
 
Drives: 2011 SS/ RS INFERNO ORANGE L99
Join Date: Dec 2012
Location: ontario
Posts: 1,465
Quote:
Originally Posted by Da Mammer View Post
+1 traction control/bcm did it. It can cut back your fuel or throttle position and really screw the pooch if you downshift and hit the gas too quick. It calculates the torque and corrects if the "calculated torque" is too high. Quick check try this maneuver again with t/c off if no issue then you know what to do next time. If it falls on its face like Wile E Coyote, then you got a problem.
ha ha screw the pooch..i have to remember that one
__________________


K@N CAI....Vmax ported throttlebody...JBA shorty headers...SOLO hi flow cats....JBA Powercables...Magnaflow competition exhaust.
rontammy0 is offline   Reply With Quote
Old 05-05-2013, 01:38 PM   #13
eymang
 
eymang's Avatar
 
Drives: 2011 2SS/RS & 1991 Vert
Join Date: Jul 2012
Location: Texas
Posts: 384
Quote:
Originally Posted by 1MP3RIALCAMARO View Post
Went to pass someone on the highway, down shifted to third and hit the gas.. instant loss of power for about a second or so and then it was like the car came to life... anybody with this issue out there? 2010 2SS with 13K miles. only modification is magnaflow axle back exhaust. nothing else.
Have you checked your MAF numbers or done the upgrade?
eymang is offline   Reply With Quote
Old 05-05-2013, 01:40 PM   #14
oldfriend


 
oldfriend's Avatar
 
Drives: 2010 SS BLK IO interior
Join Date: Dec 2009
Location: 32*38' 49N. 16*55'42W
Posts: 6,817
Quote:
Originally Posted by 1MP3RIALCAMARO View Post
Went to pass someone on the highway, down shifted to third and hit the gas.. instant loss of power for about a second or so and then it was like the car came to life... anybody with this issue out there? 2010 2SS with 13K miles. only modification is magnaflow axle back exhaust. nothing else.
Like the two brothers would have said ,,,, how do you spell your name , Y or I , then , is your car blue ?
Model and year
V6/v8 ?
Stick/ aut.?
Tires sizes ?.
Was the parking brake on ?
__________________
2010 BLK 2SS RS IO
oldfriend is offline   Reply With Quote
Old 05-05-2013, 01:43 PM   #15
two_wheel_mayhem
Would rather be riding
 
two_wheel_mayhem's Avatar
 
Drives: 2012 SS LS3
Join Date: Jul 2009
Location: Indiana
Posts: 1,677
I believe it is the traction control too. It always cuts the throttle for longer than it needs to.
__________________
Nice vehicles with mods.
two_wheel_mayhem is offline   Reply With Quote
Old 05-06-2013, 08:37 PM   #16
ccbrian
 
ccbrian's Avatar
 
Drives: Rally Yellow 2011 SS Camaro
Join Date: May 2013
Location: United States
Posts: 2
Perhaps do you have a custom air intake recently installed, if so sometimes it can feel a lot like you've lost power. Or perhaps your air intake has gotten pretty dirty and you should clean it.
ccbrian is offline   Reply With Quote
Old 07-08-2013, 09:29 AM   #17
Matster

 
Matster's Avatar
 
Drives: 2010 2SS/RS IOM/IOM #3625
Join Date: Jun 2008
Location: Greater Toronto Area
Posts: 1,883
Most likely the traction control. Had mine into the shop a few weeks back as I was concerned it might be a fuel issue, as in not getting enough. Most of the time on the street I leave all the nanny stuff turned on so when the guy sitting on my shoulder with the horns says "do it" the car has the halo and says no.

Now this isn't a subtle loss of power, this is a bang your head between the head rest and the steering wheel thing, violent. Usually when it starts making peak torque (3750rpm/737 ft lbs of torque) and the wheels start spinning.

I took it to my tuner/shop and we had already somewhat come to the conclusion that the issue was the TC. He took it out and data logged it and it did the same thing to him (thank God, not a driver error issue). He then tried it with the TC off and had no issues with power loss.
__________________
666 EVIL RWHP BUILT AND TUNED BY SHIFTED PERCEPTIONS INC.(SPi)

416 Forged Stroker, E-Force Supercharger, Blower Cam, Rotofab CAI, Stainless Works 2" LT Headers and 3" Exhaust, LPE ZR1 Twin Disc Clutch, DSS 1400 HP Axles, Pfadt Performance Kit Stage 3.
Matster is offline   Reply With Quote
Old 07-08-2013, 01:46 PM   #18
tk3c-pyce
 
Drives: 2010 Camaro SS
Join Date: Oct 2010
Location: Bulgaria
Posts: 20
If you didn't get any error msgs like "Engine power reduced", then it would be the traction control. If you have a DTC light, then it's another story.
tk3c-pyce is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:00 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.