Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Emblempros
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Specific Models / Packages > Camaro 1LE Forum


Reply
 
Thread Tools
Old 05-08-2013, 11:13 PM   #15
HighMtnSS
 
HighMtnSS's Avatar
 
Drives: '13 AGM 2SS/RS 1LE, 1 of 139
Join Date: Apr 2011
Location: Broomfield, Colorado
Posts: 142
300 miles and I still have those lovely smells!
HighMtnSS is offline   Reply With Quote
Old 05-09-2013, 12:33 AM   #16
AmericanMuscleCars
Teenage Dream Camaro
 
AmericanMuscleCars's Avatar
 
Drives: A Visually Stunning Camaro
Join Date: Feb 2013
Location: Florida
Posts: 1,722
Must be playin' that funky music... PLAY THAT FUNKY MUSIC!!!!
AmericanMuscleCars is offline   Reply With Quote
Old 05-09-2013, 01:56 AM   #17
kansjfr
 
Drives: 2013 2SS 1LE
Join Date: Apr 2013
Location: Coffeyville, KS
Posts: 131
Quote:
Originally Posted by AmericanMuscleCars View Post
Must be playin' that funky music... PLAY THAT FUNKY MUSIC!!!!
...white boy
kansjfr is offline   Reply With Quote
Old 05-10-2013, 01:14 AM   #18
1LeSS
 
1LeSS's Avatar
 
Drives: 2013 2SS/RS VR 1LE
Join Date: Jan 2013
Location: Prince George, B.C.
Posts: 449
Got the car back from the dealer today. New clutch stuff to the flywheel. It was a pressure plate failure that caused the problem.
All covered of course.
Just a good idea that if something doesnt seem right, just have the dealer log it. Then if something goes wrong theres no problem.
I immediately hit the hwy for a summer cruise when i got the car back. Wow, its a different car now.
1LeSS is offline   Reply With Quote
Old 12-15-2013, 08:16 PM   #19
Kleeeb

 
Kleeeb's Avatar
 
Drives: 2014 Red Hot 1LT/RS
Join Date: May 2013
Location: College Station, TX
Posts: 1,806
Send a message via MSN to Kleeeb Send a message via Skype™ to Kleeeb
My 2014 has 1041 miles on it and I still smell a burning smell randomly while driving. :P
__________________
Kleeeb is offline   Reply With Quote
Old 12-15-2013, 11:32 PM   #20
Ir0nM4n


 
Ir0nM4n's Avatar
 
Drives: 14 1LE
Join Date: May 2011
Location: Washington
Posts: 2,565
Smell = my inability to shift correctly all the time... Saving money for the future.
__________________
Ir0nM4n is offline   Reply With Quote
Old 12-16-2013, 02:15 PM   #21
Boydr12
 
Drives: 2012 Camaro RS, 2013 Camaro 2SS 1LE
Join Date: Jun 2013
Location: Henderson, NC
Posts: 153
Quote:
Originally Posted by davidcroft View Post
Get some ARH long tubes w/o cats and these other smells will be dwarfed! When I sit at stop lights and driving around with the windows down, my clothes smell like I've been sitting on top of a boat motor all day!
No thanks I'd rather not break the law as well as ruin the environment
Boydr12 is offline   Reply With Quote
Old 12-16-2013, 03:39 PM   #22
tmcclint
 
tmcclint's Avatar
 
Drives: 2014 AGM 2SS/RS 1LE
Join Date: Aug 2013
Location: Colorado Springs, CO
Posts: 228
Mine has that funny smell as well. I assumed it was the clutch too. I usually only smell it when it's been warmed up and I pull it in the garage. I just wish I could get some miles on it but the roads are all covered in gravel now and I'd rather not sand blast the new paint. Guess I'll wait until spring.
__________________
2014 2SS RS 1LE
tmcclint is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:16 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.