Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Anthony @ LG Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Camaro ZL1 Forum - ZL1 Specific Topics


Reply
 
Thread Tools
Old 05-09-2013, 11:21 PM   #15
jashobbsie
Davenport Stage 5+
 
jashobbsie's Avatar
 
Drives: Camaro ZL1 & C7 Corvette 3LT Z51
Join Date: May 2012
Location: Alberta, Canada
Posts: 471
thats just the newness burning off..thats what i call it...my car smells like this after every run out when I get back to my garage....Driving it like you stole it ...show the car who's boss...lol
jashobbsie is offline   Reply With Quote
Old 05-10-2013, 07:21 AM   #16
Rizzo
 
Drives: 2012 Camaro ZL-1 SIM
Join Date: Sep 2008
Location: San Antonio, TX
Posts: 454
Quote:
Originally Posted by djm96z28 View Post
The new clutches on these cars seem to have the burning smell for about 1000 miles or so. Mine did when new and at about 800 miles it stopped. I haven't smelled it since.
I agree with this statement. Mine was like that at first, but it disappeared the more I drove it.
__________________
=================================================
Rizzo is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:23 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.