Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
TireRack
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V6 LLT Engine, Exhaust, and Bolt-Ons


Reply
 
Thread Tools
Old 05-16-2013, 09:19 PM   #43
SPARTAN sui
PC Technician
 
SPARTAN sui's Avatar
 
Drives: 2016 Hyper Blue 2SS
Join Date: May 2012
Location: North Dakota
Posts: 1,342
Typical issue when your salesperson isn't obsessed with the Camaro like we are lol
__________________
SPARTAN sui is offline   Reply With Quote
Old 05-16-2013, 09:24 PM   #44
KMPrenger


 
KMPrenger's Avatar
 
Drives: 16 SS Camaro, 06 Colorado
Join Date: May 2009
Location: Jefferson City, Missouri
Posts: 12,032
Quote:
Originally Posted by GretchenGotGrowl View Post
Take off the engine cover first.

Sent from my SPH-D710 using Tapatalk 2
No need for that.

Coolant cap will be up front in the middle on the LFX.
__________________
2016 Camaro 1SS - 8-speed - NPP - Black bowties
2010 Camaro 1LT V6 (Sold. I will miss her!)
KMPrenger is offline   Reply With Quote
Old 05-16-2013, 09:25 PM   #45
KMPrenger


 
KMPrenger's Avatar
 
Drives: 16 SS Camaro, 06 Colorado
Join Date: May 2009
Location: Jefferson City, Missouri
Posts: 12,032
Quote:
Originally Posted by tonymac View Post
...
Sorry for the hijack..
No worries!
__________________
2016 Camaro 1SS - 8-speed - NPP - Black bowties
2010 Camaro 1LT V6 (Sold. I will miss her!)
KMPrenger is offline   Reply With Quote
Old 05-16-2013, 09:32 PM   #46
GretchenGotGrowl


 
GretchenGotGrowl's Avatar
 
Drives: 11 F150 EB/13 Sonic RS/15 Z06
Join Date: Sep 2010
Location: Little Rock, AR
Posts: 7,128
Quote:
Originally Posted by KMPrenger View Post
No need for that.

Coolant cap will be up front in the middle on the LFX.
Doh, forgot about that.

Sent from my SPH-D710 using Tapatalk 2
__________________
New Ride -- 2015 Z06 2LZ (stock) -- Journal
Old Ride -- 2012 Camaro 2LT/RS (647 RWHP & 726 RWTQ) -- Build Thread
GretchenGotGrowl is offline   Reply With Quote
Old 05-16-2013, 09:50 PM   #47
CamaroC-17
Formerly Camaroc5
 
CamaroC-17's Avatar
 
Drives: 2010 Camaro LT/RS M6
Join Date: May 2010
Location: USA
Posts: 1,657
Didn't get the car back yet. It needs a new windshield. They knew that entire 3 weeks it has been there. Even said the body shop tried to come do it a few times but the car was up in the air. Dealer called yesterday and said its ready to go. I asked if the windshield was done and said oh crap, it will be ready tomorrow then. Well I took a trip to the base to get some work done (I live two hours from base and dealer) and to be close by to get the car. Whole day went by and I called and he said the windshield was delivered to the wrong dealer but assured it would be ready tomorrow....so I get to drive all the way back there tomorrow...I bet they forget to fix my radiator fans...after they changed the timing chains the high mode stopped working and I have had to constantly remind them and every time the service tech acts as if its the first time I am mentioning it. I just want everything taken care of so I don't have to come back. Since owning the car it has had about 70 days of shop time..40 within the first 6 months.

Sent from my DROID RAZR HD using Tapatalk 2
CamaroC-17 is offline   Reply With Quote
Old 05-17-2013, 05:56 AM   #48
Blade


 
Blade's Avatar
 
Drives: 2012 Camaro 2SS SIM RS
Join Date: Dec 2009
Location: Charlotte
Posts: 4,623
Send a message via AIM to Blade
^ Thats nuts....I am assuming you being in the service have limited time and distance to go looking for a different service shop to avoid repeated issues.
__________________
Blade is offline   Reply With Quote
Old 05-17-2013, 08:57 AM   #49
insidethreat07


 
insidethreat07's Avatar
 
Drives: 2001 Camaro 3.8
Join Date: Jul 2010
Location: Continental Ohio
Posts: 11,011
Quote:
Originally Posted by CamaroC-17 View Post
Didn't get the car back yet. It needs a new windshield. They knew that entire 3 weeks it has been there. Even said the body shop tried to come do it a few times but the car was up in the air. Dealer called yesterday and said its ready to go. I asked if the windshield was done and said oh crap, it will be ready tomorrow then. Well I took a trip to the base to get some work done (I live two hours from base and dealer) and to be close by to get the car. Whole day went by and I called and he said the windshield was delivered to the wrong dealer but assured it would be ready tomorrow....so I get to drive all the way back there tomorrow...I bet they forget to fix my radiator fans...after they changed the timing chains the high mode stopped working and I have had to constantly remind them and every time the service tech acts as if its the first time I am mentioning it. I just want everything taken care of so I don't have to come back. Since owning the car it has had about 70 days of shop time..40 within the first 6 months.

Sent from my DROID RAZR HD using Tapatalk 2
all bullshit aside, as soon as you get your car back Id never go to that dealership again. Thank god the dealership in town isn't like that
__________________
2001 Camaro 3.8 V6
Berger Panel, Cardinal Red Camaro Rear Insert, 10 Spoke SS Wheels, Bowtie Center Caps, BMR Shock Tower Brace, Air Silencer Delete, SLP Lid, K&N Air Filter, Whistler/BLS Headlights, Eaton Limited Slip, UMI Rear LCAs PHB & SFCs, Nitto 555s/Nitto 555R, Flowmaster Axle Back Exhaust, Pacesetter Mid-Tube Headers & Y-Pipe, 3'' Exhaust, SS Front & Rear Sway Bars, !EGR, !Cat, Poly Bump Stops, Custom Ash Tray Switches, SJM Line Lock Kit, SLP Fan Switch



insidethreat07 is offline   Reply With Quote
Old 05-17-2013, 10:16 AM   #50
911medic

 
911medic's Avatar
 
Drives: 2012 SIM 2LT/1970 Camaro
Join Date: Nov 2012
Location: Near Minneapolis, MN
Posts: 1,577
Quote:
Originally Posted by CamaroC-17 View Post
Since owning the car it has had about 70 days of shop time..40 within the first 6 months.
Quote:
Originally Posted by insidethreat07 View Post
all bullshit aside, as soon as you get your car back Id never go to that dealership again. Thank god the dealership in town isn't like that
I'd be trading it in on something that isn't a mechanical disaster. Good luck, OP.
__________________
All bleeding stops eventually -- 2012 2LT Auto w/sunroof -- My journal thread
Roto-Fab Intake & W/W Relocate Kit -- ADM Race Scoop -- Dynomax VT Axle-Back Exhaust -- Vitesse Throttle Controller
RX Catch Can -- Drake Bowtie Delete -- JacFab Radio Face Cover -- LED Fog Lights -- LED Dome/Trunk/Plate Lights -- Gen5DIY Dash ABL -- Diode Dynamics Cupholder Lighting
Wishlist: ACS T5 Splitter -- Hood Vent Mod -- Footwell/Door Pull/Homelink Button Lighting
911medic is offline   Reply With Quote
Old 05-17-2013, 10:56 AM   #51
CamaroC-17
Formerly Camaroc5
 
CamaroC-17's Avatar
 
Drives: 2010 Camaro LT/RS M6
Join Date: May 2010
Location: USA
Posts: 1,657
Don't get me wrong. The dealership has always been great. Never questioned warranty, always gave me a brand new loaner even when I was too young for a dealer car they would pay for a rental. Treat me very well. They just kind of dropped the ball the last few days about the fans and windshield. Which they are a huge dealership with a lot going on. They only have like 5 service guys that organize it all.

Sent from my DROID RAZR HD using Tapatalk 2
CamaroC-17 is offline   Reply With Quote
Old 05-17-2013, 10:58 AM   #52
CamaroC-17
Formerly Camaroc5
 
CamaroC-17's Avatar
 
Drives: 2010 Camaro LT/RS M6
Join Date: May 2010
Location: USA
Posts: 1,657
I am leaving now to get it. 2 hour drive.

Sent from my DROID RAZR HD using Tapatalk 2
CamaroC-17 is offline   Reply With Quote
Old 05-17-2013, 11:01 AM   #53
GretchenGotGrowl


 
GretchenGotGrowl's Avatar
 
Drives: 11 F150 EB/13 Sonic RS/15 Z06
Join Date: Sep 2010
Location: Little Rock, AR
Posts: 7,128
Quote:
Originally Posted by CamaroC-17 View Post
I am leaving now to get it. 2 hour drive.

Sent from my DROID RAZR HD using Tapatalk 2
Good luck man.
__________________
New Ride -- 2015 Z06 2LZ (stock) -- Journal
Old Ride -- 2012 Camaro 2LT/RS (647 RWHP & 726 RWTQ) -- Build Thread
GretchenGotGrowl is offline   Reply With Quote
Old 05-17-2013, 04:26 PM   #54
CamaroC-17
Formerly Camaroc5
 
CamaroC-17's Avatar
 
Drives: 2010 Camaro LT/RS M6
Join Date: May 2010
Location: USA
Posts: 1,657
Got the car. Runs and sounds great! I forgot how good the engine sounds when its not covered up by a loud exhaust. Oil PSI is back to normal. The sound that I thought was a loose heat shield was A bad slave cylinder and throw out barring in the clutch which they found and replaced on their own. They even transferred over my painted valve covers for me. The guy who did the work said its a 2013 LLT. Only thing he didn't do is hook my ZL1 light harness back up to the fuze box. So my lower fogs are not powered right now. They had the car spotless inside and out and did replace the windshield and fixed the radiator fans.

Here's the million dollar question...mod or not to mod. At the least my elite catch can will go back on.


Sent from my DROID RAZR HD using Tapatalk 2
Attached Images
 
CamaroC-17 is offline   Reply With Quote
Old 05-17-2013, 04:28 PM   #55
Goo

 
Goo's Avatar
 
Drives: Cayman S
Join Date: Jun 2011
Location: Silverdale, WA
Posts: 825
Nice
Goo is offline   Reply With Quote
Old 05-17-2013, 05:27 PM   #56
KMPrenger


 
KMPrenger's Avatar
 
Drives: 16 SS Camaro, 06 Colorado
Join Date: May 2009
Location: Jefferson City, Missouri
Posts: 12,032
Quote:
Originally Posted by CamaroC-17 View Post
Got the car. Runs and sounds great! I forgot how good the engine sounds when its not covered up by a loud exhaust. Oil PSI is back to normal. The sound that I thought was a loose heat shield was A bad slave cylinder and throw out barring in the clutch which they found and replaced on their own. They even transferred over my painted valve covers for me. The guy who did the work said its a 2013 LLT. Only thing he didn't do is hook my ZL1 light harness back up to the fuze box. So my lower fogs are not powered right now. They had the car spotless inside and out and did replace the windshield and fixed the radiator fans.

Here's the million dollar question...mod or not to mod. At the least my elite catch can will go back on.


Sent from my DROID RAZR HD using Tapatalk 2
Glad to see it is all taken care of. For me, the million dollar question is if the timing chain issue still exists in your new LLT engine, or if its the same exact design as the 2010 engines.

So before this all began, did you take off the headers and everything before taking it in? I can't remember. That sounds like a lot of work lol.
__________________
2016 Camaro 1SS - 8-speed - NPP - Black bowties
2010 Camaro 1LT V6 (Sold. I will miss her!)
KMPrenger is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:37 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.