Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Cam Motion
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 03-28-2013, 04:34 PM   #1
Mattsmaro
 
Drives: 2010 Chevy Camaro SS/RS L99
Join Date: Mar 2013
Location: Belleville, IL
Posts: 14
2010 SS engine knock

So I am kind of freaking out about this. My Camaro only has 19,000 miles on it. When I start my camaro cold... it has a loud knocking noise and continues to knock until the engine temp. gauge gets over 1/4 of the way up. Should I be worried about this? Is anybody else having this issue? HELP!
Mattsmaro is offline   Reply With Quote
Old 03-28-2013, 04:53 PM   #2
hd48
 
hd48's Avatar
 
Drives: SS2 Rally Yellow Lt Grey Leath
Join Date: Mar 2009
Location: Cape Coral,FL
Posts: 185
Cool Engine Knock

My advise would be to bring it back to the dealer, that is not normal and since the car only has 19000 its a warranty issue, dont let them bullsh-t you Good Luck Let me know how you make out.
hd48 is offline   Reply With Quote
Old 03-28-2013, 05:50 PM   #3
gramps_green_rs
ex-RCAF
 
gramps_green_rs's Avatar
 
Drives: 11 SGM1LTRS SV1000S
Join Date: Mar 2011
Location: Hammond, ont, canada
Posts: 1,055
my Aerostar did that, it had a spun rod bearing. Get it checked.

gramps
__________________
gramps_green_rs is offline   Reply With Quote
Old 03-30-2013, 09:19 AM   #4
Mattsmaro
 
Drives: 2010 Chevy Camaro SS/RS L99
Join Date: Mar 2013
Location: Belleville, IL
Posts: 14
engine knock

Now it only does it every once in awhile. Like she has mood swings or something. I tried to show my friend how it knocks and it wouldn't do it. It has a 5 year-100,000 mile powertrain warranty... so i guess i'm no sweating it too badly.
Mattsmaro is offline   Reply With Quote
Old 03-30-2013, 05:29 PM   #5
2011 SS SLP ZL427
 
2011 SS SLP ZL427's Avatar
 
Drives: 2011 SS ZL427
Join Date: Feb 2013
Location: Drums PA
Posts: 115
Has the dealer done your oil changes or have you done them and if you have done them have you used the specified oil (Mobile 1) for your changes?
__________________
2011 SS SLP ZL427 is offline   Reply With Quote
Old 03-30-2013, 11:28 PM   #6
Mattsmaro
 
Drives: 2010 Chevy Camaro SS/RS L99
Join Date: Mar 2013
Location: Belleville, IL
Posts: 14
I've only had the car for a little over a month and it get's free oil changes for the next 2 years.
Mattsmaro is offline   Reply With Quote
Old 03-31-2013, 08:33 AM   #7
2011 SS SLP ZL427
 
2011 SS SLP ZL427's Avatar
 
Drives: 2011 SS ZL427
Join Date: Feb 2013
Location: Drums PA
Posts: 115
I would take it into the Dealer let them keep it overnight being the engine does this when its cold, see what they have to say and what avenue repair they take.
__________________
2011 SS SLP ZL427 is offline   Reply With Quote
Old 04-05-2013, 08:30 PM   #8
hale95
 
Drives: 2010 White orange rally 2ss
Join Date: Nov 2012
Location: 24630
Posts: 10
Mine did that.... Started it up click click click, got 12 miles down the road the valve spring cylinder 6 snapped and it went from click to bam. Not trying to scare you but a minute at the service station beats a week or 2 in repair shop.
hale95 is offline   Reply With Quote
Old 04-06-2013, 10:02 AM   #9
VOLmanTN
Go Vols!
 
VOLmanTN's Avatar
 
Drives: 2011 Camaro Convertible
Join Date: Feb 2012
Location: SC
Posts: 113
recall for bad lifters on the l99. Could be your issue.
VOLmanTN is offline   Reply With Quote
Old 05-20-2013, 08:57 PM   #10
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,725
Quote:
Originally Posted by Mattsmaro View Post
So I am kind of freaking out about this. My Camaro only has 19,000 miles on it. When I start my camaro cold... it has a loud knocking noise and continues to knock until the engine temp. gauge gets over 1/4 of the way up. Should I be worried about this? Is anybody else having this issue? HELP!
Greetings Mattsmaro,

Are you still experiencing this concern? If so, send me a private message describing what's going on and I can explore how we can get this situation handled.

William R.
Chevrolet Customer Care
Chevrolet Customer Svc is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.