Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
ADM PERFORMANCE
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Camaro ZL1 Forum - ZL1 Specific Topics


Reply
 
Thread Tools
Old 05-22-2013, 06:49 AM   #15
NightmareZL1
Can't stop ***ifying
 
NightmareZL1's Avatar
 
Drives: Ashen 2013 Gray ZL1
Join Date: Dec 2012
Location: Honolulu, HI
Posts: 273
totally, you just can't help but notice that it is different. From slow 10mph turns, to freeway accel, more balls everywhere. It's awesome.
__________________
Rotofab, grinding rear diff sound forever, dealer replaced supercharger - now i have a rattle when starting from a stop, ordered 2.35 lingenfelter pulley, hp tuner, belt, 100mm idler pulley, tr7IX spark plugs, wideband kit, long tubes with no cats...hoping for 650hp. dyno with rotofab = 518hp
NightmareZL1 is offline   Reply With Quote
Old 05-22-2013, 06:55 AM   #16
Rock on
 
Rock on's Avatar
 
Drives: black 2011 2ss
Join Date: Apr 2011
Location: plain city utah
Posts: 237
I felt the same thing until I added high flow cats I think you have to work on both ends to make it breath better
__________________
FASTER THAN A SPEEDING TICKET 2011 cammed 3600 stall 68 cammed 2800 stall
Rock on is offline   Reply With Quote
Old 05-22-2013, 07:05 AM   #17
OldScoolCamaro


 
Drives: Camaro's, always have, always will.
Join Date: Oct 2010
Location: Home of the brave
Posts: 4,851
...possibly the guy with the ZL1 claiming loss of low end power after installing Roto-fab CAI is running on the low octane table.., has too little miles on the motor yet, or has an incorrect instalation with some obstruction or loss of vacuum. From my personal experience there is another issue at hand other than that of a properly running ZL1 with a properlly installed Roto-fab ZL1 CAI to make one say it has a low end problem.
__________________
In Scott We Trust...all others must show proof.
OldScoolCamaro is offline   Reply With Quote
Old 05-22-2013, 07:48 AM   #18
Pappa Joe

 
Pappa Joe's Avatar
 
Drives: Charger/TL1000R/Cobalt/ZL1
Join Date: Sep 2011
Location: Ontario,Canada
Posts: 1,207
Quote:
Originally Posted by OldScoolCamaro View Post
...possibly the guy with the ZL1 claiming loss of low end power after installing Roto-fab CAI is running on the low octane table.., has too little miles on the motor yet, or has an incorrect instalation with some obstruction or loss of vacuum. From my personal experience there is another issue at hand other than that of a properly running ZL1 with a properlly installed Roto-fab ZL1 CAI to make one say it has a low end problem.

I tend to agree I noticed it spins wheels a lot quicker,I have been running 104 from the get go .I found it very noticable not even really pushing it.
Pappa Joe is offline   Reply With Quote
Old 05-22-2013, 08:52 AM   #19
DangerZL1

 
Drives: Accord
Join Date: Oct 2009
Location: Memphis, TN Area
Posts: 1,910
I don't see how you couldn't feel the extra power unless something else is not ideal. The additional airflow allows for more boost which is noticeable throughout the power band. I can understand not feeling the difference in normally aspirated car, but with most of the dynos adding over 30 at the wheels, this should be a butt dyno improvement.
DangerZL1 is offline   Reply With Quote
Old 05-22-2013, 10:10 AM   #20
TripleBlkZL1
 
TripleBlkZL1's Avatar
 
Drives: 13 ZL1, 15 Scat Pack,& 15 Silverado
Join Date: Oct 2012
Location: Chicago, IL
Posts: 621
Quote:
Originally Posted by 2012-1822 View Post

I know California is mentally hilarious, but what is the deal with the 91 octane, have they started banning having fun unless you are a pot head out there?
I was just trying to explain my situation lol
__________________
2013 M6 ZL1.. Mods- Roto-Fab CF Intake, Ported and Polish LS7 TB and Snout, 2.55" Upper Pulley, 100mm Idler Pulley, Solid Isolator, Afco Heat Exchanger with fans, ID850 fuel injectors, SW 2" LT Headers With High Flow Cats, and CMS 91 Octane tune.. 579.8rwhp and 537.4rwtq
TripleBlkZL1 is offline   Reply With Quote
Old 05-22-2013, 12:36 PM   #21
hognutz


 
hognutz's Avatar
 
Drives: 2013 ZL1
Join Date: Oct 2011
Location: tangent or
Posts: 2,978
pull your fuses then do a run with the nannies off.

post in a pic of the install to make sure the tube and maf are oriented correctly.

I did pulley, TB, CAI all at once so in my case it was like I was driving a differnt car. never drove it will just CAI.
__________________
2017 zl1 or GT350 hmmmm
2015 Hellcat-sold
2013 ZL1 -sold
2013 Dart
2013 Megacab 8" lift 38"mt's
hognutz is offline   Reply With Quote
Old 05-22-2013, 04:29 PM   #22
IcePick06
 
IcePick06's Avatar
 
Drives: '12 AGM ZL1; '07 Ducati 1098
Join Date: Oct 2011
Location: Tha OCizzle
Posts: 724
I feel a little bit of extra pull in the upper RPM's when going WOT but for the most part you can't really feel a 25hp increase on a car this heavy. Once you do more mods like a pulley, headers, tune, etc. along with the rotofab you will feel the extra power. I just love the sound of the supercharger whine now when going WOT, especially when outside temps are somewhat cool
__________________
My Toys:

2012 ZL1 Coupe (M6) #80

2012 Nissan Titan
2007 Ducati 1098
2006 Yamaha R6 (Track/Race Only )
IcePick06 is offline   Reply With Quote
Old 05-22-2013, 05:15 PM   #23
htron50


 
htron50's Avatar
 
Drives: 2012 ZL1
Join Date: Feb 2009
Location: SC
Posts: 2,462
It's a great ROI and easily reversible for the purist. I was surprized to see how little air intake ports there are on the stock box after I got it off. So, it certainly gets much more air with the RotoFab.
__________________
2012 CAMARO-ZL1
Sincere Thanks to City Chevrolet, Charlotte, NC http://www.citychevrolet.com/blog/ca...et-camaro-zl1/
htron50 is offline   Reply With Quote
Old 05-22-2013, 05:36 PM   #24
Flea
 
Drives: Camaro ZL1
Join Date: Dec 2012
Location: South Carolina
Posts: 199
I didn't really notice a gain in power with the Roto-Fab install, but I absolutely love the sound of the supercharger whine. I was a little disappointed that I couldn't hear the supercharger very much when I got the car, but now I'm even more in love with car because of that sound. I didn't feel any loss of power, though.
__________________
Flea is offline   Reply With Quote
Old 05-22-2013, 09:36 PM   #25
Mil
 
Drives: 2013 Victory Red w/ automatic #671
Join Date: Jun 2012
Location: The Bat Cave
Posts: 243
Quote:
Originally Posted by Whos_Drivin View Post
What mode are you driving in? The torque management may be kicking in.
nannies off/ traction control off. Anyway .. guess i should have done my homework before deciding on this mod.. Now i have a head turning super charged air sucking machine that screams under the hood when i exhilarate, but it is now not as fun taking off from dead stop w/ less torque.

I have read that with a CAI mod for most cars it seems to be normal that low in power/torque is compromised .. but the gains are pushed towards the upper rpm range which is basically only a benefit for track driving.
Mil is offline   Reply With Quote
Old 05-22-2013, 09:55 PM   #26
Mil
 
Drives: 2013 Victory Red w/ automatic #671
Join Date: Jun 2012
Location: The Bat Cave
Posts: 243
I've ran nothing but 93 octane since the day i took delivery. My ZL1 was ordered, it wasn't purchased off the lot. Just to be sure and out of curiosity I done the fuse pull way before i've done any mods. I didn't experience any difference from the fuse pull so I guessed I were the lucky few that actually took delivery of my ZL1 with the proper 93 octane. I have up to 4,500 miles logged. I had all my traction assists off. I went back to check and made sure all my hoses related to this mod are on tight.. they were fine so still puzzled how some are claiming increase on all ranges of the rpm. Anyway its a pretty simple mod.. i don't see how i could mess it up.. I'll post pictures some point over the weekend for those who suggessted it.. so you could see if i messed it up or not.
Mil is offline   Reply With Quote
Old 05-23-2013, 08:05 AM   #27
Enough
 
Drives: 2013ZL1
Join Date: Jul 2012
Location: Northern California
Posts: 94
Give it some time (couple of weeks) for the car to self adjust your fuel trims. This flat is normal for adding something which adds more air and creates a slightly different flow path over the MAF sensor. I felt the same right off idle low end flat spot and it corrected itself over time.
Enough is offline   Reply With Quote
Old 05-23-2013, 12:21 PM   #28
hognutz


 
hognutz's Avatar
 
Drives: 2013 ZL1
Join Date: Oct 2011
Location: tangent or
Posts: 2,978
Quote:
Originally Posted by Mil View Post
I've ran nothing but 93 octane since the day i took delivery. My ZL1 was ordered, it wasn't purchased off the lot. Just to be sure and out of curiosity I done the fuse pull way before i've done any mods. I didn't experience any difference from the fuse pull so I guessed I were the lucky few that actually took delivery of my ZL1 with the proper 93 octane. I have up to 4,500 miles logged. I had all my traction assists off. I went back to check and made sure all my hoses related to this mod are on tight.. they were fine so still puzzled how some are claiming increase on all ranges of the rpm. Anyway its a pretty simple mod.. i don't see how i could mess it up.. I'll post pictures some point over the weekend for those who suggessted it.. so you could see if i messed it up or not.

I took delivery of my ordered car with 8 miles on it and ran nothing but premium. The fuse pull woke mine up for sure. even my wife noticed it.

just make sure you pulled both fuses and they were the right number. I thought the fuse pull was BS until I did it. Now some say it does nothing but on my car it was noticable. this was even before mods.

need to get on a dyno or at least datalog the car. right now it is all speculative posts. The butt dyno is not calibrated very well.

to people who say 25hp is not noticable it disagree you should be able to feel 25hp. so if you don't it is either some kind of wied misconception IE the power is just even more linear not and is fooling you or you maf transfer function went off for soem reason and you running rich robbing power.
__________________
2017 zl1 or GT350 hmmmm
2015 Hellcat-sold
2013 ZL1 -sold
2013 Dart
2013 Megacab 8" lift 38"mt's
hognutz is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:08 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.