Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
ADM PERFORMANCE
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 05-27-2013, 03:48 AM   #1
mlefev
 
Drives: 2010 Camaro
Join Date: Oct 2011
Location: California
Posts: 6
Compass in display doing strange things?

I hope this the correct area for my question...

I just noticed this today. My compass in the center display is being really strange. This happened after a couple of weeks ago when i got an airbag service message, then a stabilitrak service message. i haven't seen the messages since, and there are no service lights on.

Now on to the compass...Instead of N for North it displays NO. Instead of E it displays O. South is still S and West fluctuates from WO to W. any ideas? Could it be an electrical problem?
mlefev is offline   Reply With Quote
Old 05-27-2013, 11:49 AM   #2
juandavr
 
Drives: Camaro 2LT/RS
Join Date: Dec 2012
Location: Medellin, Colombia
Posts: 88
Maybe a language problem? because West in spanish is Oeste, so when you are heading Northwest, in spanish would be Nor-Oeste or NO
juandavr is offline   Reply With Quote
Old 05-27-2013, 04:33 PM   #3
Rock-It Man
376 cubic inches of fun
 
Rock-It Man's Avatar
 
Drives: 2010 Camaro 2SS A6
Join Date: Jul 2010
Location: MA
Posts: 1,063
Did the compass problem start on May 5th?
Rock-It Man is offline   Reply With Quote
Old 05-28-2013, 07:36 AM   #4
Rizzo
 
Drives: 2010 Camaro SIM 2SS/RS
Join Date: Sep 2008
Location: San Antonio, TX
Posts: 424
Quote:
Originally Posted by Rock-It Man View Post
Did the compass problem start on May 5th?
Oh...I see what you did there.

__________________
========================
Rizzo is offline   Reply With Quote
Old 05-28-2013, 12:25 PM   #5
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,613
Quote:
Originally Posted by mlefev View Post
I hope this the correct area for my question...

I just noticed this today. My compass in the center display is being really strange. This happened after a couple of weeks ago when i got an airbag service message, then a stabilitrak service message. i haven't seen the messages since, and there are no service lights on.

Now on to the compass...Instead of N for North it displays NO. Instead of E it displays O. South is still S and West fluctuates from WO to W. any ideas? Could it be an electrical problem?
Hello mlefev,

Sorry you're having some issue's with your compass and center display. Could you private message me your VIN and current mileage? I will look into your issue further for you.

Reggie B.
Chevrolet Customer Care
Chevrolet Customer Svc is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.