Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
JUICEDMOTORSPORTS
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Camaro ZL1 Forum - ZL1 Specific Topics > Engine | Exhaust | Bolt-On | Drivetrain Modifications


Reply
 
Thread Tools
Old 06-03-2013, 07:17 PM   #57
RabbitCTSV
 
Drives: 2009 Ctsv
Join Date: Jun 2013
Location: Houston
Posts: 5
Quote:
Originally Posted by 900+CTSV View Post
Rabbit, Didn't your motor blow up?
Unfortunately I was one of the guys that dealt with Keith and bought a Whipple.
Sorry to hear about you whipple. What happened ?
RabbitCTSV is offline   Reply With Quote
Old 06-04-2013, 01:47 PM   #58
ZL1terminator
 
ZL1terminator's Avatar
 
Drives: Pearl white, 2010 Premium GTR
Join Date: May 2012
Location: Alberta
Posts: 103
I don't have KDI whipple setup but I have heat exchanger, and cam from them and I have only been all to happy with the customer service! Still sorry to hear about that happening to you guys, and you can say what you want from your own experience with KDI! But I am just giving my 2 cents dealing with them!
ZL1terminator is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:01 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.