Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
BeckyD@RodgersChevrolet
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6)


Closed Thread
 
Thread Tools
Old 06-07-2013, 02:44 PM   #1
The 2010 Sin
weaponsinc.com
 
The 2010 Sin's Avatar
 
Drives: 2014 Lifted 1500, 2013 2SS CRT
Join Date: Feb 2010
Location: Tulsa, Oklahoma
Posts: 2,864
Clutch Review: Out w/ Monster in w/ the Slayer

This is my 10,000 mile review:

Previously installed in my 2010 Camaro full bolt on heads and cammed LS3 I had the Monster Stage 3 single disc capable of 700hp/tq. I was having problems blowing out master cylinder after master cylinder (4 to be exact) tried the lingenfelter clutch return spring and the braided line between the slave and the master. Still no dice. I was told by several employees at monster that I do not know how to drive the car at 3,500 miles of squealing like a pig and shuddering so bad it was embarrassing to drive I decided to call it quits and work with the guys at http://www.hendrix-engineering.com/

When we pulled the transmission and looked at the monster clutch the blades that come off were totally bare metal on metal in a few areas *losing all of its contact patch between clutch disc and the flywheel.* We and all of us at Jim Glover Chevrolet were completely dumbfounded. The shim, the flywheel and the clutch was all installed properly and double checked for anything being loose before we pulled it apart and removed it.

We un-boxed the Hendrix engineering street slayer billet twin carbon and they were excited. Finally a clutch that looked the part. (the install tech was a little concerned about it being a strapless design but he followed the instructions to a T and did it right.)

First drive was unbelieveable! MY CAR MOVES WITHOUT SQUEAKING OR SHUDDERING! I dont have to "LEARN HOW TO DRIVE MY CAR" either.

After the first oil change at 3,500 miles I also changed my clutch fluid and it was super clean but did it anyway just to prevent issues down the road.

I find it crazy that this clutch capable of holding 800RWHP drives easier with a smoother engagement and no shudder or squeal driven normally. I even removed and sold the clutch return spring which is no longer needed and I have not had the need to replace my Master Cyl. after 10,000 miles of driving on this gorgeously performing clutch.

Bravo http://www.hendrix-engineering.com/ You've done a bang up job on this one.. (You kicked the little monster in bell housing!)


So the moral of the story is save your money and spend it properly on a unit that is made for the car not shimmed out from GTO specs.


I have over $1,500 from that monster that i'll never get back. (Clutch, install, master cyls x 4 and slave) My loss will hopefully be your gain!!!!
__________________
The 2010 Sin is offline  
Old 06-07-2013, 06:03 PM   #2
blufin

 
blufin's Avatar
 
Drives: Fire Engine
Join Date: Oct 2008
Location: WPB, Florida
Posts: 1,407
I went with the Street Slayer twin carbon when my stock clutch gave out after several hundred passes at the drag strip. I couldn't be happier with the street manors and how it performs on the strip. Even when new, the stock clutch would get hot and smell terrible after a few launches. The Street Slayer has never smelled after a full night of racing. The engagement/disengagemet is smooth like butter and holds tons of torque.
__________________
12.618 @ 110.75 Bone Stock 1/4 mile
8.165 @ 86.52 Bone Stock 1/8 mile
11.189 @ 124.44 on a 1.73 60' TVS2300 3.4 pulley, JRE tuned, Kooks LT headers and HF cats, MBRP catback exhaust, CAI intake, ADM scoop. Stock wheels/tires.
Sold
blufin is offline  
Old 06-07-2013, 06:45 PM   #3
jamesr
 
jamesr's Avatar
 
Drives: 2012 Camaro ss
Join Date: Nov 2012
Location: Topeka,Kansas
Posts: 130
Yea going through same stuff with my level 2 twin monster only have 550 miles on clutch they want me to send it back so they can measure everything shutters bad i 3rd &4th has no free travel .G to measure most likely need to take so off the adapter but may change to a street slayer just have to get it out next week.
jamesr is offline  
Old 06-07-2013, 07:29 PM   #4
The 2010 Sin
weaponsinc.com
 
The 2010 Sin's Avatar
 
Drives: 2014 Lifted 1500, 2013 2SS CRT
Join Date: Feb 2010
Location: Tulsa, Oklahoma
Posts: 2,864
I'm sorry to hear you're going through the monster issues.. Save yourself and dont waste money trying to reinstall one. They always want you to spend $500 labor to have them send you another turd to put in the bell housing.
__________________
The 2010 Sin is offline  
Old 06-07-2013, 07:41 PM   #5
jamesr
 
jamesr's Avatar
 
Drives: 2012 Camaro ss
Join Date: Nov 2012
Location: Topeka,Kansas
Posts: 130
Sin you race Tulsa I use to run MAKO about 5 years ago
jamesr is offline  
Old 06-07-2013, 08:57 PM   #6
The 2010 Sin
weaponsinc.com
 
The 2010 Sin's Avatar
 
Drives: 2014 Lifted 1500, 2013 2SS CRT
Join Date: Feb 2010
Location: Tulsa, Oklahoma
Posts: 2,864
No i dont race in Tulsa, I'm married to my job nowdays. :-/ use to run Club/SCCA racing at hallett road course.
__________________
The 2010 Sin is offline  
Old 06-07-2013, 08:58 PM   #7
The 2010 Sin
weaponsinc.com
 
The 2010 Sin's Avatar
 
Drives: 2014 Lifted 1500, 2013 2SS CRT
Join Date: Feb 2010
Location: Tulsa, Oklahoma
Posts: 2,864
Quote:
Originally Posted by jamesr View Post
Sin you race Tulsa I use to run MAKO about 5 years ago
That was with Turner Motorsports/BMW
__________________
The 2010 Sin is offline  
Old 06-08-2013, 12:07 AM   #8
yotaman96


 
yotaman96's Avatar
 
Drives: 2010 Camaro SS, 2000 Trans Am WS6
Join Date: Jul 2008
Location: Portland, TN
Posts: 2,701
I have the Street Slayer twin carbon as well. Mine's not as pretty as the newer ones, but so far, it works great.
__________________
2010 IOM Camaro 2SS/RS manual trans
Magnacharged 2000 Trans Am WS6 manual trans
2015 Ram Crew Cab Cummins
yotaman96 is offline  
Old 06-08-2013, 08:12 AM   #9
quincy speeder
 
Drives: 2011 Camaro SS
Join Date: Sep 2012
Location: Quincy.Ma
Posts: 202
Good write up.

I had similar problems with the monster. Clutch is junk.
__________________
2010 SS, 230 Cam, ARH headers,Airaid intake, 160 t-stat,3.90 gears 475hp/430tq. -old setup
added- Procharger F1-D, alky control,FIC 96lb,fuel system- 810hp/735tq- 10.3 at 136mph , 1.75 60'. see how long it lasts.
Thanks to Slowhawk Performance.

2008 C6, 427ci,YSI,mcleod clutch,Alky control, built tranny, custom fuel system. 985rwhp, best 1/4 -9.4 at 152mph. still trying to get the shifting down:(
quincy speeder is offline  
Old 06-08-2013, 10:46 AM   #10
GLGJR
 
Drives: 09 CTS-V
Join Date: Feb 2010
Location: North Texas
Posts: 22
Where is the "Like" button?
GLGJR is offline  
Old 06-08-2013, 10:50 AM   #11
dekan513
chevy pride
 
dekan513's Avatar
 
Drives: 2ss/rs
Join Date: Feb 2012
Location: pikeville ky
Posts: 2,138
monsters seem to alway have problems unless u get in the twins. but street slayer and rxt is wht u hear nothing but good things about . glad u can enjoy ur car now .
__________________

check out ky speeds fb page https://www.facebook.com/kyspeed
dekan513 is offline  
Old 06-09-2013, 10:45 AM   #12
The 2010 Sin
weaponsinc.com
 
The 2010 Sin's Avatar
 
Drives: 2014 Lifted 1500, 2013 2SS CRT
Join Date: Feb 2010
Location: Tulsa, Oklahoma
Posts: 2,864
above shows someone is having an issue with the monster twin! They need to stick to gto's
__________________
The 2010 Sin is offline  
Old 06-10-2013, 02:58 PM   #13
The 2010 Sin
weaponsinc.com
 
The 2010 Sin's Avatar
 
Drives: 2014 Lifted 1500, 2013 2SS CRT
Join Date: Feb 2010
Location: Tulsa, Oklahoma
Posts: 2,864
anyone else have any issues with the monsters like I did?
__________________
The 2010 Sin is offline  
Old 06-10-2013, 05:22 PM   #14
mp51998

 
mp51998's Avatar
 
Drives: Black 2011 2SS/RS
Join Date: May 2011
Location: S. Texas
Posts: 1,837
I did in the wifes car but it was a single. I was told I needed to learn how to drive it correctly as well. Kept it about a month then put the stocker back in. I have a Mantic 9000 twin in my car for about 3k miles and so far no problems. I won't buy another Monster clutch.

Last edited by mp51998; 06-10-2013 at 10:57 PM.
mp51998 is offline  
 
Closed Thread

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:29 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.