Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Anthony @ LG Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V6 LLT Engine, Exhaust, and Bolt-Ons


Reply
 
Thread Tools
Old 06-09-2013, 08:25 AM   #43
Angrybird 12
Retired, Cancer Survivor
 
Angrybird 12's Avatar
 
Drives: 12 CAMARO, 15 Impala, 07 Colorado
Join Date: Dec 2007
Location: East Tennessee
Posts: 20,968
Quote:
Originally Posted by The Magic Man View Post
Man, my engine didnt fail but currently at dealership for spun bearing and crankshaft replacement. They are covering under warranty but did try and blame the lack of oil on the catch can. I'm at 20K miles and had the oil changed (by a different dealer) at about 16K. I hope I dont experience any lack of power once I get it back. Keep us posted
Lack of oil because of the catch can? Did they say how? Any oil that the catch can gets would have been burnt up anyway (or deposited on the valves and turned into carbon deposits which is worse) in the engine and not returned to the oil system.
__________________
Cancer's a bitch! Enjoy life while you can! LIVE, LOVE, DRIVE...CAMARO!

The Bird is the word!
Angrybird 12 is offline   Reply With Quote
Old 06-09-2013, 08:43 AM   #44
GretchenGotGrowl


 
GretchenGotGrowl's Avatar
 
Drives: 11 F150 EB/13 Sonic RS/15 Z06
Join Date: Sep 2010
Location: Little Rock, AR
Posts: 7,133
Man, you were more patient than most would be. Congrats on the new car. I'll keep my fingers crossed that this one is trouble free for as long as you own it.
__________________
New Ride -- 2015 Z06 2LZ (stock) -- Journal
Old Ride -- 2012 Camaro 2LT/RS (647 RWHP & 726 RWTQ) -- Build Thread
GretchenGotGrowl is offline   Reply With Quote
Old 06-09-2013, 12:34 PM   #45
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 9,234
Quote:
Originally Posted by Ocx View Post
Update:

Took the car back to the dealership, took a ride with the Service Manager. He drove the first round, I went with him. He noticed nothing wrong. My turn to drive, I demonstrated that it will not break loose or show any noticeable aggressiveness out of 1st with TC,etc. disabled. I even tried to brake torque to do a burnout....nothing.

This was on friday before Memorial day weekend.

Today I traded in my car to a different dealership and drove off with a 2013 2SS/RS everything except navigation. My "old" car was a 1LT RS. No more.

And the rest was history...
Greetings Ocx,

Sorry to hear about the prior experiences, but congrats on the 2SS! I know you're going to enjoy it. Let us know if you have any questions anytime.

All the best,

William R.
Chevrolet Customer Care
Chevrolet Customer Svc is online now   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:51 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.